Strange Pixelated Artifacts Appearing in Denoise Processed Photos

New to both Denoise and AI Sharpen. On testing Denoise, all photos are exhibiting strange pixelated squares in renders. They appear in different parts of each photo. After multiple attempts to render a clean shot, only one in ten turns out without issues. What is going on?

Mode: Standard
Remove Noise - 30
Enhance Sharpness - 1

Please go to Help, Graphics info and press Copy then post the info here. Make sure your PC meets the technical requirements.

Application & Version: Topaz DeNoise AI Version 3.7.0

Operating System: macOS 12.4

Graphics Hardware: AMD Radeon Pro 580X OpenGL Engine

OpenGL Driver: 4.1 ATI-4.8.54

CPU RAM: 8192 MB

Video RAM: 2047 MB

Preview Limit: 4492 Pixels

Thank you.

Hi, you will need to raise a support request at the main website.

Already did using the main contact link at the bottom of Topaz Lab’s website. If there is another process to do so, please advise as i could not find it. Only saw published help guides not specific to this issue.

I have also the same problem. The macOS is 12.5. The rest of the configuration is essentially the same. Very annoying.


This was the suggestion from Topaz support to eliminate the error. It did indeed work. I have seen no errors since making these adjustments under the Preferences > Processing tab.
Switch the processor to AMD Radeon, and the memory consumption to Low.
They admitted this is a bug affecting Mac-OS systems. Hope this helps and I hope they officially respond here.

1 Like