Sharpen AI v4.0

v4.0.2
Released February 24th, 2022

Windows: Online | Full
Mac: Full

SPECIAL UPDATE INSTRUCTIONS

  • If experiencing conflicts with the in-app updater, please manually download the installer linked above.
  • This version of Sharpen AI requires MacOS 10.14 or Windows 10 (or higher). It is not supported on MacOS 10.13 or Windows 7/8.
  • If you use Sharpen AI as a plugin to Photoshop or Lightroom Classic on Mac, once you install this update, please do the following:
    1. Quit Photoshop and/or Lightroom Classic completely.
    2. Sharpen AI should open by itself after installing the update. Your plugin configurations should now be reset. Follow any prompts displayed relating to installing plugins.

Changes

  • Fixed processing error when using Standard model on machines with older CPUs(that don’t support AVX instruction sets)
  • Opening Sharpen in standalone after moving it on Mac will automatically update the lightroom template with the new path
  • Fixed issues with auto model suggesting versions of models that aren’t compatible with the current version of Sharpen

v4.0.1
Released February 17th, 2022

Windows: Online | Full
Mac: Full

Changes

  • Improved update dialog - now clarifies between owned and unowned updates
  • Added “Select All” hotkey (Ctrl/Cmd + A)
  • Improved performance for M1 macs with 8GB of RAM
  • Fixed plugin/standalone taking long time after pressing “cancel” to actually close
  • Fixed “Canceled” appearing in file list view while processing
  • Fixed files that have previously been canceled not processing the next time images are being saved
  • Fixed scrollbars disappearing while being held down
  • Fixed OpenGL models not loading correctly
  • Fixed in app updater getting stuck at 100% (updating to 4.0.1 may still fail)
  • Fixed “Apply” and “Cancel” buttons being non-functional sometimes

v4.0.0
Released February 15th, 2022

Windows: Online | Full
Mac: Full

Changes

  • Native M1 support
  • New “Standard” AI model
  • New installation flow for mac
  • New theme for the app
  • Improved logic for choosing AI Model automatically
  • Added ability to use eraser end of tablet stylus to erase mask

Fixes

  • Fixed batch processing not completing successfully when using auto masks that haven’t been processed yet
  • Fixed issues arising from changing auto mask model or selecting refine, while an auto mask is already running-
  • Fixed zooming in/out not enabling the update preview button
  • Fixed mask overlay sometimes not appearing until the preview is updated
  • Fixed crash with certain Nvidia GPUs.
  • Fixed “foggy” results on windows computers using intel GPU to process, on “Normal” variants of models
  • Fixed recommended model being stuck on “Detecting…” on small images (<128px in either dimension)
  • Fixed various UI elements of file list getting reset when scrolling a lot (such as time taken to process image)
  • Fixed crash when applying watermark to very small images
  • Fixed a couple hotkeys and UI elements appearing in External and Plugin mode, when they should only apply to Standalone
6 Likes

On my M1 Mac, v4 installed directly into the Applications folder. Since v3.3.6 was in a Topaz Labs LLC folder within that, I had to manually uninstall it.
So far so good and it is working as a plug-in to On1 PhotoRaw 2022.

2 Likes

I installed Sharpen AI 4.0 on my 24" iMac w/M1 chip. I dragged and dropped the icon into my Applications Folder. Then I double clicked on the icon. Rather than the application opening, I got that same dialog instructing me to install it by dragging and dropping the icon into the Applications Folder. I went through the entire process several times, but I never got the application to open. What should I do?

Thanks, Jack

Installed and runs fine as standalone or LrC/ PS plug-in. Initial tests suggest around 25% speed boost (Motion Blur - Very Blurry). New Standard Model looks interesting too - nice upgrade! (MacBook Pro M1 Max 32-Core GPU 32GB URAM 1TB SSD, macOS Monterey 12.1, LrC 11.2, PS 23.2). So far, so good…

1 Like

I cannot download thru app or from this page. What’s the next step?

Running Mac OS 12.2 on iMac 4.2 GHz Quad-Core Intel Core i7. Update install from App failed, so I downloaded from he link on this page. Uninstalled v3.6, drug v4 into the apps folder. Launching v4 but it refuses to activate but it presented no errors. - I figured maybe I had the wrong password, so I reset it here and tried again: still wouldn’t activate after several attempts. It stays in trial mode. I tried launching the app via Edit in Lightroom, but it would not run. A shame: I had similar problems with v3.3 which I resolved with v3.6. Looks like I need to try and go back to v3.6 if I can find it to download it. Sorry to say that it seems that this app is devolving. (Having other headaches like changes applied in modes e.g. increasing blur or noise reduction, do not execute. I’m stuck with the default options presented.)

3 Likes

All my apps were stalling/freezing in standalone mode in their latest versions, not used in a while. Reinstalled all and only Sharpen AI has issues, freezes when I try to load an image in standalone. Windows 11. Works well from within LRC.

After dragging the app into the Applications folder, you can close that window and open the program directly from the Applications folder or through Launchpad.

Sorry to say that but it sucks that with every new release the destination install folder changes!

4 Likes

I have tried that several times. However when I double click on the Sharpen AI app to open it, all I get is that dialog about dragging and dropping to install it.

2 Likes

I have a Mac Book Pro 2021 M! MAX with 32GB running MacOs 12.1. I use Sharpen AI as a plugin from Photoshop v23.1.1.

I have this issue. After using Sharpen AI Photoshop frequently freezes showing a window that says “You are invoking a Topaz…”. I had this issue with Sharpen AI v3.5.5 and I still have it with v4.

Any suggestion would be appreciated.

This like the latest Gigapixel has NOT been a good experience for me. I rolled back Gigapixel to it’s previous version as the latest still crashes as does this Sharpen 4.0. Your team is working with me but even the most recent 4.0-rc2 is no better. loads the profiles now but crashes when executing. Ugh.

Works fine for me - can’t reproduce that issue

Very excited to try this!

On a side note, I suggest that the product release forums be split into PC and MAC sub forums, so all the MAC complaints can be neatly grouped :grin:

8 Likes

I tried a few Sony raw and Drone JPG files and it worked ok but the issue I had was with a DNG file and I tried several. These were large 48Mpx DNG drone pictures. Try a DNG file if you have one.

The app works fine on my Intel MacBook Pro with Monterey. Solid release, thank you!

1 Like

download the installer on top of this page.

No issue for me with DNGs. I tried some older ones that had been converted when I imported them to LR, as well as some created more recently.
Mac mini M1.

That annoying re-update in plugin mode is still happening.

  • switch to plugin;
  • Topaz starts to update sharpening;
  • completes sharpening;
  • restarts the entire update process.

So the update occurs twice, each time.

No probs installing on my Mac Mini and M1 Macbook Pro. Deleted V3 first
NOW HOW ABOUT THAT PLUGIN FOR APPLE PHOTOS???