Sharpen AI v3.0

v3.0.3
Release April 6, 2021

Windows: Online | Full (Win 10) | Full Legacy (Win7/8)
Mac: Online | Full

Features

  • Improved AI engine performance over v3.0.2

Fixes

  • Error saving while resizing window
  • Processed image does not save back from app to host editor
  • Preview / Saving processing failure to start/finish
  • Crash on host editor after clicking “Apply”
  • Crashes on Windows with certain hardware
  • Crash on Mac machines with certain hardware
  • Errors when saving images under specific conditions
  • “All GPUs (Experimental)” option not actually showing up in 3.0.2

v3.0.2
Release April 1st, 2021

Windows: Online | Full (Win 10) | Full Legacy (Win7/8)
Mac: Online | Full

Fixes

  • Fixed more performance degradations and crashes on specific hardware and operating system configurations
  • Fixed in-app updates not working if you weren’t logged in
  • Fixed error when saving images
  • Fixed issue with loading RAW files
  • Disabled zoom and view buttons while saving images
  • Added ability for logs to be attached to crash reports for easier debugging
  • Re-added the “All GPUs” option as “All GPUs (Experimental)” and removed it from the default setting
    • This is due to stability issues on some computers
  • Minor graphical improvements to version text and preferences dialog

v3.0.1
Release March 30th, 2021

Windows: Online | Full (Win 10) | Full Legacy (Win7/8)
Mac: Online | Full

Fixes

  • Fixed several crashes on specific hardware and operating system configurations
  • Fixed several processing errors on specific hardware and operating system configurations
  • Fixed several performance degradations on specific hardware and operating system configurations
  • Fixed processing error caused by the Normal/Very Noisy/Very Blurry setting being in an invalid state
  • Fixed memory leak when opening and processing several files on Mac
  • Fixed changing certain settings not cancelling the current preview generation if auto-update preview was turned off
  • Fixed lens correction issue causing misalignment between the original and preview images
  • Fixed mask thumbnail appearing blank or incorrect after saving mask until preview is generated
  • Fixed minor performance issue with status indicators
  • Potentially fixed aliasing issue while previewing

Changes

  • Improved Processing Error message to include help for updating graphics drivers
  • Disabled opening images while in masking mode
  • Hid view dropdown while in masking mode
  • Removed “All GPUs” option from AI Processor

v3.0.0
Release March 24th, 2021

Windows: Online | Full (Win 10) | Full Legacy (Win7/8)
Mac: Online | Full

Major Changes:

  • Completely new AI engine
  • New Very Blurry specialty added
    • Extra noise suppression specialty renamed to “Very Noisy”
  • Changed CPU/GPU options in preferences
  • Windows Full Installers come with a “Legacy” version
    – This is for people running Windows 8.1 or lower
    – Windows 10 will continue with the normal installers
    – Online installer will download components based on the OS it’s run on
  • Changed how trial flow works
    – Trials are now gone, you can now use the app without being logged in
    – While not logged in, or if your license is expired, your image will save with a watermark
    – Users who own the product should be able to use it offline without a watermark given they’ve logged in once and don’t log out
    – If your license is expired, you can still use any version released before the license expired without watermarks (including any bug patches released for that version, even if they come out after the license expired)
  • Updated the preview panel experience
    – Previews no longer block panning, zooming, or switching images
    – Auto update preview is now on by default and moved to the preferences panel
    – Updating preview while auto update is turned off moved to top bar “Preview” button
    – Adds scroll to zoom
  • Updated image and RAW libraries to their latest versions
    – Biggest update is the additional/fixed CR3 support in libraw (change log 26)

Fixes:

  • Fixed first install not setting the opening directory correctly
  • Fixed masking button being pushed over to the left
  • Fixed masking button disappearing when cancelling a save
  • Fixed login dialog allowing spaces in email and password
  • Fixed some visual issues with saving in batch
  • Fixed non-ASCII characters in path breaking RAW file loading
  • Fixed blank Save Options section showing in preferences while in plugin/external mode
  • Fixed Lightroom saving back as the wrong color profile

Changes:

  • Comparison view will now process all unprocessed previews when in manual update mode
  • Changed “Switch Users” option to Login and Logout depending on if you’re logged in or not
  • Changed image importing so that new images get selected instead of just being added to the file list
  • Changed minimum window size to 1080x580
  • Changed combo box design
    – (Drop down GPU/CPU selector in Preferences is an example)
  • Added watermark warning dialog if saving an image that would have a watermark applied
  • Added License Info dialog under Account menu
  • Added right panel from Gigapixel when saving
  • Added cleanup methods to the installer
    – Should clean out the TGRC folder on Mac and Windows
    – Additionally should remove some large unused dll files on Windows (CUDA, ~750MB)
  • Removed some unused libraries to save space
  • Removed product tour as it no longer aligned with the application
3 Likes

The download links don’t appear to be working:

Fixed! You can try it again now.

1 Like

That worked! Thanks.

Topaz Sharpen AI 3.0.0.

Needs to be fixed: big squares in preview.

I checked just to see if by some fluke it would run on a GPU-less machine, but as I expected, it doesn’t. Same problem as Denoise AI 3.x: https://community.topazlabs.com/t/denoise-3-0-2/21242/121

Running Windows 10 Pro x64 2004.

It shows a blank white window for less than a second and exits immediately. According to an x64dbg log, it loads the DirectX Software Renderer (d3d10warp.dll) and immediately unloads it 4 different times. The log ends with a C0000005 access violation.

A similar problem existed with Video Enhance AI 1.7.1 and was fixed in version 1.8.0. The latest beta of VEAI continues to run on the same system using the DirectX Software Renderer for the UI. OpenVINO works well.

IMHO if you’re going to support OpenVINO then you should support GPU-less machines, otherwise there’s not much point to using OpenVINO if a GPU is required to run.

UPDATE

Guess what…

I GOT IT TO WORK.

I made the incorrect assumption that you are using the DirectX 12 Software Renderer for Windows 10.

But you’re not. You’re still using OpenGL.

topaz_opengl

So, it simply means that it needs to use the same setup that it always has on Windows 10. It needs MESA copied into the application directory. It also no longer calibrates… the user needs to go into Advanced Settings and change the AI Processor to CPU. It will then work for OpenVINO on GPU-less machines.

I am EXTREMELTY SORRY I wasted your time with this. All I needed to do was set it up like I always have in the past, on Windows 10.

 
Just to document it, here are the full steps:

 
𝟣. The following environment variables MUST be set:

Right Click “This PC” or “My Computer” on Desktop -> Properties -> Advanced System Settings -> Environment Variables -> New

First Variable Name: MESA_GL_VERSION_OVERRIDE
First Variable Value: 4.2COMPAT

Second Variable Name: MESA_GLSL_VERSION_OVERRIDE
Second Variable Value: 420

Set the above two variables for BOTH User AND System.

Reboot.

 
2. Download Mesa.

At the time of this writing I downloaded mesa3d-20.3.4-release-mingw.7z. (Later versions have issues with missing Vulcan dll files, so it’s recommended to avoid them for non Vulcan applications until they have those issues fixed. I recommend 20.3.4; earlier versions should also work.)

Extract the file. Install and use the freeware 7zip application to do so, if you need it.

You only want two files from the archive: x64\opengl32.dll and x64\libglapi.dll. Copy these into the Topaz application directory. So for Sharpen AI, copy them to C:\Program Files\Topaz Labs LLC\Topaz Sharpen AI, if you used the default install location.

 
3. Run the application (Topaz Sharpen AI), it should now load and use the MESA llvmpipe software renderer. You can confirm by going to “Help” -> “Graphics Info”. It should look like the above screenshot, and show that it’s using llvmpipe.

 
4. It appears that newer Topaz applications no longer run “calibration”. They’re set to use GPU by default. If there’s no GPU, then the application will just exit when the preview tries to run. If the preview is set to “auto” (which it is by default) then that means it will happen as soon as an image is loaded. So you need to go to “File” -> “Preferences” and set “AI Processor” to “CPU”.

 
𝟧. The Topaz application should now run on a GPU-less workstation, as well as a VM/VPS.

 
I haven’t checked everything yet, but it’s working for Sharpen AI and Denoise AI. I believe it will work for all other Topaz Applications except Video Enhance AI, which should run immediately after installing without needing to copy files into the application directory. I haven’t tested to see if not having the above environment variables (MESA_GL_VERSION_OVERRIDE / MESA_GLSL_VERSION_OVERRIDE) makes a difference for VEAI, but I don’t think that it does.

There are some versions of Topaz Applications (again I haven’t checked everything obviously) that run without needing Mesa files copied into the application directory. Denoise AI 2.4.x and 3.0.0 “Legacy” on Windows 7 are like this. They use an old version of llvmpipe (5.0) which appears to be built in. I’m not certain in these cases if environment variables need to be set (MESA_GL_VERSION_OVERRIDE to 4.2COMPAT and MESA_GLSL_VERSION_OVERRIDE to 420), but I suspect that they do. I haven’t tried removing them and then installing and running Denoise AI 2.4.x or 3.0.0 “Legacy”.

Again, I’m VERY sorry for anyone’s time I may have wasted with my incorrect assumptions about Topaz applications using the DirectX Software Renderer.

1 Like

I couldn’t get it to load!

1 Like

Upgraded to 3.0.0. tonight. It loads fine but when I try to use it, it crashes as soon as I go to update the preview. It leaves the small screen and I have to press esc to get rid of the popup. I have downgraded back to 2.2.4 and that version still works fine. I have tried it direct from the program and from Photoshop but it does the same. Running W10 on Intel i5.

10 Likes

Download link not working!

Does not appear to support hyper-threading on Mac. I use a 10 core iMac which gives me 20 hyperthreaded cores. When using CPU only seems to be using 10 of the available 20 cores. Now really slow in CPU mode. VIdeo card performance seems to have improved but still doesn’t seem as fast as previous versions when using 20 cores!

1 Like

Just updated to 3. Program froze when I went to quit. Subsequent launches cause it to crash on auto preview. MacOS 10.14.6.

3 Likes

V3.0 crash appears to be something to do with the AI Processor selection in Preferences. If i leave it with the auto select of the Intel® 530 Graphics Display Adapter it crashes. Change to CPU and it works, except that it is very slow updating indeed.

This new Update is pure garbage. It makes Halos around edges like Photoshop does. Also sharpening options are simply very limited comparing to older version. I’m going back to version 2

9 Likes

Mac 10.14.6. Upgraded (3.0.0) just now, but application hangs for several minutes before crashing. Fix?

4 Likes

Completely agree. Just tested it and new algorithms are worse than some low budget sharpening filters, leave lot of halos in motion blur mode and others as well, which is the whole point of using Topaz product to avoid halos. And in normal sharpen mode which they now call I think Too Soft as if we are third grade kids, the slider moved to maximum barely does any sharpening and when set to “very blurry” it produces weird artifacts around edges. This is a disappointing disaster of a release. The new AI algorithms are big step backwards. Who tested this? Was there no feedback.

9 Likes

I went through the motions of installing on Mac, but the app is nowhere to be found.Latest installed version is still 2.1.3 from May 2020. What am I missing?

I have not been able to get Sharpen Ai to run on my work station since December 2020. It will work on two a lower grade PC’s. I tried the lastest 3.0 and it still will not launch. None of the new Ai products were working.

Just because it uses AI doesn’t mean I want it featureless. Give me enough control to instruct the AI engine to respond to me. The results from the latest upgrade are lackluster at best (halos/poor sharpening/loss of depth&contrast.
Also, are we going to be held hostage:
– While not logged in, or if your license is expired, your image will save with a watermark
– Users who own the product should be able to use it offline without a watermark given they’ve logged in once and don’t log out

8 Likes

I am using 10.13.6 and having the same problem

1 Like

Program working ok, but processing image is extremely slow now. What I used to be able to process in 3 minutes now takes 18 minutes. Other than installing new version, I have not made any changes. I am running on PC with Windows 10. Preferences Performance section shows AI Processor as NVIDIA GeForce GTX960 which is my card.

3 Likes