Sharpen AI v2.1.8

Masking works ok with OpenVINO on my Win10 platform. Had an error msg in post install about some file missing, but doesn’t seem to be an issue. I didn’t catch what it was, and had just uninstalled the Beta, so it might have had something to do with it. I might try reinstall to see if it happens again,

I’ve just downloaded 2.1.0. Why does it select Stabilize now? If I click on Sharpen, only the first one of the batch changes. You have to choose select all. I want it to choose Sharpen Auto by default. Can I change default settings?

1 Like

It does not show in preferences. I suggested that before, but it was not implemented in this release as far as I can tell. I think it would be nice if one could.

In Mask, when you hide the overlay, the Sharpened preview goes away but the Update button is still greyed out.

I don’t really see why the sharpened image is removed when the overlay is hidden.

  1. Open new image – Update is enabled
  2. Apply mask
  3. Click Update – as it is enabled
  4. Image is sharpened – (you can see it update behind the mask overlay) and Update now becomes disabled
  5. Uncheck overlay to hide the mask overlay
  6. Sharpened image is removed and original, unsharpened image is displayed but Update is still disabled
  7. You have to change some sharpen model setting to reenable the Update button

Note that this is in standalone mode on W10 with Auto Update disabled.

1 Like

OK I succeded looks like my VPN prevented me to download Sharpen AI but Gigapixel was OK with my VPN ?

macOS Catalina version 10.15.6

iMac (Retina 5K, 27-inch, 2017)

Processor 4.2 GHz Quad-Core Intel Core i7

Memory 32 GB 2400 MHz DDR4

Graphics Radeon Pro 580 8 GB

tried using mask feature in Sharpen AI 2.1.0 could not find a masking brush, all parameters seemed ok but no brush to paint mask.

tried again with different image no problems masking brush appeared automatically.


when updating in Windows 10 64bit Pro, after update only “add grain” does something. I had to remove old installation, clean registry from Sharpen related items (path information), and then re-install totally.

I run sharpen AI with restricted user (both in Windows and Mac, have not tried to update in Mac yet). Thus, I have to install software in folder accessible for restricted user account. It seems that installer, while updating, does not recognize custom folder.

It seems that your installer is still a bit unstable.

I will be very happy when the mask could be copy from one image to all.

Yesterday I received an email informing me of the new version 2.something download, which I did, and installed as Administrator.
Ran it today, it reported that I am still running 1.4.6 and that I should download 2.something AGAIN. I am in a rural area and interface the Internet through the HughesNet satellite service. I do not have unlimited data download allowance in my HughesNet account, so do not want to download the same thing repeatedly just to accumulate Crash Logs.

I am going to wait for an email that says a version 2.something is now “safe” to download. I am surprised by these message strings that look like a Beta Test on Sharpen AI 2.X is in progress. I am a “former” Topaz Beta Tester–“former” because I had a bad experience in the Topaz Beta section in which an entire message string I was working in was wrongfully removed. I would have gladly edited a comment of mine to remove what was interpreted as objectionable, but never got the opportunity to do that. Other Beta Testers had time invested in that message string, and I felt bad for them.

Anyhow, I will wait until Sharpen AI v2.xx seems to be working acceptably well. I can’t afford to download it daily.
The Topaz AI products are, as a group, amazingly good, and literally deserve a Nobel Prize or something equivalent.



When version 2.0.0 of Sharpen was released there was a change in the default installation folder and the instructions stated that unless you manually deleted 1.4.6 then you would have two versions of Sharpen on your computer, and that they would happily co-exist. If this is your first update since 1.4.6 then it’s likely that you do indeed have both versions. You don’t say what operating system you’re on, but on my Windows 10 PC they would both be located under Program Files - 1.4.6 in a folder called Topaz Labs, with 2.1.0 in one called Topaz Labs LLC.

1 Like


I updated Sharpen AI and Gigapixel AI on my Macbook Pro 16" laptop today. Both installations and startup went smoothly.

I noticed, however, that the messages displayed on exit when you have not saved your modified image are different. The question is different and opposite for the two programs. It might cause some users to take the wrong action without thinking about it.

Hello Paul,

That was very helpful information. I do have Windows 10 on my PC. Probably a current version, since it decides to do an update fairly frequently. The new Sharpen AI version was exactly where you said it would be. I am going to try hard to have the two versions “happily co-exist”. I kind of like the results I have been getting from 1.4.6 and having it remain on my system delights me. Now I am going to try to run 2.1.0

Thank you VERY much for your prompt helpful response.


1 Like

Auto masking feature seems to only work when Sharpen AI is as a stand alone. It doesn’t work as a PS filter.

i have the same problem the find objects only works in the stanalone version and not as a plugin with photoshop

Same issue here. Win 10 and PS 2020 all up to date.
Opening Sharpen AI as a PS filter, the masking button is on the top of the picture beside the view and original buttons and there is no recognition of any subjects.
When I open Sharpen AI from within Lightroom, it works exactly as the standalone version.

Why not mask in PS?

I thought the idea was to mask inside Sharpen AI so that only the selected area is used by AI to compute the sharpening. In any case in my opinion the results from Sharpen AI are no better than what can be achieved in PS. So just mask and sharpen in PS. Problem solved.

I am getting an entry point not found error with file cldnnplugin.dll.

But the application still works.