Sharpen AI update did not update in Lightroom & PS - help?

just updated Sharpen AI, did the 2 updates - the stand alone is at 2.0.1 but LR and PS still point to the older version and ask me if i want to update again.

do i need to manually link LR and PS to the new install, and if so, how do i do it?

thank you

1 Like

i have the same problem (W10, adobe ps cs6). the update ininializes another update. after that standalone application shows “2.0.0” - while the ps-plugin stays with “1.4.6”.

1 Like

my standalone shows 2.0.1 after the 2nd update, and a different splash screen. still the older version in LR, but my PS 20.21 now links to the sharpen ai 2.0.1 ------

I can’t update at all, the same message will be seen when I start the program, any idea?
“Do you want to install the updates now? This will close Topaz Sharpen AI…”

I believe the installer advises you that you need to uninstall the previous version manually. E.G. on windows from the settings apps panel.

Then install the new version again.

I’m on a mac. i do not understand. if i uninstall all ai sharpen, will that also uninstall the bits in ps and lr? - and if i then reinstall from scratch, it should magically recognize LR where it didn’t before?

to be clear - it sucessfully updated PS, it did NOT update LR - is this normal behavior on a mac?

thank you

You have already stated that the older version is still installed. You need to uninstall that.

And if you don’t want to uninstall/reinstall here is a instruction to set up the external editor preset, remember that you just need to substitute Sharpen AI for Studio 2:

ok - so i uninstall the old version. I have the new version also installed. how do i point LR to the new, already installed version? thank you for the link to uninstall/reinstall - though it is to topaz studio 2 — i am hoping it also works for ai sharpen?

thank you for your help.

Yes, this will help without you needing to substitute:

install the old version s first

Hi everyone …
I could fix issue like this …

  1. Open PS preferences panel and “add” folder containing new Plugin (check out, there are two S Plugins at different locations (would seem update doesn’t get rid of previous version but didn’t try as too glad it’s working now …)

  2. Quit / reopen PS

  3. Invoking Sharpen AI will invite you to update, and that’s it …

Strange enough to be mentioned, maybe …

I get 4 very different “Auto” values proposed for the very same image file, depending if I process

  1. As a Standalone version,
  2. As a Studio2 plugin (invoked from inside Studio2)
  3. As a Studio2 plugin (invoked from PS)
  4. As a PS Plugin

For instance
AI SA vs S2 vs PS.S2 vs PS Topaz AI
21-17 vs 33-20 vs 26-47 vs 74-28

I insist that it is on the very same “fresh” original image file - not altered in any way - repeated the whole process 3 times …

Mine did not give that warning. It simply said this was a different version. So that I understand, if I simply uninstall version 1.46, LR and Topaz Studio will then know this new AI Sharpen (2.02) is the one to open without any other fiddling with the various settings? I hate to sound ignorant but this seems complex unless I just don’t get it.

I just downloaded the latest version of SharpenAI. Even though I followed all the recommended steps it still does not show up in PS. (I’m using CS6) It is still necessary to manually move the plugin from the resources folder to the plugins folder after manually getting rid of the old one. If Topaz is going to start charging for their upgrades it would be nice if they could fix this persistent problem. I’m about to download the latest Studio 2 and I’m assuming I will have to do the same thing here.
This problem has been around for awhile now and has been discussed on this forum but it’s still a problem.

I also use CS6 and the past few updates have not gone well at all. I’ve had to get tech help for each update. I have had to wait up to 5 weeks to get an update to work properly.
I’m holding off on this update for awhile.

Read this thread, also please don’t post Sharpen AI questions in a Mask AI thread as you won’t get an answer.

Yesterday i downloaded updates 4 times, each of which took about 1/2 hour. I also uninstalled the previous version. Today I tried to edit in SharpenAI from the latest version of Lightroom. It shows in the Lightroom menu, but does nothing, no error message, just nothing. I launched SharpenAI standalone and now it is doing another 1/2 hour update. I only hope this will will fix the “edit in Lightroom” issue.

Same issues - clearly broken on Mac at least - each time it prompt, each time I run the upgrade . . but its just never there . . cant find it in finder either - its like it just goes nowhere - yet one would expect that since its prompted from within Studio, that Studio would pick up the new version. . can’t find it to add as a plugin to light room either . . (no surprise as its not in finder anywhere seemingly)

I just ran the update utility instandalone - sure it launches OK - but when I go into studio - its back at the old version, and prompting for the update again.

Is there a fix for this? how do you get sudio to update this - its stuck in a loop seemingly

Did you uninstall the previous version?