Sharpen AI 3.0 Extremely Slow

Have just upgraded to version 3.0 of the Sharpen AI software and find it extremely slow in rendering previews and especially in processing. It is taking 5-6 minutes or more to process an image. I am using the plugin from Lightroom. My MacBook Pro system meets or exceeds the recommended system requirements. Thinking I will go back to the old version which while not super fast was not this slow.

Unfortunately I have to agree. I just tried standalone version and it preview is rendering more than 15 minutes and the blue line is still in the beginning of progress bar. I use not too powerful windows laptop (i5 processor, 8 GB memory), but previous version was working on it.

Please go to Help-> Graphics info, press Copy and paste the info here. What are your Processing Options set to in the preferences (under the File menu):

image

Please answer the questions in my post above.

Application & Version: Topaz Sharpen AI Version 3.0.0

Operating System: macOS Mojave (10.14)

Graphics Hardware: AMD Radeon Pro 555X OpenGL Engine

OpenGL Driver: 4.1 ATI-2.11.23

CPU RAM: 32768 MB

Video RAM: 2047 MB

Preview Limit: 4492 Pixels

Application & Version: Topaz Sharpen AI Version 3.0.0

Operating System: Windows 10 Version 2009

Graphics Hardware: Intel® HD Graphics 615

OpenGL Driver: 3.3.0 - Build 23.20.16.4973

CPU RAM: 8078 MB

Video RAM: 1500 MB

Preview Limit: 3135 Pixels

Sharpen AI v3.0.0 is extremely slow (previews are taking 2-3 minutes, processing 8-10 minutes).
I reinstalled Sharpen AI v3.0.0. and tried it as a standalone and Lightroom/ Photoshop plug-ins.
I’ve tried all GPU permutations (no difference) and the CPU option (app crashes during preview).
Now rolled back to v2.2.4.

Late 2014 iMac 5K 27", 16GB RAM, OS is MacOS Mojave v10.14.6.
System:
Model Name: iMac
Model Identifier: iMac15,1
Processor Name: Intel Core i5
Processor Speed: 3.5 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB
Boot ROM Version: 430.0.0.0.0
SMC Version (system): 2.22f16
Serial Number (system): C02P365DFY11
Hardware UUID: 0CFD2EDD-A549-57B0-9AA2-06D2AD69CAE3

Graphics
AMD Radeon R9 M290X:
Chipset Model: AMD Radeon R9 M290X
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 2 GB
Vendor: AMD (0x1002)
Device ID: 0x6810
Revision ID: 0x0000
ROM Revision: 113-C408A0-730
VBIOS Version: 113-C408A0-017
EFI Driver Version: 01.00.730
Metal: Supported, feature set macOS GPUFamily2 v1
Displays:
iMac:
Display Type: Built-In Retina LCD
Resolution: 5120x2880 Retina
Framebuffer Depth: 30-Bit Colour (ARGB2101010)
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported
Automatically Adjust Brightness: No

Just check what your Performance settings and select the alternative to what is being used at the moment to see if that makes a difference.

Make your GPU driver is the latest from the AMD website.

Please raise a support request at the main website so they can investigate.

I now have rx480 Plus rx580 on my I Mac.

As I understand it, the only way on a Mac to get a later graphics driver is to update the OS since the graphics driver is managed by the OS. Some of the Topaz programs are not compatible with Big Sur, so I was waiting to update to Big Sur. I guess I will revert back to the earlier version of Sharpen if there’s not a way to make it run faster and stay with my current Mojave OS. But, thank you for trying to help.

Wondering if it is a Mac problem? I’m on Windows 10, using a i5 7600 chip with 64 gb system ram and a 1070Ti graphic card and the program is lightning fast. The previews, even fit in window previews rarely take for then 15 seconds. I know this doesn’t help you folks with problems, I present this only as a point of comparison. Hopefully this helps narrow done the trouble. I just hate problems with new version. For what it’s worth, here is my graphic info from the program:

Application & Version: Topaz Sharpen AI Version 3.0.0
Operating System: Windows 10 Version 1909
Graphics Hardware: GeForce GTX 1070 Ti/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 432.00
CPU RAM: 65494 MB
Video RAM: 8192 MB
Preview Limit: 8000 Pixels

All apps except Adjust AI and JPEG to RAW are compatible with Big Sur.

You need to update your graphics driver from the NVIDIA website as it is way out of date.

Thanks Don, I know it’s old, however I’m a firm believer in if it’s not broke, don’t fix it. All software is running just fine. If I start to have problems I will update to the Studio drivers. I don’t update drivers if they are performing well with the software I have. I’ve encountered no problems with PS 2021, latest LR, Studio 2, etc. Thanks again for the tip.

I’m also having problems with Sharpen AI being so slow as to be unusable. Previous version worked great. I know my system is getting a bit long in the tooth but it should still work ok.
Application & Version: Topaz Sharpen AI Version 3.0.0
Operating System: Windows 10.0.19042 Build 19042
Processor: i5-4670 CPU @ 3.40GHz 4 core
Memory: 16Gb
Graphics Hardware: GeForce GTX 750
Driver version: 456.71
Total graphics memory: 10210 MB

I notice that both the Mac users who are experiencing very slow speeds are using the Mojave OS. And maybe they were using CPU, not GPU. Could that be the problem? I cannot recall if anyone beta-tested it on Mojave.
On Big Sur, it is several times faster using the GPU. It is VERY slow using CPU. Some people say that CPU delivers a better result. I haven’t noticed this myself:


GPU on the left, CPU on the right. Very heavily zoomed in, so it’s never gonna win any prizes!

It helped, but it still taking ages to see preview of image. I tried one of the sample images (lady) with auto settings and it took about 7 minutes to generate preview. I can’t imagine how long it would take to slightly change setting. Anyway is there way to downgrade to previous version?

I am using the GPU setting. I tried changing to CPU just to see what happened, and the program crashed every time it tried to render a preview. I also tried going directly into the program rather than using the LR plugin, but performance was still very slow. I will either go ahead and update to Big Sur, or I will revert back to the previous version which worked adequately. Thank you.