"Remove" doesn't work on faces

Try removing the strand of hair from this picture:

toree

Steps to reproduce issue:

  1. Load image
  2. Delete “Upscale” enhancement
  3. Add “Remove” enhancement
  4. Mark the strand of hair
  5. Press “Remove selection”
  6. Wait :grinning:

Result:
toree-topaz-faceai-remove-

(i’ve tried both with the whole strand and only a partial - it’s the same result)


Topaz Photo AI [v3.0.0] on [Windows]
Same issue in v2.4.2

Would you mind sending in some more information to get a better understanding of the problem you are having with this particular type of image? Please send the following information:

  1. The original image file.
  2. The processed image.
  3. A screenshot or description of the settings panel so I can see what adjustments were turned on.

You can securely submit your image(s) to my Dropbox using the link below.

Dropbox File Request

Please be sure to send me a note to let me know you sent something.

Any progress on this issue? I’ve had other occasions where I try to remove an entire person, and the head remains floating in the air. One thought occurred to me - could it be the presence of “Face Enhancement” that interferes?

You need to use the remove tool before face recovery. Then you won’t get a “ghost” face!

002 Montreuil (Ray)
Unable to get rid of the coloured artefacts in the face and hair on this old JPG scan when upscaling. The only solution is to work on it with the remove tool as is, save it and then do face recovery and upscaling on the saved image.
002 Montreuil (Ray)-TPAI-remove-

With the OP’s image, do the reverse: Upscale and face remove, save and then do remove on that:

1 Like