Program is so Slow its not usable

I opened the program today and it was so slow I closed it, rebooted my computer and tried again. It still wouldn’t work so I downloaded the latest version 2.4.1 - it again, took forever to open the photos and would not process them. I deleted the application completely and downloaded the old 2.3.2.
It took 1 min 51 seconds to open one photo. It then took over 3 minutes to process it with sharpening and noise reduction - I don’t know how it looked because the preview would not update.
I had to wait over a minute to change the zoom magnification.
I then went and re-downloaded 2.4.1 and it again took forever to open the photos and I don’t know if it’s processing them.
I have a new MacBook Pro - Apple M2 Pro with 16gb of memory - I had no issues last week.
Please help - I rely on this software.

Steps to reproduce issue:

  1. Step 1 - try to open image and wait
  2. Step 2 - try to process image and wait
  3. Step 3

Topaz Photo AI [4.2.1] on [Mac]

Same issue here since latest update. Not usable anymore to process images.
I guess this constant preview update during zooming steps doesn’t help either…

Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.

This worked for me - its lightning fast now and I love the 2.4.1 version.

Hi John, could I please get theses instructions, but for windows, not mac.

If you are still experiencing problems please reach out to us at the following link:

Topaz Labs | Support Page

This topic was automatically closed after 60 days. New replies are no longer allowed.