Topaz Photo AI has worked great for me since the beginning.
But now after the last update (Version 2.3.1) the issue changed. (Windwos 10)
Everything seems to work fine on digitally captured photos but old scanned photo racks, there is something wrong.

“Autopilot” / Detecting faces, the processing stops there, it continues for several minutes, up to 30 minutes I’ve tried without any change. Trouble

The program cannot work properly, or continue.
My friend who lives in the same house as me, who I advised to buy Topaz Photo AI, which he made and has been using, also has the same problem.
This has always gone well, except now.
Please guide me.

You can choose one of these two workarounds to resolve this issue:

Let me know how that goes for you and we will make sure to reach back out to you to let you know when this is resolved.

I followed your instructions.
Everything seems fine, I downloaded Topaz Photo AI v2.3.0 and setup seemed normal and pooled as usual.
But I couldn’t find a link anywhere to open the program. It was also not found inside a new folder, which the setting had created (attachment)
I also looked elsewhere on my computer, but to no avail.
Maybe I did something wrong, I don’t know???
It’s probably best to wait until you’ve solved the problem with a new update. I accepted it.
But one question: Do I need the old Topaz programs; Denose AI, Gigapixel AI and Mask AI inside my computer? This takes up space.




This topic was automatically closed after 60 days. New replies are no longer allowed.