Problem saving Impression changes back to Photoshop

Hi. I just purchased Impression in Studio, updated to 1.5.2 last night. I haven’t figured out how to save the changes and send the image back to Photoshop for any further tweaks. When I do some adjustments in Impression and click OK (where it says “Save changes and return to host application”) it just takes me back to the original image in PS. In the panel on the right in PS I see the background image with the layer above it. But the layer icon is just the checkerboard background.
What am I doing wrong? I see I can save the file as a jpg or tiff but that just saves it into one of my folders. Also, the one time I did that, it didn’t save properly anyway. The image was dark and the brush strokes were significantly different.
I already own Topaz B&W Effects2 and Adjust. I have no problem with them applying changes and seeing the altered image back in PS.
I’m using an iMac with OSX Yosemite and Photoshop CS6.

Did you hit apply before saving back to PS?

Hi. Thanks for the reply. I believe I did. I’ll go and do another one now to be sure then get back to you shortly.

Hi again Kathy. The same thing happened as the previous times. I hit Apply. Underneath the image you see a thumbnail of the original and beside it a new thumbnail is created. But it only shows the checkerboard pattern. When I then hit OK to return to PS it’s the same result—the layer panel small thumbnail still shows only the checkerboard icon and the image in the main window is still the original unaltered image.

A checkerboard image is an indication of transparency. Maybe if you list the steps you took it might help explain why you are ending up with a transparent layer and point us in the right direction. I’ll help as much as I can but I’m a PC user with Paint Shop Pro as my host program.

Hi. The steps were very simple. I created a layer copy of the background image in PS as Topaz requests. This last time all I did was use one of the presets in Impression. I didn’t make any further adjustments, just wanted to go through the process quickly for you.
Then I hit Apply. The rest was as I described in the previous message. The checkerboard transparency appeared beside the original. I then hit OK (where it says “Save changes and return to host application”). That took me back to PS with the original image still showing in the main window and the same checkerboard transparency in the layer panel sidebar.
Could this be a bug in the program or is there perhaps a setting somewhere where I need to change something so the processed file shows properly?
I hope someone can help me with this. I’ve probably spent close to 10 hours fussing over this problem in the past two days.

Take a look at the adjustment you added and see if the opacity is set very low?

Could you post screenshot of what you are seeing when you return to PS please.

Were you working with layers either importing or exporting?

No. Opacity is all the way up.

I’m sending you 2 screenshots. One is within Impression in Studio showing you what I see after hitting Apply. I hope you can see the transparency thumbnail at the bottom beside the original PS image.
The second one is after hitting OK and returning to PS. This time even the original image isn’t visible. This program is really messing with PS. I quit PS and Bridge, re-opened Bridge, opened an image into PS, and this time even that new image isn’t showing up in the main window.
When I first downloaded Impressions in Studio the problems were even worse. When I tried to zoom in the whole thing froze and started generated patches of patterns, even in PS. I couldn’t quit or even Force Quit PS or shut down the computer in the normal way I had to use the rear button on the iMac to get out of the computer and restart.
The version I started with was, I think 1.4.4. The update is to 1.5.2. That seemed to resolve the freeze when zooming issue.
I’m going to restart the computer and try going through all these steps again. If I get the original image when I go back to PS from Studio, I’ll send you a new screenshot. At least now you should be able to see the PS window with the transparency showing in the layers panel.

I created a layer in PS before opening Studio if that’s what you mean. Some of the images I’ve been trying this with had previous layers from past plug-in work, like Nik.

P.S. The upload of the screenshots showed in the writing window but aren’t visible to me on the main thread. Did you get them?

Don. As I mentioned elsewhere in the thread, this program is playing havoc with Photoshop and apparently other functions on my iMac. I went through the process a couple more times after sending you the screenshots. Same result. The final time the original image appeared in PS for a nano-second then disappeared, leaving the main window blank. After earlier taking a couple of screenshots, even that function refused to work that time.
By the way, I noticed when I open an image in Impression in Studio, at the very top it says Topaz Studio - @18.2% or similar depending on the image. Could that be relevant or is it just telling me the size of the image relative to 100%.
Also, is there any chance that re-installing the program would fix these issues? Is it even possible to do that?

I had exactly the same problem. Layers get corrupted when sent to and saved by PS from Studio. I been certain that everything is FLAT when the image returns. AND make certain the image coming from PS are flat. See if you can duplicate the issue.

I had exactly the same problem. Layers get corrupted when sent to and saved by PS from Studio. I been certain that everything is FLAT when the image returns. AND make certain the image coming from PS are flat. See if you can duplicate the issue.

Thanks for the reply Barbara. I don’t know what you mean by making sure the image coming from PS is flat. I load a psd version of the image into PS. Then I duplicate it to make a layer. Then I open Impression in Studio. Several times today I tried just using a preset without any additional adjustments, then hitting apply. The same thing happens every time as I’ve described.

It’s frustrating. I like the product and would like to make use of it. I’ve spent several hours on each of these past two days dealing with this. I’m not a techno wizard but neither am I a doofus. I’ve been using PS for 10 years and I have at least a half dozen plugins that all work just fine, including 2 from Topaz.

They make really interesting products but this can’t be good for their reputation. As far as I’m concerned, the right thing to do would be for someone to get on the phone with me and talk me through the possibilities.

In other words, I think the people at Topaz need to be more responsive. When you go to the page where you submit a Help ticket, they say right there that they’re overwhelmed and may not reply quickly. Does that not imply they’re understaffed and not doing a good job of customer care? It might also imply that they’re rushing some of these new products, updates, and ways of doing things to market without thorough enough testing.

If that happens often enough the feedback is going to start showing up online.

Go to the Layer menu … and then go to flatten image. It will destroy your layers so make sure you’ve finished what you’re doing in PS (or that you’ve saved the image with layers). Then flatten. Through the Layers menu. Then use Topaz to do what you want and reopen in PS. Make sure everything has been applied in Topaz. You should be good to go.


Thanks again Barbara. So does that mean I’m mistaken about the need to create a layer first before sending the image to Topaz. The last time I tried just sending the background image I could a message saying I need to create a layer first. I’ll try it now (while restraining myself from pulling out my hair :slight_smile:

I’m not sure what you mean by sending me screenshots, I haven’t seen any, just use the up arrow on the header where you are typing the reply to upload it.

Sounds like that is a PS issue.

I’m not sure what you mean so I suggest that you raise a support ticket at the links in the header of this site and Topaz Support will get back to you.

The % is the zoom level which is shown when you open an image in Studio, as for most products.