Presets create duplicate entries

[Please describe your issue here. Try to include logs (Help β†’ Logging) and add screenshots if necessary.]
Presets are a valuable addition. However there is an issue, I would like to mention:
When opening an image in Photo AI, the Auto Pilot makes its suggestions. If you then want to apply your preset, you will have double entries of the enhancers. So, I suggest to add the option of removing the entries from Auto-Pilot when applying the ones from the preset. It would only need a dialog whether you want to replace the entries, when using the preset.

Steps to reproduce issue:


Topaz Photo AI [v3.x.x] on [Windows/Mac]

1 Like

You can disable Autopilot from being ran on your images by going to Preferences > Autopilot and toggling the option off to Automatically apply filters as a workaround for this problem.

Thanks, this is clear to me, but I am interested in the suggestion from AutoPilot – and then after having examined it, I may switch to my Preset. Otherwise you might also make a simpler access to use the presets without even having to open the image in the plugin and just run the preset on a whole series of images

I will be sure to share this insight with the appropriate development team. Your feedback is 100% valuable! We greatly value our users’ feedback and take each request into consideration when working on updates and improvements. It helps to give us more insight on what our apps are needed for, and ultimately what direction we need to take to fulfil that need.