Precision Detail in Topaz Studio is "wonky"

Precision Detail used to be my go-to sharpening adjustment. Now, when I use it and click on the drop-down box for detail, my image turns “wonky” and almost painterly, like it a Topaz Impression was applied.
Is there a bug in my software? Do I need to re-install Topaz Studio? Has anyone else had this issue?


If you are already using v1.14.5 it is up to date. Go to Help-> Graphics Info, press the Copy button and paste the details in this thread.

I’ve seen this happen to an image that has previously been through Sharpen AI. Some adjustments will not behave nicely after AI treatment.

1 Like

I just did a quick check of TS 1.4.5 and found the Precision Detail to be working as it always has. Is there any chance you have a blending mode other than Normal selected?

I usually start with AI Clear. Could that be causing the problem?

I don’t touch the blending mode, but I’ll check tonight to see what it’s set at.

Try it the other way round, use Precision Detail first and see if it behaves normally without the AI.

I will. Thanks for the suggestion.

I experienced the same problem with AI Adjust. After reading the initial post in this thread I tried using Precision Detail in Topaz Studio (V 1.14.5, Mac), with the same outcome. However, the issue only seems to occur with photos taken from my Nikon P1000, whether they are jpgs or RAW (NRW format). I have checked every other photo type (e.g. photos taken with a Kodak, Sony, iPhone, etc.) I have available, but the program behaved as expected.

None of the Topaz products appear to support NRW files but it is only Precision Detail (either within Studio or within Adjust A1) that cause problems for a jpg file shot from my P1000. I have not tried adjusting settings on the camera to determine if there are any other relevant variables.

it appears with all kind of files, it is Mac related, hope they fix it soon !

seesm fixing the broken and unusable studio detail and AAI plugins for Mac user does not have high priority for topaz.

1 Like

I believe that there is a replacement for Studio currently in test, see the VP of Developments statement here so there will be a detailed announcement going out to users, hopefully this week:

I just tried Topaz Studio 2 and I get the same issues using Precision Detail 2. I’m glad I didn’t pay $99. I wouldn’t pay anything for Topaz Studio until those issues are resolved.

btw, I have stopped using Topaz Studio because of all of the issues with my images.

wow, the issue with both products ai and studio detail is now unsolved for about a month and now they realise studio 2 with the same bugs seems they don’t caret if their software actually works.

Have you raised a support request yet?

yes 2

just discovered the old detail 3 plugin works flawless in ps cc had a copy on a backup. and this made me think that a company which brings 4 incarnations of essentially the same filter to the market within just a few years must have a terrible management. so it is of no surprise they bring flawed products to the market and ignored bugs too.

I think that the issue is linked to handling RAW files in any Topaz product running on Mac. If I open a RAW file (ORF from Olympus OMD E5 Mk2) in Adjust AI or either Topaz Studio and drop the small details to -100 then I get the “Impressionist” effect. If I send a Tiff of the same image from On1 then Precision Detail works as expected.

I will double check my steps and submit a support request in the next day or so.

1 Like

I have tried multiple things, including a reinstall. I have attached two sample images. The clear image was immediately upon opening Studio. The other is after applying Precision Detail before doing anything else. I have tried at least 7 images and all with the same result. I tried adjusting once it was open with no success.