Poor response is making application unusable

Fairly new user of Topaz. Initially great but now performance is so bad, it’s become unusable. I have a new Mac M2 pro. read reports to clear cache etc which I did. very temporary improvement but now so slow, I could make a cup of tea while the initial image is processed. This is not fit for purpose…

Please follow the instructions below to fix this issue:

Topaz Photo AI Freezes on Importing Image (Mac)

Let me know if it’s working after doing this and I’ll keep an eye out for your reply.

Thanks for replying. I tried this previously and it worked, but for a very short time. I’m now back to the issue where EVERYTHING takes an eternity. I need a permanent fix as repeating this process every time I want to use the software is not an option. Thx Mike

Could you give me some more information about your workflow in order to better help troubleshoot the problems you are having.

Do you use Topaz Photo AI as a standalone app or as a plugin? Also does this issue occur when working on a single image or if you are working on Batch Processing?