Photo Subject Selection is Impossible in 2.4.x (2.4.0, 2.4.1, 2.4.2)

I’m unable to adjust the subject selection because the UI is so incredibly sluggish. Prior to 2.4.0 it was a bit sluggish but still usable. I’m editing a 9504x6336 resolution image (quite often lower resolution than this because I crop before using Photo AI so I don’t think the resolution matters that much). The auto subject selection has never been perfectly accurate so I often adjust it manually, so this makes my the product unusable for me. I’ve now returned to 2.3.2 twice (from 2.4.0 and now also from 2.4.2) and uninstalled the newer version.

I have a Macbook Pro 2019 16" (Intel-based) - 2.6GHz 6-core, 32 GB 2667 MHz DDR4, AMD Radeon Pro 5500M 8GB, Intel UHD Graphics 630, 1536 MB, running Sonoma 14.2.1.

Steps to reproduce issue:

  1. Choose the divider view (where you drag the vertical divider left & right to reveal original image vs updated image in the preview.
  2. Make sure Sharpen is present and click on it to make changes to settings.
  3. Switch to subject selection and attempt to modify selection using add/remove. It takes forever to respond after hovering mouse over image and after clicking to modify selection.

Topaz Photo AI [v2.4.2] on [Mac]

1 Like

Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.

I’m having the same issues on a Windows system. Subject selection/refinement lagging to the extreme. Practically unusable!

Asus Pro Art system
Processor 13th Gen Intel(R) Core™ i9-13980HX 2.20 GHz
Installed RAM 64.0 GB (63.6 GB usable)
System type 64-bit operating system, x64-based processor
NVIDEA GeForce RTX 4070
2TB SSD