Photo AI upgrade fail

[Please describe your issue here. Try to include logs (Help → Logging) and add screenshots if necessary.]

I am running Photo AI 1.3.3 on a Windows 10 machine. I have tried to update to the latest version but I consistently get the following message: “this installation package could not be opened. Please contact the application vendor to verify this is a valid Windows installer package.”
I have also tried to uninstall the program and re-install it but get the same message.

Hi @ptpons-26454, please try downloading a new installer directly from our Topaz Labs Download Page and use this to update Topaz Photo AI – let me know if you’re able to get any further!

Thank you for getting back to me. I did as you suggested. The installer goes part way through the install and then I get message that says the old version of PhotoAI could not be removed and installer quits. Tried removing it through the control panel of windows, that did not work.
Wondering if I can go into the directory, remove the PhotoAI folder and start over?

Follow the instructions here to fix this issue.

  1. Click here to download the v1.3.3 installer.
  2. Run the installer and remove v1.3.3 from your computer.
  3. Download a new installer from the downloads page:
  4. Run the installer for the latest version.

No luck. When I download v1.3.3 and run it, get a message that says it is not a valid windows installer. Tried to remove it manually and then load the latest version. It partially loads and then get a message that says the previous version could not be removed.

That error appears if the installer is corrupted/incomplete or the file path is invalid. Can you try redownloading the installer for v1.3.3 and run it again? Try moving it from your downloads folder to your C: drive directly and try running it from there.

Please reach out through if that doesn’t work so I can troubleshoot faster.

Thanks. Tried to do so but it stops part way thru the install and says the prior version cannot be removed.

Please confirm that you ran the v1.3.3 installer again as this is needed to remove the previous version of Topaz Photo AI.

You can also try deleting the registry entry for Topaz Photo AI by following the steps here:
How to Clear Your Topaz Labs Registry Entries (Windows)

Then try running the installer again. If that still fails, you can schedule a screenshare with me from the link below. Make sure you have Zoom meetings installed.
Schedule a screenshare appointment

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.