Photo AI 3 Face recovery, Photoshop batch and actions

I use macOS, TPAI as a plugin for Photoshop.
In TPAI Settings selected All, Low quality or Subject only (no matter) for Default face detection.
If I use TPAI from Photoshop filters menu and Face recovery is applied by Autopilot or manually added then faces selected according to TPAI settings and export result to Photoshop include Face recovery.
If I use TPAI as action in Photoshop (alone or in batch processing images) and Face recovery is recorded in this action then I’ve no one face selected automatically no matter what selected in TPAI Settings for Default face detection (it looks same as selected None for Default face detection but it’s not true). And export result from TPAI to Photoshop doesn’t include Face recovery because of that.
Is it normal behavior for TPAI in Photoshop action or is it a bug?

Steps to reproduce issue:

  1. Record action with TPAI and Face recovery.
  2. Start Photoshop batch processing for photos or folder or just start saved action with TPAI from Photoshop Actions pallette.
  3. See for selected faces for Face recovery while action executed and exporting to Photoshop.

Topaz Photo AI v3.x.x on Mac

Please follow the steps below to reset your Photoshop plugin.

  1. Close Photoshop fully.
  2. Run the Topaz Photo AI installer again. Get a new one from the downloads page: Topaz Labs Downloads
  3. Open Photoshop Elements and check the File > Automate > Topaz Photo AI plugin again.

Let me know if those steps get it working again.

Topaz Labs Documentation | Topaz Photo AI | Plugin | Photoshop & Photoshop Elements

If it does not, open Topaz Photo AI, go to the menu bar on the top, and click the ’ Help > Open Log Folder ’ menu option. You should be able to attach the whole folder to this email to send to me.

You can securely submit your files(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.

Dropbox File Request

File > Automate > Topaz Photo AI working normal but it’s not what I want to use.
I want to use recorded action in which I use Topaz Photo AI from Photoshop menu Filters > Topaz Labs > Topaz Photo AI and not from File > Automate > Topaz Photo AI.
And in that case Face recovery that presents in recorded Photo AI action doesn’t select any faces (but they are presented on image and they are detected with Analyzing image on Photo AI start).
Screen capture: Automate vs recorded action.mov - Google Drive
Logs.zip (25.6 KB)

Thanks for sending in that informaiton and for linking that video. I have not been able to replicate this issue on my machine but did notice that in the log files you were on v3.0.0. Let’s try updating you to the most recent version release to see if this resolves the issue.

Please make sure you’ve also turned off any firewall, VPN, or proxy that may be on your computer. These are known to block the installation. Also, make sure there are no settings or configurations in your OS system that could interfere.

Try using the link below to update:

3.0.1 changed nothing for me.
This issue happens only when Photo AI was called from recorded action (or this action used for batch processing via File > Automate > Batch…). In that cases Face Recovery selects None for faces no matter what selected in Photo AI settings (All, Subject, Low quality).
If Photo AI was called via File > Automate > Topaz Photo AI or via Filter > Topaz Labs > Topaz Photo AI then there are no this issue and Face Recovery select faces according the settings selected in Photo AI settings.
Logs.zip (43.5 KB)

Thanks for that information. This problem is occurring with the Actions process while working between Photoshop and Topaz Photo AI. When you are using the action it is saving and running the settings from the previous instance while using Topaz Photo AI.

You will want to use the File > Automate option manually instead of the action method. I have reached out to some of the developers to bring this to their attention, while we do not have a timeline for it I can assure you it is on their radar.

Thanks for info.
But File > Automate is not the same as using from Action.
When using File > Automate (or Action with Photo AI inserted via Insert Menu Item) it’s «semiautomatic» because I need to press Export to Adobe Photoshop in Photo AI plugin for each image (opened in Photoshop or in folder for batch processing). And in this case I can’t use batch processing for group of images because it waits to press «Export to Adobe Photoshop» and pauses batch processing.
When using Photo AI from Photoshop Action as recorded action via direct call Filters > Topaz Labs > Topaz Photo AI… (not via Insert Menu Item and not direct call File > Automate) it’s automatic because I don’t need to press any button while batch processing group of images (opened in Photoshop or in folder for batch processing). And in this case I can do something else while batch process continues without need of my attention.