PHoto AI 2.0 - Crashes always on certain pictures

I think it has to do with face recovery…On images with faces Photo AI just disappear. No error message.
It happens when almost finished with optimizing an opened image.

E.g. this one (480p screenshot from Star Trek Voyager)

EDIT: when face detection is deactivated it’s running…

Just tried that, seems to be my problem, too. If I open a Photo without Face AI it runs…with Face AI the app crashes shortly after…

I’m not sure if the cause is the same, but I’m also experiencing sudden program closes without any error messages or warnings. If I open the program again, I can load and edit the picture I was trying to edit before (so, it’s not an “always happens with some pictures” for me), but the problem is there.

Yes, it has something to do with face recovery

Same issue, here

Same problem here:

Photo AI v2 crashes with error code 3221225477 when trying to recover faces on a group of people. This happens both when loading the image from Lightroom and when opening it directly in Photo AI.
It works fine if I manage to turn Recover Faces off.

Windows 11, i7, 16Gb RAM NVIDIA GTX 3070 with latest Studio drivers.

I managed to successfully run your image through Photo AI 2.0 with no crash.

This picture crashes on my computer as well.
What graphics card are you using?

I don’t think that this have to do with graphics card… the crash was not in 1.54.
I have tested with both: 1050 Ti + 3060 Ti. I think i tested CPU too.

You lucky one… have you set something special? There are more settings for face restoration in menu.

NVIDIA® GeForce® RTX 2060 (6 GB GDDR6 dedicated)

I haven’t really messed with the settings. I guess it was my turn to get lucky. :wink:

NVIDIA RTX3060, 128GB RAM, MSI, 12th Gen Intel(R) Core™ i9-12900K 3.20 GHz

I switched to the NVIDIA gamer driver and now Recovering Face works as it should: No crash!

1 Like

I was too optimistic; as soon as I completed the installation, the magical miracle disappeared. Photo AI is again crashing when attempting to recover faces. However, the driver’s installation did result in a brief period of smooth functionality, indicating that the driver is likely the problem.

I don’t know if this will help you but I’m using the Nvidia Studio driver; not the Game Ready driver.

Same with v2, v1 didn’t crash without an error like this new version, I have had it skip doing some of the photos in a batch and I re do only the ones it skipped and it done them (in v1) but v2 just exits randomly, mostly on face recovery/enhancement and detection stages. Turning it off did fix it from happening, but I also had Light correction crash out with no error also when I was attempting to skip the face enhancement just to try and diagnose the issues.

It was the Studio driver I had previously, but when I switched to the Gaming driver, before rebooting, I was able to run Photo AI on this image and another image with groups of people. But when I rebooted, Photo AI crashed and I got the same error code again…
I tried to reproduce this by reinstalling the Studio driver and running Photo AI without rebooting, but no: this was probably a one-off experience.

Forgot to mention I’m on Windows 10. I’ve seen a couple posts where the crashing was occurring on Windows 11 so I don’t know if that’s the common denominator or just a coincidence.

I am running it on Win 11 Home Edition.

Most of the time it crashes during the two “face activities”: Recognition and Restore. It seems to work with, say, five to six people, but larger groups, such as the black and white image we tried here, are absolutely impossible to handle; it crashes in Recognize Face before it starts working on Restore. Other images with smaller groups crash as soon as the first few faces are restored.

I am very disappointed as this feature is the reason I bought the Photo AI and I am now very close to asking for a refund.

Hang in there for a bit. Looks like the team is aware and working on a fix.

1 Like