Photo AI 1.3.1 Update Error

I am trying to update Photo AI to 1.3.1 from 1.3.0. When I try to update, the installer tells me to ensure I have access to certain folders like Topaz Labs LLC\Topaz Photo AI\TBenchmark or TCameraProfile. These folders do exist. However, their properties indicate a dash in “Read Only”, but clearing this has no effect because it seems the installer just resets this property again! When I retry, the error repeats indefinitely and my only option is to cancel.

Note that my base folder is F:\Apps\64 as opposed to C:\Program Files because I want to keep my OS drive as clean as possible. If Topaz is assuming the source folder is on C: (it didn’t for the clean install of 1.3.0), then there is NO WAY I’ll be able to install this update! Please advise.

Topaz Photo AI v1.3.1 on Windows 11 Pro

Is the F drive on an external drive?

Ho, it is an internal 8 TB IDE in my desktop PC, partitioned as D:, E:, and F:, with F:\ being 6.5 TB of the drive.

I can’t see why you are having an issue as I use a extra internal SSD as the D: drive (System is on the C: drive which is a SSD as well) where I install all EXE apps and it installs OK and runs OK. If you don’t get a response from support staff raise a support request at the man website.

This may have been happening because I was checking for updates in the app itself. After running the 1.3.0 installer in repair mode, I tried again through the app, but the error persisted. Upon downloading the full MSI for 1.3.1 and running that, the install went flawlessly. I’m now running 1.3.1 on my F: drive.

Perhaps this anomaly is related to something unique to my system, but it might be something Topaz could look into. But I’m happy now; thank you for your comments.

1 Like

Next time you try to update and get that error, please open the log folder for Topaz Photo AI and send me the installer log. I can review and share with my team so we can understand the issue.

To find the log folder, open Topaz Photo AI, go to the menu bar on the top and click the Help > Open Log Folder menu option.

I am having the same problem and using the same solution. It only started when I installed v 1.3.
I install to an external SSD.

Are you still getting an error or did the solution above work for you? If you’re getting the same error still, please gather your logs using the steps @Lingyu mentioned above :slight_smile:

Its working now with a clean install. Here is the log file
Topaz Photo AI Installer (383.1 KB)

Great! Just wanted to double-check, thanks for letting me know :slight_smile:

Thanks for sending the logs over. The error shows up in here so I passed the log to my team for review.

This should be enough information to figure out the cause.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.