Out of memory error in upgraded version 3.4.4

[If you are posting a new bug, please include the following]

I am unable to process a video due to this ‘Out of memory error’ anymore.
The application was upgraded to version 3.4.4. This error was seen in much earlier versions, but was fixed before. Now it resurfaced and i’ve tried to process the video multiple times and the same error happened.

The OS has enough memory, so not sure where this error come from.
In the preferences, i’have already set ‘Max memory Usage’ to 50%.

Hello, could you send us a note at help@topazlabs.com so that our team could take a closer look at this bug? Thanks!

The process completed fine after i’ve send the preference on memory usage to 30%.
But it was very slow.

Depending on the filters enabled, this would be expected behavior when the memory usage setting is reduced. By loading less information into memory, the process is more stable but overall slower on your GPU.

The application crashed again after 2 days of running, using this 40% memory usage.
It looks like this memory is getting used and not released and causing this crash.

Also, since you have to restart from scratch this is a critical issue, since i have to wait again 2 days…or try to split the video files.