Offline Model Downloads

As a brand new Topaz user I agree, I was trying to find model downloads and found one or two users on another site that shared pastes of seemingly all model links hosted on the official topaz domain (2000+ files/links, 100+GB total), but they were posted 9~4 months ago thus most definitely outdated by now.

This script is doing, uh, something, often insanely fast with many errors, but as another person said, it’s hard to tell what, or when it’s finished etc. I’m very confused with it.

I’ve just tried this. I placed the batch file provided by Topaz inside the Program Files-Topaz-TVAI folder, changed the Command Prompt window to that directory, and run it from there. It works but it’s slow due to the hundreds of separate files and various checks the system makes in between each downloaded file. I get plenty of ‘output file is empty’ and some other errors too, but it does work.

I have a gigabit connection and while downloading model files, there are many peaks at 200 to 400 Mbps - but the average speed due to the pauses is under 60 Mbps. It would make a huge difference if Topaz would provide and periodically update a zip file (or say half a dozen of them) containing all, or various sets, of model files. Life would be much easier then, and quicker too - for us and for the Topaz servers!

My current progress after nearly 20 minutes downloading is 197 .tz files totalling 6 GBytes so it’s slowed down slightly. I’ll probably give up if it hasn’t finished in half an hour lol.

EDIT: It’s just finished downloading after 40 minutes, with a “Stream has Ended”, and “Output file is empty” message. I don’t know if it’s everything but I now have the princely total of 313 .tz files totalling 13.6 GBytes of data. That’s less than I expected, but it’ll do nicely for now! Has anyone had more?

Thanks for the insight. How do I obtain the “batch file provided by Topaz”? Also are there any instructions on how to run such a file? Does it run from Topaz AI? I am not an IT guy, so any simple instructions would be most appreciated…

@ dave.bilger
There is batch file downloadable in the first post of this thread, you download that and then go to topaz video app and under the process tab there will be open command prompt, which you can drag the batch file into and then press enter. This is on windows.

@ any dev,
I started the process at 11am, it is now 6am on the next day and the thing is still going, is that normal? am at almost 80gb downloaded and 1386 files installed. how long is this supposed to take?

Not a dev but I ended up with only 13.6GB of .tz files, and that took 40 minutes on a gigabit connection. It never reached anywhere near that speed though, on any of the files. The biggest factor I found that slowed things down was that every file ran a server and security check before it downloaded - a single zip or 7z file containing them all would be WAY faster and would free up the server quicker too.

Will be interesting to know the total file size when yours complete, so I know how much I missed!

What’s the update on this? Need the models. Program doesn’t download models by itself!

The script is listed above, this is how you will download models for offline use.

I tried. It didn’t work. This thread is over 5 months old and still no better way?

Can you share what did not work?

This is the current path to download models for offline use :slight_smile:

Please, just post one file that’s zipped as suggested above, and the location to put the models. Simple.

Even better, have an option inside the program to download the models offline.

there used to be an option to download the models for offline use. They took it out about a year ago. Wish they would bring it back. It was SO SIMPLE.

1 Like

When will adaptation 3.5.0 be updated?

New scripts are now posted with Iris v2 and Nyx v1 :+1:


Where? Zip file available?


so…i had the day off and decided to work thru this. Here is what I found:

  1. DO NOT use the default settings for where your models are stored. It defaults to C:/Program Files which Windows considers a protected folder. Even when i tried to (using Admin) change the folder and subfolders to NOT BE 'READ ONLY"…windows kept reverting them (thanks windows). As a matter of fact, when i went into c/program files/topaz labs llc/topaz video ai…there wasn’t even a folder called “models” at all. I created that folder…then tried to use the bat file…but nothing would write to that folder.

SO…as a test i created C:/Models folder. Made sure permissions shows ‘full control’…and then started the bat file. Lo and behold i got 333 files (14.6G) in about 40 mins. I can only assume that because i didn’t have any ‘favorite’ or ‘presets’ created and saved that i just got the minimum amount of models. I did another test and ran thru an interlaced vid and a progressive vid …and after those models downloaded (during ‘preview’) I saw that my newly created ‘models’ folder contained the newly downloaded models.

For those that might be confused…here is my quick and dirty instruction set:

create a Folder called “Models” in the root of your C drive (or whatever drive you wish)
open Topaz >File/Preferences
change “Model folder” to newly created folder (browse if need be)
Save and restart (blue button on bottom)

grab bat file from top of this thread, unrar/unzip to destination of your choice
in Topaz go to "Process/Open Command Prompt
drag/drop the unzipped bat file into the command prompt window, hit Enter.

Interestingly, I did find over a dozen errors and it appears to be the same, just different addresses. I included 2 screenies here to show. I do not know if this is a true error or what…but you will see what i mean. A dev would probably know.


good job, thanks

Do you have a script for Linux?

I tried the Mac script as is since it’s just bash but it didn’t work straight off. Some error about ffmpeg.

I didn’t really mess with it, shouldn’t be too hard to convert right?

1 Like

4.0 Video AI Model Download Script

I get some errors. I’ve specificed the path to Topaz’s FFMPEG and most models download but I get errors on many models. Some examples:

[Parsed_tvai_up_0 @ 00000206D609A700] Failed to configure output pad on Parsed_tvai_up_0
Error reinitializing filters!
Failed to inject frame into filter network: Invalid argument
Error while processing the decoded data for stream #0:0


[Parsed_tvai_up_0 @ 000001F8DF3D2840] Invalid value nap-2 for model, model should be in the following list:
aaa-9 : Aliasing or Moire
ahq-10 : High Quality
ahq-11 : High Quality
ahq-12 : High Quality
alq-10 : Low Quality
alq-12 : Low Quality
alq-13 : Low Quality
alqs-1 : Strong Halo
alqs-2 : Strong Halo
amq-10 : Medium Quality
amq-12 : Medium Quality
amq-13 : Medium Quality
amqs-1 : Medium Quality Halo
amqs-2 : Medium Quality Halo
ddv-1 : Dione DV
ddv-2 : Dione DV
ddv-3 : Dione DV
dtd-1 : Dione Robust
dtd-3 : Dione Robust
dtd-4 : Dione Robust
dtds-1 : Dione Robust Dehalo
dtds-2 : Dione Robust Dehalo
dtv-1 : Dione TV
dtv-3 : Dione TV
dtv-4 : Dione TV
dtvs-1 : Dione Dehalo
dtvs-2 : Dione Dehalo
gcg-5 : Computer Generated
ghq-5 : High Quality
iris-1 : Iris
iris-2 : Iris
nyx-1 : Nyx
nyx-2 : Nyx
prob-1 : Proteus
prob-2 : Proteus
prob-3 : Proteus
thd-3 : Fine Tune Detail
thf-4 : Fine Tune Fidelity
thm-2 : Themis

If it matters, using Windows 10 updated to the latest as of this version of Topaz 4.0, Nvidia 2080ti.

1 Like

The Topaz Video AI download all models script still not working correctly as of 4.0.1 - only downloads some models. Not sure why, other people seem to have the same issue. Any advice, Topaz? Does it correctly download all models on your end?