Nyx Fast produces Error

Using regular Nyx model variant produces no error. However, Nyx Fast just place a red "Error’ message on screen.

My system profile is:
OS Name Microsoft Windows 11 Pro
System Model HX99G
System Type x64-based PC
Processor AMD Ryzen 9 6900HX with Radeon Graphics, 3301 Mhz, 8 Core(s), 16 Logical Processor(s)
Installed Physical Memory (RAM) 64.0 GB

I have attached the log file.
2024-03-13-17-53-20-Main.tzlog (42.8 KB)

Thank you

1 Like

Open the Preferences Panel>Processing and double check what is set for your AI Processor. You will want it set to your GPU card not auto or the CPU.

I also have this problem. Double checked and I’m using my GPU. Nvidia GeForce RTX 4090.

1 Like

Can you share your logs?

I have tried all variations for the processor settings: Auto, CPU, GPU, All GPU with same result. The log is attached with the original post

1 Like

I also have this problem with both Nyx and Nyz fast. I have never encountered errors in hundreds of hours of processing with any of the other AI models. But with Nyz, I can almost guarantee an error on demand - I just have to use it!!

I had not reported it previously because I wanted to make sure there wasn’t any issue with my machine of configuration that might be responsible and wanted to do a lot of fiddling with Topaz settings (such as memory allocation, etc).

I am not at my workstation at the moment but can post logs later on. They do not seem to contain anything relevant though. the logs simply say it is churning along happily and then the log ends (still looking perfectly happy)…

Sorry for the delay in reviewing the logs. Looks like its showing an invalid scale for the model for some reason. Can you send me the file to test on my end and put in front of the team for review?

You can securely submit your file(s) to our Dropbox using the link below. Please be sure to send me a note to let me know you sent something and include the file name.

Submit File to Dropbox

For what it is worth, I was finding Nyx would cause a near-instant error 100% of the time (error would occur always within a minute of starting to process the file). I have now found a workaround which is labour intensive and not desirable long term, but it has stopped the 100% error rate and it is now down to zero.

The workaround is to increase the number of processes from 1 to 2 (if using Nyx Fast) or 1 to 3 if using Nyx (v3). Nyx (v3) will still error out with 2 processes - it requires 3 but Nyx Fast seems reliable with just 2.

of course this then means I can only ever input one source file at a time and process one at a time since more than one simply results in parallel processing which I do not want (and which just causes Nyx to error out again anyway).

So it seems that at least on my setup there is something about the Nyx model that actually requires several processes even though I only wish to ever have one process. As I say it is a workaround though and luckily I do not use Nyx very often - only for already HD content that needs improvement due to low bitrate compression.

My video card is an RTX2600 Super running on Ryzen 2700+ Windows 11.

As promised, here is my log when the Nyx error occurs. The error rate is 100% So that is good from a testing point of view. Infact when this particular error occurred, every single job in the queue spontaneously errored out once the first job did (which usually happens anywhere from instantly to 10 minutes in).

The only workaround I have found (100% “success” rate so far) is to:

  1. Reboot machine
  2. Chnage number of processes from 1 to 3 (as in the not recommended setting)
  3. Load one single source file into Topaz that requires the Nyx processing.
  4. Process the single job (no previews or a short run of any segment since any more than one single Export or Preview run on the file no matter how small will subsequently produce the error on the actual run).
  5. Once done, reboot machine and repeat.
  6. Once the Nyx processing is done with, reset processes back to 1 and proceed as normally with multiple jobs if needed.

As previously mentioned I have literally been running Topax almost non-stop for two months on this machine with a 0% error rate. But Nyx has produced a 100% error rate. The other models I have used with zero issues are Artemis, Aion and Proteus though I have also used a few others merely for experimentation purposes.

logsForSupport.zip (257.1 KB)