Newest Denoise AI updates have worse performance

The lastest 2 updates to Topaz Denoise AI (2.2.1 and 2.2.2) have seriously degraded noise reduction performance for me in Denoise mode. I was very happy with the results I was getting with NR settings in 15-20 range removing most noise from my images. Since the upgrade, it takes 50-60 to get acceptable noise reduction, but I still see a lot more residual noise than before. AI Clear works much better but I don’t like its sharpen effects as much.

I would like to roll back to earlier versions of Denoise AI. Is there a way to do that?

I am using a Windows 10 desktop with a powerful graphics card.

Mike Moore

Please go to Help-> Graphics info in DeNoise, press Copy and paste the info here.

Which version?

In version 2.2.2 turn on the low light mode and it will boost the noise reduction. this may solve your issue without going back to an earlier version. I also noticed that setting GPU memory usage to medium in the preference menu produced better results than high. My video card is a Radeon RX580 with 4GB of memory so it may not hold true of all cards.

Here is the information

Application & Version: Topaz DeNoise AI Version 2.2.2

Operating System: Windows 10 (10.0)

Graphics Hardware: GeForce GTX 1060 6GB/PCIe/SSE2

OpenGL Driver: 3.3.0 NVIDIA 432.00

CPU RAM: 32703 MB

Video RAM: 6144 MB

Preview Limit: 6906 Pixels

I think I noticed the problem starting with 2.2.0 but I can’t be sure. I would probably like to go back to 2.1.6 since I am pretty sure that was working great for me.

I tried low light mode, but it did not do make much difference for me. I am a nature photographer and most of my photos are in bright natural light.

You can try an earlier version here: DeNoise AI 2.1.0

I used the link provided and downloaded 2.1.6. I uninstalled 2.2.2 and installed 2.1.6. I tried the older version and it did not help so I am really stumped.

I even went back and tried it on some older images wondering if my camera was recording noiser images, but DeNoise still does not do the job I remember it doing a couple of months ago. Luckily I get good noise reduction results with AI Clear (MUCH better than with DeNoise). At this point I have no idea what is going on.

This is what I get with DeNoise AI at Remove Noise 30 and Sharpen 48 on an ISO 1600 image from my Panasonic G9. The noise is about the same just larger grained. If I use AI Clear all this noise is removed. Note the image is out of focus so don’t worry about that.

And here is a crop from an image from the same sequence I processed a month ago. Almost no noise. I don’t remember the settings but the NR was less than the above image. No idea why it stopped working like this.

I think its working but the settings may have been changed. Probably some complained that it was too strong on low noise pictures. If you use the Low Light mode which just increases the strength, it will help. Below is you first picture with Low Light off and Reduce noise =59 and second is with it on but same settings. Clearly a difference.
Low Light mode = off:

Low Light mode = On:

I thought I had tried Low Light ON before without much difference, but trying it now I do see a big difference so I guess I will use that going forward and see how it works. My main complaint was that I was using settings around 20 before and with the new version was having to go up to 60+ but that is consistent with them dialing down the strength.

I hope it works because I find the sharpening applied by DeNoise AI to be more natural than that applied by AI Clear.


1 Like

I used the link provided and downloaded 2.1.6. I uninstalled 2.2.2 and installed 2.1.6. I tried the older version and it did not help so I am really stumped.

If you tried a previous version and get different results than when you had it installed before then you have to think about other things that may have changed in the meantime. Did you update any drivers? Add any new TSR apps? Computer hardware changes? Different camera RAW settings?

Please update your driver from the NVIDIA website then reset the calibration under Advanced Preferences and see if that makes a difference.

Also, if you use Low Light Mode start with Auto settings for DeNoise AI. In fact always start with Auto settings as it is a viable starting point.

I figured it out. I had started adding +15 vibrance in ACR. Turns out this is a very bad thing to do before running DeNoise AI. Now that I am not doing that I am getting my old performance. I appreciate all the help figuring it out and should have known it would be something I did. Adding saturation is fine, but vibrance seems to be very bad for some reason. Of course, that might be specific to the kind of noise my camera generates. I still have to use low light mode, but when I do I get the same level of NR as before.

I am thinking the best workflow might be to run ACR twice. The first time with everything at 0, then run Denoise, and then apply ACR again with my presets.

Thanks again!