Mask AI v1.2.0

Download:

Released April 22, 2020.

Major Features

  • New Installer experience
  • Improved models
  • Improved tutorial experience
  • New tutorial: “Refinement”
  • Improved file menus
  • Icons now optimized for system scaling factor

Fixes

  • Fixed bug where trimaps were not saving properly pre-first compute
  • Fixed bug where system open dialog would pop up after closing an image

Known Issues

  • Selecting auto-detect crashes on High Sierra Macs

Hotfixes
v1.2.1:

  • Fixed issue where program was unable to open for MacOS 10.12 and 10.13 users

v1.2.2:

  • Fixed OpenVINO startup issue on Windows

v1.2.3:

  • Fixed bug where auto-detect would not work on MacOS 10.12 or 10.13
  • Fixed bug where trimap drawing would not be processed if auto-update is unchecked
3 Likes

Please note there is no Update found through the application.

image

The Windows Online Installer works, but after about 10 minutes downloading steps 1 through 6 it stopped 2 minutes short of completing the last step. After a long wait I gave up, closed the installer, and ran it again. The second time went faster, and took about 6 minutes downloading just step 5 again. It then installed and the updated program runs fine.

It starts the first time by automatically running the tutorials, but the first one gets hung up because it runs the CPU/GPU optimization check in the middle of the lesson. It would have been better if I had set the preferences manually before the Tutorial ran.

1 Like

No updates available from within application.

Using Full installer it took less than 2 minutes from the start of installation.

I will try changes later on today.

I had the same experience.

1 Like

2020-04-23_13-51-47

4 Likes

This is exactly what I get03%20PM

Topaz MaskAI installed and opened without any problem, but when I attempt to log in I receive a message saying a timeout error has occurred. It only comes up with that error after several minutes so it would appear that it is probably correct. I have a good internet connection here so I can only assume the server on your end is overloaded.

I get exactly the same messages. Older version works fine however. Mac 10.13.6

This Mac installer is not working,please advise.

I am not in the Mask AI beta testing as I do not hold a licence for it. I have just downloaded the full installer to trial it with a view to purchase, and it is crashing on me as did De Noise AI and Sharpen AI when I was beta testing them.

1 Like

I just noticed that this version has a couple of non-functional beta plug-in files included (kicks up a Photoshop error). I think we went through this with one of the DeNoise updates a while back, and the guidance was to find the two offending files and delete them. Hopefully they will always remember to remove these from any future updates.

Same!

I have the same issue on my Mac Pro running High Sierra. A clue from the crash report is the following:


Termination Reason: DYLD, [0x3] Wrong version

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @rpath/liblzma.5.dylib
Referenced from: /Applications/Topaz Labs LLC/*/Topaz Mask AI.app/Contents/Frameworks/./libavcodec.58.dylib
Reason: Incompatible library version: libavcodec.58.dylib requires version 8.0.0 or later, but liblzma.5.dylib provides version 6.0.0
______________________________________________-

Does this give a clue to what the problem might be? looks like a library dependency issue with the wrong library being present.

I’ve had quite a bit of trouble with Mask AI v1.2. I’m running Mac Catalina. The on-line updater simply didn’t work, returning something like “did not recognize image.” The full updater works fine. Unfortunately when I finished, I uninstalled v.1.1.

I ran a quick test, stand-alone. However, running it as a plug-in has proved to be impossible. I cold-booted, and re-installed to no avail. It crashed repeatedly, leaving no error message. The Photoshop message simply said something like “Plugin crashed.”

Fortunately, I am still able to run ReMask.

Mask Ai upgrade installed OK but it won’t accept my valid login and password - A SOCKS message.
Installing Mask AI has been a frustrating experience since I first bought it.
Now an upgrade has disabled my sign in.

Just got the email that a new version of MASK AI was available and should be downloaded/installed from the email link. I did so and 35 minutes later the new MASK AI started up with an automatic tutorial that I really didn’t want to watch but hey, OK. First tutorial worked fine, when the second tutorial started, as soon as I pressed Detect subject (as prompted) the program just failed and went away. After some searching I found a “TIP” on this sight that I have to update my Geforce GTX 1060 6 GB video card driver. I followed the steps to get to the GeForce driver update page. And here I wait, stuck waiting for that page to detect my GPU and select the driver to download. I’m about fed up with TOPAZ. I bought all your products, had to buy a new computer with a better than recommended video card and now you send out a “revised product” without any warning that video cards must again be “updated”.

Successfully installed Mask AI v1.2.0. Ran program and it ran thru the demo and then did some cpu/gpu testing and successfully completed it.
I then started LR Classic (latest version - and verified that it is latest) , deleted the Edit In preset for Mask AI, created a new preset for Edit In Mask AI, saved, exited LR & rebooted windows.
From LR, executed Edit In | Topaz Mask AI. LR created a .tif (from the raw/CR2 image) and launched the module.
Did a test mask (blue, green, red) and then selected Compute Mask. Started with Processing Mask at 11% and stayed there. Then the module simply closes and goes back to LR, with no changes made to the creaed .tif file.
Looks like a bit of a bug here.

There is no problem in installing for me. However it does keep on clashing as a plugin in photoshop. Even in the standalone, I can’t make refinement or adjustments to the mask.

I am using the latest Catalina on a iMac of 2019 with i9 , 64 Gb ram and a Radeon Pro 580X 8 GB graphic card.

That is a bit over blaming Topaz for problems on the NVIDIA website … there is no need to use auto detect as that will need you to accept a install on your browser. Just enter the details in the search box on the page.