Lightroom Classic - Plugin Extra - Error Code: 512

Installed the newest Topaz Photo AI and trying to open it via plug-in extras gives me an error code: 512. Lightroom Classic is the newest version and running on Sonoma 14.3 M2.
Unfortunately I could not get it to work so far. Opening as standalone or exporting as TIF no issues.
2024-01-28-16-04-58.tzlog (32.4 KB)

Let’s try to reset your Lightroom plugin to try and get it working for you. You can follow the directions below to reset your Lightroom plugin:

  1. Close Lightroom fully.
  2. Run the Topaz Photo AI installer again. Get a new one from the downloads page: Topaz Labs Downloads
  3. Open Lightroom and check the File > Plug-ins Extras again.

Let me know if those steps get it working again.

Hi John,

Unfortunately, still the same behavior.

Best, regards, Sascha

Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

First make sure that any plugin like Lightroom is fully closed.

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.

Hi John,

Still not working.
Deleted plist files from Lightroom and Topaz. Created new Lightroom Catalog, restarted Mac, but all no help.

Any other ideas?
Thanks for help.

John, I have the same problem. Any suggestion?

Hi, I have the same issue. Went through the process; still when I try to open the file into Topaz Photo AI, I get this error message

All the suggested steps have not helped and even installed Sonoma 14.3.1 from scratch. I have downgraded to PhotoAI 2.2.2 and then it is working. However, as soon as I upgrade to 2.3.0 or 2.3.1 = Error:512. Therefore I hope it will get addressed with 2.3.2.

@sascha.gammeter @angharad.elliott @giuseppe.de_filippo

Please reach out to us at the following link as we would like to try and troubleshoot this and try to find a solution for you all:

Topaz Labs | Support Page

This topic was automatically closed after 59 days. New replies are no longer allowed.