Latest Studio 2

Opened Studio 2 and it told me there was an update.

It took two iterations of splash screens before it would update, an old bug that keeps recurring.

Opening Studio 2 and loading an image was fine (standalone). Calling Studio 2 from ON1 which, up to now, has worked perfectly and is part of my main workflow, crashed. Every time. So, I can not longer use Studio 2.

Mac Mojave o/s.

Having the same problems with double installation and crashes when called from On1, worked from Lightroom. Will submit a bug report on this tomorrow (evening here in Australia).

Also the deterioration of the image after just adding the Precision Detail filter, which I have bug reported a couple of times, has got worse.

Not sure what this release has done to deserve being called 2.1.0 not 2.0.14.

I’ve reported Precision Detail Filter several times, it hasn’t worked for some time and it doesn’t work well in TS1 either. It used to be one of my go-to filters.

Yep, Precision Detail is not a filter I’d be chosing to use anytime soon.
Just thought it was me, glad to know I’ve not competely lost my eyesight.

It may be a Mac issue so you should raise a support request at the main website, on Win 10 I don’t seem to have an issue as you can see from the screenshot … off on the top and on, on the bottom:

“May be a Mac issue”??? What does that mean? It should work on all platforms.
I had TS2 on my Mac but it updated twice in a few hours and then the updater froze. Tried to reinstall but the clean re-install broke down and I am now fed up with offing around with it. Topaz boys get it sorted please.

1 Like

If you read the thread the reply was about the Precision Detail filter not about the updater.

And there are many issues on many products, not just Topaz, that have unique issues both on Mac OS and Windows 7, 8.1 or 10.

While it may only be a Mac issue it is occurring and has been doing so for some time.

I submitted a bug report for 2.0.10 and, eventually, Topaz managed to see the same effect. It seemed better in 2.0.11 but then got worse again in 2.0.12. I have supplied Topaz with images, screen recordings etc.

The level of distortion seems to be imaged based. Every image that I have tested undergoes a change just by adding Precision Detail filter with default values, however some images suffer less than others, but all look worse with the filter added and I haven’t been able to adjust settings to get any improvement.

I have seen similar issues with detail sliders in Adjust AI.

I am using an 18 month old iMac with 32 Gbytes running the latest release of Mojave. As far as I am aware there is nothing special or unusual with my set-up and everything else runs normally.

I have tried to include example screen shots but system is not allowing me to include images in my reply either by uploading or by pasting. If someone can let me know how to do this I will post them later.

1 Like

I concur. It may work on Windows, it definetly doesn’t work on a Mac. If it was a 'Mac issue" then we’d see something similar happening is other photo software.
Its a “Topaz Studio” issue on a Mac. It needs to be fixed, or removed.

1 Like

Hi,

I opened a support request back on August 6th earlier this year regarding an issue when using Precision Detail filter in Topaz Studio Two.

I’m running macOS Mojave V10.14.6 and both my previous versions of Studio 1 and Studio 2 had no issues when applying Precision Detail adjustments. Which suggests the problem is not with the Mac OS. After having run the latest updates from Topaz Labs on their Studio software versions 1 and 2, the Precision Detail filter now mysteriously applies an effect to the image before making any adjustments. There have been no changes to the macOS, nor have I loaded any other software.

If you click on show original, the image will temporarily revert to its normal state. However, the softening effect being applied can’t be removed, reset or adjusted - rendering the Precision Detail filter useless. Several of the sliders in Precision Detail are ineffectual in their operation.

I’ve followed up several times, requesting an update on progress with no response after the initial statement of your case is on hold and we will let you know when its fixed. I’ve no problem with that and I understand buggy software does take time to correct.

My gripe is the lack of customer communication, with not a single courtesy update in two months - despite several follow up emails.

So, Topaz Labs; I’m not the only one with this issue, and others are getting frustrated as well… Not what I’d expect from a company promoting themselves as developers of professional software.

How about letting us know what’s being done to fix it? Rather than leave us in the dark which only compounds frustration and reluctance to continue supporting your products.

Same issue here. Same Apple OS. Using Lightroom as “home” editor. Crashes every time I attempt to open an image in TS2 from LR. Sent problem to Topaz Labs including line-for-line problem report generated my my iMac. No response as of yet. Seems like the return of the old 2.0.12 issue that makes TS2 essentially worthless in my workflow. This is getting to be seriously ridiculous.

1 Like

Hi Paul, I presume you are exporting in TIFF to TS2?
If so then I have the same issue. Loosing interest in making TS2 part of my workflow.
Just for the ducks of it, I changed to a jpeg and srgb and surprisingly it loaded and worked.
I have no interest in working with 8bit, but find it intriguing it will work.

Hope a solution is forthcoming

I can’t edit any image in TS2 from LR using “Photo- Edit in- TS2”. It keeps crashing. This was my former workflow and it worked fine. I don’t want to have to move every image to the desktop to pull it into and edit it in TS2. I’m close to pulling the plug on this program, even after the small fortune it cost.

1 Like

4 posts were split to a new topic: TS2 Installer on Mac

Having same problem where it takes two attempts/splash screens to update and it crashes each time TS2.1 is called from LR Classic. (iMac 5k OS 10.14.6)

1 Like

A post was merged into an existing topic: TS2 Installer on Mac