Latest PhotoAI (2.1.2) almost unusable due to frequent crashes

Installed the new version of PhotoAI today and it’s gone from being completely stable in the previous release to almost unusable, it’s crashed on me about seven time so far this evening!
Steps to reproduce issue:

  1. Load photos (100+MB Tiff files)
  2. Process images (it may crash during this process)
  3. Save images (it may crash here as well!)

Also, what’s going on with the UI change so that by default with multiple images, only the last one is saved by default unless you back an reselect “Select All”

Topaz Photo AI [v2.1.2] on [Windows 11]

1 Like

I have the same problem,When processing multiple files, it crashes after 3-7 pictures.

Are you using Intel graphics? Turns out I had forgotten to make PhotoAI using my NVidia GeForce 2060, and switching to that GPU solved the problem which makes me think it’s an Intel driver issue.

I am using intel 1135g7, Iris® Xᵉ display

nicholas.simpson via Topaz Community <> 於 2023年11月26日 週日 下午5:36 寫道:

Try updating your drivers to the latest.

I have the same problem and I run Topas Photo AI on a Lenovo laptop with Intel iRIS Xe graphics videocard and Intel i7 1165G7 processor with Windows 11.
My solution so far has been to go back to version 2.0.0 which works fine.

Did you check whether you’re running the latest Intel grpahics drivers?

My Lenovo assistent-app says nothing about an update for the Intel graphics driver.
Intel on the other hand says there is a new driver available, but this will override the Lenovo settings. They recommend to stay with the Lenovo assistent.
So I’m not sure what to do?
Any suggestions?

I’ve never had a problem installing the Intel drivers on laptops rather than those delivered by the vendors that often lags months behind the Intel release.

I installed the newest version of the graphics-driver from Intel and updated Topaz Photo AI from 2.0.0 to 2.1.2.
And guess what? It worked!
So now I’m back in business with the latest version.
Thanks for your help, Nicolas.

I had previously crash while editing some picture (resaving that image with another software was looking to solve that problem, but very time consuming) but now the app just hang at save. I’ve tryed to save in different format but it still hang at processing. At least it doesn’t crash, but unusable. Very frustrating.

Chiming in that I’m having this issue too, but with different hardware. I’m using a 5800X3D and RX 6600XT with 8GB VRAM, and 16 GB of Ram. I’ve only just started experiencing this, so not sure if it started because of the 2.1.4 update or that I’ve been using the remove tool for the first time. Both coincide with this frequent crashing, and always happens while using the subtract tool. It doesn’t seem to be an issue of running out of resources and happens even during low workload times like masking for the removal. It was set to auto mode, but I’ll try setting it to force GPU only processing just in case.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.