Information: Unable to run the selected model

I’m trying Video Enhance (2) for the first time. After dropping in an mov video shot at 1080p 30 fps on a DSLR and going through all the settings, I get an error message after clicking Start Processing:

Information: Unable to run the selected model

Trying to enhance detail and upscale to 4K UHD with Artemis Medium Quality V11, but all models gave me this error. Tried saving as mp4 and mov.

Running Dell XPS 8930 with Win 10 Home 64 bit 19042, i7-9700 CPU and 32 Gb memory. Graphics card is NVIDIA GeForce GTX 1070 with 8 Gb vram (drivers updated today).

Please, can anyone suggest a solution?

I have had this happen a couple times and it turned out to be a problem with the input file.

  • Make sure you have the codec installed that the video requires
  • Try playing the video in some other player like VLC and see if it reports any problems.
  • Try remuxing it with MKVToolNix.

Thanks, jamietre

I seem to have the right codecs installed and the test video plays in Windows media player. I found that the tutorial also does not run VEAI, with the same error. Windows event viewer seems to indicate a “windows resource exhaustion” problem- low virtual memory- even though I’m using the graphics processor. I will increase virtual memory and try again.

It was the virtual memory problem. My C: drive is SS and virtual memory management was set to OFF. I turned it on and VEAI worked as expected.

Thanks for your suggestions!

I have the same problem. I have checked the event viewer and i see the error: Display driver nvlddmkm stopped responding and has successfully recovered. When I switch over to CPU works fine.

I had this problem too–kept displaying “Unable to run this model” for anything other than 2.00X. Topaz Support asked me to update my nVidia drivers, then set File > Preferences > Max VRAM Usage to “Medium/Low” or “Low”.

Once I did this, I was able to select 4K UHD for upscaling.

I tried to create a new thread, but must not have (earned?) permission to do so.

I too am getting “unable to run the selected model” error when trying to use my graphics card. Works fine with CPU, but slow as heck; it took 1.5 days to do a 25m video from 480p to 1080p, 30fps. I have a GeForce GT 640, which according to supports DirectX 12 but feature level is/was only 11_0; not sure if this is software updatable in more recent driver releases than the time of their review.

I tried/verified the following:

  1. Virtual memory is enabled/system mananaged/not limited.
  2. Tried setting max vram to low.
  3. Tried a couple of different models.

Is there a troubleshooting guide? Any other ideas/thoughts?

Have the exact same issue with my i9 10900 and RTX 3090, not sure if this is an issue with the setup itself or drivers related (I had the Resize BAR big update with OpenCL 3.0, etc)

So, I think this is something Topaz guys should take a look at


You should turn off resize BAR. VEAI cannot run with it turned on

I also have the same problem by using the RTX3090 and 5600x, and this problem is occurred after I update my GPU bios for the Nvidia resize bar feature.

So it definitely not compatible with VEAI 2.1.1 version, but the biggest problem is that turn off resize bar still not working…

1 Like

Yeah I think that’s a drivers compatibility issue

Really irritating that I have to roll back from 465.89 to 461.40 (At least that’s what I rolled back to…) in order to properly use this bloody program… the fact that they neglect to fully take advantage of the 3k series GPU, with advanced AI built into the GPU itself is mind-bogglingly absurd!

That’s why Nvidia has “Gaming Driver” and “Studio Driver”.

There is another thread have discussed this issue, and the solution is simply switch Game Ready Driver to Studio Driver. It works for me right now, you can try it out.

I’ll wait as I use this computer for other stuff and having drivers that focuses stability will cause me problems on other parts (probably not).

My question now: Is there any benefit for this software to use the advantage of Resize BAR as I see there are AI models sharing CPU/RAM with GPU/VRAM?

I read in a previous thread that it made no difference with either the game ready and studio driver, I’ll give it a go just so I can cover all my bases while still being up-to-date… plus, it wouldn’t hurt to have the studio driver as I am a 3D artist after all! :smiley:

EDIT: Just installed the studio driver, but then again, it’s at version 461.92 the same as the previous game driver, so that may or may not be the reason; as it is version 465.89 that conflicts with most of VEAI’s models… regardless, I’m sticking with this driver as I have some rendering I need to do! :slightly_smiling_face:

I am having this problem but have no idea where to locate and turn off resize BAR?

I am STILL having this same problem now!!

Trying to upscale a 1080P video to 4K resolution (2x) using Artemis v12. Fails randomly after less than a minute.

Hardware: Ryzen 5950X
GPU: Aorus RTX 3070
Software: VEAI v2.1.0 and then upgraded to latest v2.1.1 (same problem)
NVidia drivers: previous and latest 466.11
Resizable BAR: Not enabled (did not update firmware for that yet)

Artemis v12 also failed for a previous 1080P video that successfully upscaled using Dione Interlaced DV v2.

I retried the previous video with Dione Interlaced DV v2 in latest version and IT FAILED TOO NOW.


I presume this means GPU conversion does not work at all now?

How can I run VEAI upscaling successfully? Is this a known issue???

Will try CPU processing but now it is telling me that what the GPU could do in 18 minutes is now going to take 3 hours 52 minutes on a Ryzen 5950 16-core CPU !!!

I downloaded and installed the latest NVidia Studio drivers v462.31 and re-ran this 1080P Artemis v12 conversion on 3070 - and it worked.

Looks like latest Game Drivers are broken. Hope NVidia finds problem before this is released to Studio drivers in a future update!

1 Like