Video Enhance AI v2.3.0

I copied the name and I copied too much, I didn’t see that, and with “6” it looked ok :sweat_smile:

I’ve found a serious bug. Your initial unrendered frames contain erroneous compression artefact. If I import a video I get compression artefacts that are not there if I use a different tool first to decompose the video into lossless PNG frames. I confirmed the difference in the top left ‘unrendered’ comparison view box. This bug was not present in at least 1 version from last year (old renders used for comparison).
Source video was H264 MPEG4 AVC, color ITU-R BT.709.

Quick question. I just noticed in my installed files there are multiple installations totaling like 60 gigs of space. Does VEAI not uninstall its old version when updaing? Is it ok to uninstall the others?

So… Anyone using VEAI there?
I’ve got a strange bug since 2.2.0 when i can’t set an output format correctly. I’ve noticed 2 of my last upscales are in JPG format where i requested PNG (i’m using an AHK script that sets it so there’s no mistake on my end). Here’s an example of a CMD call that runs JPG upscale regardless of what i’ve set:

"veai.exe" -i "path\test.mp4" -f png -o "path\" -b 101842 -s 1.0 -m alq-13 -c 1

I’m pretty sure that’s incorrect place for an “-f” argument, but putting it in a right place like this:

"veai.exe" -i "path\test.mp4" -o "path\" -f png -b 101842 -s 1.0 -m alq-13 -c 1

…results in

Error: You must enter a output format

-f, --output-format < mp4 | mov | jpg | png | 8tif | 16tif >
mp4 - H.263 encoded video file (low-quality)
mov - ProRes HQ encoded video file (high-quality)
jpg - for 8 bit compressed jpg sequence
png - for 8 bit lossless png sequence
8tif - for 8 bit uncompressed tiff sequence
16tif - (default) for 16 bit uncompressed tiff sequence
* 16 bit tiff is usually rather large, please make sure you have enough hard >drive space available

Error: invalid output format.

Putting “png” after “-f” into quotation marks doesn’t fix it either. I’m currently downloading 2.3.0 to check if it’s changed, but there’s nothing about it in release notes anyway.
Could someone test that for me? Thanks!

Okay, i’ve found the problem: it’s either a 2.2.0 having this bug or a closing slash in the output path. Upgrading to 2.3.0 and removing the slash fixed it.

I find VEAI and Topaz pretty unstable, it always crashes at least once for a random movie (1h 30m+ long) rendering Topaz UI (it won’t restart and just silently die, making you restart it manually) and MOV\MP4 export completely useless (as it produces a broken file after the crash).
So i use a custom AHK script that is running a PNG frame sequence upscale and is monitoring the process, relaunching it where it died after the crash.

Here's a typical log from my tool
10.06.2021, 11:29:00: Log 20210610112900_Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP.mkv_.log created.
10.06.2021, 11:29:00: Starting...
10.06.2021, 11:29:00: Input video: A:\MEDIA\Public\Films\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP.mkv
10.06.2021, 11:29:00: Output folder: S:\FRAMES\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP
10.06.2021, 11:29:00: Using device: 1
10.06.2021, 11:29:00: Using model: ahq-11
10.06.2021, 11:29:00: Using scale: 2.0
10.06.2021, 11:29:00: Numbers of frames done: 0
10.06.2021, 11:29:00: Calling ffprobe... Now wait...
10.06.2021, 11:29:00: Total frame number unknown - trying slow ffprobe...
10.06.2021, 11:50:41: Numbers of frames to process: 172071
10.06.2021, 11:50:41: Calling VEAI...
Running parameters: "C:\Program Files\Topaz Labs LLC\Topaz Video Enhance AI\veai.exe" -i "A:\MEDIA\Public\Films\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP.mkv" -o "S:\FRAMES\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP" -f "png" -b 0 -s 2.0 -m ahq-11 -c 1
10.06.2021, 11:50:41: VEAI running as PID 14068 on GPU 1
10.06.2021, 16:18:50: VEAI closed on frame 18959 out of 172071 on GPU 1...
Running parameters: "C:\Program Files\Topaz Labs LLC\Topaz Video Enhance AI\veai.exe" -i "A:\MEDIA\Public\Films\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP.mkv" -o "S:\FRAMES\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP" -f "png" -b 18959 -s 2.0 -m ahq-11 -c 1
10.06.2021, 16:18:50: VEAI running as PID 3936 on GPU 1
10.06.2021, 21:49:11: VEAI closed on frame 42304 out of 172071 on GPU 1...
Running parameters: "C:\Program Files\Topaz Labs LLC\Topaz Video Enhance AI\veai.exe" -i "A:\MEDIA\Public\Films\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP.mkv" -o "S:\FRAMES\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP" -f "png" -b 42304 -s 2.0 -m ahq-11 -c 1
10.06.2021, 21:49:11: VEAI running as PID 5320 on GPU 1
11.06.2021, 18:42:26: VEAI closed on frame 130441 out of 172071 on GPU 1...
Running parameters: "C:\Program Files\Topaz Labs LLC\Topaz Video Enhance AI\veai.exe" -i "A:\MEDIA\Public\Films\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP.mkv" -o "S:\FRAMES\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP" -f "png" -b 130441 -s 2.0 -m ahq-11 -c 1
11.06.2021, 18:42:26: VEAI running as PID 728 on GPU 1
11.06.2021, 18:43:36: VEAI closed on frame 130500 out of 172071 on GPU 1...
Running parameters: "C:\Program Files\Topaz Labs LLC\Topaz Video Enhance AI\veai.exe" -i "A:\MEDIA\Public\Films\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP.mkv" -o "S:\FRAMES\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP" -f "png" -b 130500 -s 2.0 -m ahq-11 -c 1
11.06.2021, 18:43:36: VEAI running as PID 14976 on GPU 1
11.06.2021, 19:26:08: VEAI closed on frame 133243 out of 172071 on GPU 1...
Running parameters: "C:\Program Files\Topaz Labs LLC\Topaz Video Enhance AI\veai.exe" -i "A:\MEDIA\Public\Films\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP.mkv" -o "S:\FRAMES\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP" -f "png" -b 133243 -s 2.0 -m ahq-11 -c 1
11.06.2021, 19:26:09: VEAI running as PID 18556 on GPU 1
11.06.2021, 19:41:40: VEAI closed on frame 134228 out of 172071 on GPU 1...
Running parameters: "C:\Program Files\Topaz Labs LLC\Topaz Video Enhance AI\veai.exe" -i "A:\MEDIA\Public\Films\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP.mkv" -o "S:\FRAMES\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP" -f "png" -b 134228 -s 2.0 -m ahq-11 -c 1
11.06.2021, 19:41:40: VEAI running as PID 20112 on GPU 1
12.06.2021, 0:00:53: VEAI closed on frame 151256 out of 172071 on GPU 1...
Running parameters: "C:\Program Files\Topaz Labs LLC\Topaz Video Enhance AI\veai.exe" -i "A:\MEDIA\Public\Films\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP.mkv" -o "S:\FRAMES\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP" -f "png" -b 151256 -s 2.0 -m ahq-11 -c 1
12.06.2021, 0:00:54: VEAI running as PID 5852 on GPU 1
12.06.2021, 3:47:07: VEAI closed on frame 165938 out of 172071 on GPU 1...
Running parameters: "C:\Program Files\Topaz Labs LLC\Topaz Video Enhance AI\veai.exe" -i "A:\MEDIA\Public\Films\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP.mkv" -o "S:\FRAMES\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP" -f "png" -b 165938 -s 2.0 -m ahq-11 -c 1
12.06.2021, 3:47:07: VEAI running as PID 9960 on GPU 1
12.06.2021, 3:55:28: VEAI closed on frame 166458 out of 172071 on GPU 1...
Running parameters: "C:\Program Files\Topaz Labs LLC\Topaz Video Enhance AI\veai.exe" -i "A:\MEDIA\Public\Films\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP.mkv" -o "S:\FRAMES\Repo.Men.UNRATED.2010.1080p.BluRay.AC3.DTS.RUS.ENG.x264-EbP" -f "png" -b 166458 -s 2.0 -m ahq-11 -c 1
12.06.2021, 3:55:28: VEAI running as PID 20720 on GPU 1
12.06.2021, 5:22:40: VEAI closed on frame 172076 out of 172071 on GPU 1...
12.06.2021, 5:22:41: 172076 out of 172071 are done. VEAI is most likely finished and "missing" frames are actually ffprobe mistake.

But it’s not in a good shape now since i can’t export PNGs…

1 Like

VEAI seems to be completely unstable for me, at first everything appeared to be running fine apart from getting the “Unable to run the selected model” issue which was seemingly fixed by installing the latest Studio Drivers (471.11) however the Dehalo model would not load at all regardless of settings (CPU/GPU, VRAM allocation, Reduce Model Load etc) and would simply just say “Unable to load selected model”. I had also been using the Artemis-LQ model without issue until I tried using the Artemis-LQ model with some 4K footage and it failed to load which also broke it completely as now regardless of what I do it fails to work with the same “Unable to load selected model”.

Using the 471.11 Studio Driver with a 3090

Here’s another example of it (Disney’s Robin Hood). Seems to occur more, or at least be more obvious in uniform red/orange regions. If I can find a more striking example I’ll post it. Top and bottom are same model. Top is video directly into Topaz. Bottom is FlowFrames frame extraction PNG frames as source.

Another example, a little clearer what I mean. No render applied, but TOP = video import, BOTTOM = PNG frame from video exported by FLOWFRAMES (before applying any time scaling.). I do note a slight difference (<1%) in the number of frames between the two methods.

I used Chronos two times on the same video file. In the first attempt I went from 60 fps to 120 fps and inserted the original sound again, all okay. In the 2nd attempt I went from 60 fps to 150 fps, inserted the original sound and it did not match at all.

the reason its not matching is because for some reason chronos is stretching the footage, im glad to see im not the only one who experienced this issue. thanks for sharing your experience. I hope a developer is looking at this feed so that they can report there is an issue with chronos. Also this same bug happens to me on the dtd models that interlace that doubles the frame, it never keeps the video length the same. Its supposed to double the frames but it shouldnt be making the video longer. Please devs look into these two issues.

1 Like

I haven’t checked the length of my video after processing but you are right. When I inserted the original sound it ended long before the video, so the video must have been stretched!

1 Like

At one time it didn’t, then it did, now it still does (if you choose clean installation), but it doesn’t do it well.

Flowframes has support for this. But it’s a bit prone to artefacting. Works well when it works however.

Is it better to first deinterlace with interlaced tv and then proteus?

Has anyone noticed how Videos processed with 6 channel aac (maybe all formats: ac3, dts, etc???) audio in MP4 always come out in 2 channel only??

1 Like

Both Artemis and Proteus models have

  "interlacedFrames": 0,

at the top of the JSON. (C:\Users\[USERNAME]\AppData\Roaming\Topaz Labs LLC\Video Enhance AI\models\proteus-b-1.json)

I wonder what would happen if it was changed from 0 to 1 and you passed interlaced video through it?

Really I don’t know… I haven’t tried… it might not do anything, this might be a setting that would be used in the future maybe? Or maybe it does something now? Only one way to find out!

You must considere that actually the audio part of VEAI is there just for… Art ? lol.

so yes, actually, the audio part is transcoded in stereo AAC, and doesn’t support any great bitrate or multichannel or anything. i’m sure it’s on the list of a future release, but for now, it’s not.

Can you send me your logs?

2021-07-06-18-25-38-Main.tzlog (33.9 KB)

Here it is, first I load a video, then set auto with Proteus and it works fine then I remove the video and load another one and as soon as I click again the auto button the program crashes without even any error message.

the Topaz team told me that an improvement on the audio quality will happen in the may 2021 as far as I remember but it was a bit delayed unfortunately. :neutral_face: