How to update Studio 2

I just received an email that says “We’ve updated Studio 2, now with the Heal Tool, Mask AI integration, and improved raw handling.” When I click the download link, my only option is “Buy now - $99.99”.

There’s also a link to “see what changed” but that goes to a description of the initial studio 2 release. And there’s a link to see if I am eligible for free upgrades - I am not.

This strike anyone else as kinda craven and/or kinda screwed up?



I’m annoyed. I used to have the “Heal Tool” but now you want me to buy it as part of a package? Oy vay. I just don’t believe what has happened to Topaz. I have heal tools elsewhere. Guess I’ll go back to that.

1 Like

Do you already own Studio 2?

Yes I do

Yes, I do.

I am not sure but all I did was go to downloads and download the updated installer and it installed OK.

Instead of clicking on the name of the product in your list which takes you to the product page on the website, click on either Windows or Mac and it will download the installer and run that.

Oh. I was stupid enough to click the Download link in the email they sent me. Silly me.

Will try going to Downloads. Thanks.

1 Like

OK. Any idea what I should fill in here?

Note that Studio 2.2 has been running happily and I’ve never seen an error like this installing a Topaz product.

Hi, Is the previous version still installed?

I haven’t seen this message either as i am on Windows. Hopefully someone else with a Mac can step in our you can raise a support request at the main website.

I get the same message!

Yes, it is. And I would be vert reluctant to uninstall it as I don’t feel there is any guarantee that the new version would install, and tech support turnaround seems to be 2-3 days before getting an answer. And, of course, if the answer doesn’t work, there’s another lag… I wish that this company was more service oriented (and did a lot more QA). Sigh.

1 Like

Hi, Is there a tech support telephone number that you know of?

No there isn’t telephone support available. There is a Topaz Labs Facebook page which you could ask on.

hopefully a Mac user will chime in here


1 Like

No success here!

I too received the same message when installing the 2.3.0 update to TS2 v.2.2.0 on my 2013 MacPro with the latest Mohave OS. It appears that the installer is trying to update itself, or it is missing something in the installer. If you view the full text in the message box you’ll see this: /Volumes/Install Topaz Studio 2/ variable defaultresourcedir. I don’t know what is the proper directory it should use however. I then copied the TS2 folder with my current v.2.2.0 to the trash as a backup, and uninstalled the program. I tried the 2.3.0 installer again and received the same error. BTW, when I checked for an update in the current TS2 v.2.2.0, the reply showed that there was no update available.


1 Like

Break out the Raid. Looks like we got us a big bug here.

I got the same message and cannot upgrade to 2.3. The error message said that I don’t have enough disk space though I have plenty left in my computer. Ok, I uninstall version 2.2 in the hope of freeing some space for 2.3 but of no avail. Another greater problem arose as a result as I cannot even reinstall version 2.2 again when the same bug comes up again saying that I don’t have enough space for the original copy.

In order to get back 2.2 again, I have to restore the entire computer with the Time Machine. It was a terrible experience which is so annoying and frustrating .

I am a Mac user with a model of 2019 running i9 and 64GB Ram

Hi everyone. Just installed v2.3.0 works great in windows. No major problems with install. Worked with several pics in cr2 no less. All my filters are working. Denoise,Adjust,and Sharpen open just fine. Update I was waiting for. Hope every one has same results.

Me too, on a Mac. Don’t know, if I destroyed any settings by choosing manually a location at my choice (folder on desktop). This should be fixed asap.
I have to add, that the previous version didn’t show any upgrade, so I downloaded the installer from the website. Do they already know of the Mac-problem?