How to get 300 dpi pictures?

I am beyond frustrated as to why I can’t seem to get a PNG to export with 300dpi. I set the upscaling preferences to 300dpi by default. In the upscaling menu, I even set the output to 10 inches x 10 inches at 300dpi, and still for the life of me, the image when I look at it in Photoshop after it saves, it says it’s 48 inches wide at 72 dpi. What am I doing wrong? I have tried upscaling several different times in different ways but why is the image so large in actual size, but not 300 dpi like I am telling it to? It is an image from Midjourney, upscaled once in MJ, so it’s the 1024 x 1024 at the source file.


Topaz Photo AI [v2.4.1] on [Windows]

Please be aware that the digital image has no physical size. It has only pixels. It is x pixels wide and y pixels tall. It will get a size measureable in inches where you can calculate the dots per inch when it is on paper, but fully digital you can not calculate the dots per inch du to the lack of the ability to apply a ruler. The dots per inch stored with the image are only from a theoretical interest just for the case that you set up the printer accordingly!

1 Like

You can change the DPI settings using the Upscale filter. There’s a text box to input a px/in and you can also change the units between px, in, and cm.

By default, Autopilot will set the resolution of your images to 72 ppi.

You can change this setting by going to Preferences > Autopilot > Upscale & Resize window and locating the Output Resolution option to set your default resolution

Topaz Photo AI | Autopilot & Configuration

If you export as a tiff, you’ll get a file with 300dpi metadata embedded that photoshop recognizes. I believe the TPAI png export strips most metadata by default to minimize file size (as do other png exporters), because png is often used as a web format. The exported png has dpi metadata that PS does not recognize, so PS assigns it a default dpi of 72dpi on opening (although XnView does recognize the dpi in the TPAI png).

If you really need a 300dpi png in PS you can change this in PS with “Image Size” without resampling and resave the image. I don’t know if all other applications outside the Adobe suite of apps will recognize it as a 300dpi image.

Ultimately, you haven’t done anything “wrong”. TPAI has given you the correct size image, but PS just doesn’t recognize the dpi in the file.

Edit: I’ve edited the above text based on new info. It appears TPAI and PS store the dpi metadata in different ways. It looks like the TPAI method is not “normal” for png files.

PS uses the ‘pHYs’ chunk to store dpi metadata, which is in the png standard. Whereas TPAI uses the ‘eXIf’ chunk.

2 Likes

THANK YOU SO MUCH! This is exactly the info I was needing. I had a sneaking suspicion it was just something wonky in PS ‘reading’ the file, not that it wasn’t actually high quality 300dpi.

1 Like