GPU utilization hits max 10% while CPU goes to 90%

My PC has ryzen 5900 as CPU and Nvidia 4080 FE as GPU. As the title states whenever i use any model on any video of any length the GPU utilization stays at or below 10% while CPU runs hot at 40% to even 90% depending on number of videos i feed to the application. But in all these case GPU is mostly ideal with fan rarely running. Why is that? In the preference i have set the AI processor as 4080. Are any steps i need to take to make optimal use of my GPU so as to improve processing times?

Since that’s not even close to what I’m getting on an a Ryzen 5900x and an RTX 3080ti, please tell more.
What models? From what resolution to what resolution? What storage drive?
My CPU usage has gone up with 3.1.0, but the GPU is also mostly maxed-out. (Of course I can still play games at 300fps at the same time.)

1 Like

Hi, I have a similar issue on my Mac Studio with TVAI v3.1. However, if I change the memory allocation in the settings to 33% or less, I then find the GPU usage goes to around 90% or more. If the memory allocation is 34% or more, then the GPU usage is minimal (but CPU is much higher) and the processing speed is around 25% slower. Also, the TVAI settings seem to ignore the GPU / CPU selection. It’s only the memory allocation which makes the difference. I assume this is a bug in v3.1.



ok. So here are my specifications
CPU: 5900 12 core 24 thread
GPU: 4080 FE 16GB VRAM
RAM: 32 GB running at 2600Mz
SSD: PCI 4 Samsung 980 Pro

Videos types: mostly 450px to 1080 px videos upscale to 4k 120 fps. I mostly use proteus or gaia algorithms and chronos fast as frame interpolation method.

How much frames do you get at export?

from 450 to 1080p.

well 120 fps. the problem is while processing. the GPU utilization barely crosses 10% while CPU is running in all cores.

You use the taskmanager to measure the load?

yes. plus i look at my GPU whose fan are not running while CPU load in task manager for application Topaz AI is has high power usage and CPU usage.

The GPU is so fast in processing the video so that you cant see it in the taskmanager because its so slow at readout.

I do see it in task manager and it shows mostly 10% or under for topaz ai. The CPU usage however for topaz ai in task manager shows above 50%.

Yeah I agree. Other tools can have the report rate increased and catch what’s happening in between what Task Manager shows. If you were processing at lower FPS, it would be more of an issue.
Not sure if they let you use it without an EVGA GPU, but as an example, I’ve been using EVGA Precision X1, and in it, the hardware polling period can be set to something fast like 10 milliseconds. When I do that, I can see that the GPU becomes loaded, then finishes really fast in a cycle that’s not noticed by Task Manager.

I posted earlier about this same issue, but since have updated hardware (completely new).

14 hours ago, I started upscaling a 1080p video that is 1hr 44min in length. As I mentioned, it was already 1080p. I set video ai to upscale to 4k (but not to 60fps). Maybe I am doing that backward?

Anyway, I just got back in the office. Video was 40% done (was registering 3.7fps). Now, here is the hardware:

MB: MSI Z790 Ace mb
CPU: 13900K
RAM: 128GB Kingston Fury DDR5 KF548C38-32 (4 dimms). Have tried without XMP and with XMP profile appied to run @ 4800mhz.
GPU: RTX A6000 @ pciex16
STORAGE: Two Samsung 990 pro 2TB drives, one Seagate Firecuda 530 1TB drive.
SOFTWARE: Latest version of Topaz. Windows 11 workstation edition

Setting in Topaz: Default preset for “upscale to 4k”

Interestingly, I can use gigapixel AI at ludicrous speed: Upscale a 16bit adobe rgb tiff from 7000x4000 px by 2.5X. Takes < 3 seconds.

Performance of the machine:

Yes, I know passmark is not 100% correct at all times… just trying to demonstrate one aspect.

The machine is absurdly fast.

  1. is this the anticipated performance?
  2. perhaps I am doing something in the wrong order or otherwise incorrect?

Can anyone offer insight?


Hi Jack - in v3.1 I have found that reducing the % memory allocation below a certain threshold persuades TVAI to increase significantly the processing by the GPU and less by CPU and thereby increasing overall processing speed. You’ll need to experiment to find that % threshold.



1 Like

Thank you, good sir.

Then maybe a dev like @suraj is willing to respond to this? And also as to whether the alleged increased GPU usage really means an overall boost? (Because maybe less memory takes away from overall speed as well).

Hi Jack, you’re most welcome - I must update you, however, that my original findings were on my M1 Mac Studio. I’ve just tried the same test on an Intel Mac (with eGPU) and the opposite happened: When reducing the memory % below the threshold (34% in my case), the processing speed significantly decreased (as might be “expected”). On both machines I was upscaling 720*576 by x2 using Artemis.



Yes please @suraj … I tried the suggestion offered by @meimeiriver and had no luck. Still painfully slow.

I noticed this slowness also. I did a test by setting cpu afinity in task manager on the ffmpeg app to the last 8 cpu and unchecked the first 8.
This is okay with a non x3d chip but if using that I believe the first 8 cpu have the 3dv-cache and the rest do not, I dare say leave the rest of the cores out of the mix and only use the 3dvcache ones. I am also getting a different cpu going from 5800x to 5950x. It also seems my rx 6900xt or rtx 3060 are not able to do most of the graphics offload if doing h265 8k or if doing vp8 or vp9. I kinda hope getting more cores will allow me to use the large cache cores then keep the rest for other apps. I tend to use the nvidia card for the Topaz work and the AMD card for the gaming/streaming video needs. Right now the best cpu for the work is 7800x3d, any of the high cache cpus. I just wanted a bit more cores in my situation to give like half to Topaz. I should mention the GPUs also go to 100% when in use by Topaz, the Topaz app uses 6.6-10% cpu and ffmpeg uses 60-100% cpu if not setting afinity.

Assuming that now months later there is still no concrete solution to this? When I say that, I mean not just a “workaround” but a real fix?

I can confirm I run this 24/7 right now and had to just go to the 5950x to even use other things on the pc at the same time topaz. ( Mostly ffmpeg.exe though )