Gigapixel v5.7.3

Interesting. And the input photo is great!
Edit: I meant to respond your previous post, am not sure in the utility of this gallery.

Thanks, indeed, no comparison, much better.

The gallery is great, no controlled situations, just the right thing to compare cameras you don’t have in situations that can be comparable.

And you can download the raws.

As wedding photographers, we rarely get to choose where we shoot.

Yes. Didn’t work for me. Support team reached out to me and said they determined it’s a bug and a fix will be released next week.

1 Like

What are people’s thoughts on the 5.7.x Standard model upgrade compared to what we had in 5.5.x/5.6.x?

I saw the teeth image above (the one I am replying to). Looks very sharp and natural on the left (5.6). Looks blurry and like it hasn’t even been upscaled on the right (5.7). This makes me wonder if that person’s 5.7 photo was taken with some basic model/incorrectly/failed to download model. Because the right side is a pure downgrade. All the sharpness is gone. I don’t believe it. Something must be wrong on their computer.

Update: I have tried it and compared to the old model. In some ways 5.7 is sharper, in other ways it’s blurrier. It’s too early for me to say if it’s better or worse, because all of my usual Suppress Noise / Remove Blur settings need to change since the new model behaves totally differently and introduces a lot more artifacts if I use my old settings (25 denoise 75 sharpen). I can say for sure that the new model amplifies noise more, so I need more denoising to avoid an image full of artifacts, but that may not be a bad thing, I just need to tune it more to find its optimal settings. What do others think of the new models?

By the way… Could you please always provide a full model download archive…?

With a slow internet connection, the worst feeling ever is to sit there and click an AI model, then click a scale factor, then wait for that model to download. Then hopefully notice that it’s done. Then manually click another scale factor. Wait. Repeat… For every scale factor. For every model. For GPU and CPU. It’s the most tedious download process I have ever had in any application in my life.

Even just a button to “Download all missing models now” in the preference pane would be enough becase at least that could run overnight unattended. Anything would be better than having to manually click each setting one by one and wasting a whole day. :cry:

5 Likes

Totally agree. With a slow internet connection, it’s painfully slow.

2 Likes

I had to partially reinstall TL software after updating windows to 21H2.

1 Like

New Gigapixel user here, fresh install of 5.7.2 on M1 Mac.
External editor feature from Photos app does not work on some pictures (the app is launched but doesn’t open the photo)
Works fine on the same photos with Sharpen or Denoise.

I’d suggest using 5.4.5 as a comparison point, as I certainly found that better than 5.5-5.6 - they Jury’s out on 5.7 as you (extremely annoyingly!!!) can’t have multiple versions installed at once so I can only be bothered to go back and forwards so often.

Ran into the following issues:

  • Auto Update Preview repeatedly failed to update the preview.
  • Auto Update Preview starts updating the preview every time a slider is moved, but before the slider is released. So it keeps updating while you still move the mouse/slider, which results in sluggish UI response.
  • Scaling still maxes out at 600%, even though old versions were able to scale higher than that.
  • For my usage case there does not seem to be sharper results in Standard mode. I still hope for a mode between Standard and Lines, because the former leaves many drawn grass patch areas blurred while the latter is grossly oversharpened (and now introduces strange mosaic like circles).

PS: Old v4.22 cannot be installed anymore, as the registration server seems to be down.

1 Like

I come back to the previous model. 2 huge problems for me with the new standard model :

  • First it add some noise AND chroma noise. Yes it adds details, but with luminous scenes, it adds more (chroma) noise than details.
  • Second, and it’s a no-go for me, with some pictures (that are luminous, or sunny, I don’t really know and I didn’t check further) this model adds a huge offset to the left and up, that means that it’s unusable when you mix models (standard and line for example) after rendering to have the best result.

Until you change this behavior, I stay on 5.6.

I still don’t see the plugin in PS on MacOS Monterey (Intel) with the latest PS. The files are in place as they should be, but, does not appear in the menu.

Update: Had to reset the PS preferences…Works now…

I just bought the topaz trio of image adjusters and I was wondering if we can become beta testers for them as well as for the video AI?

Never mind, I just found the closed group menu!

Glad I saw your comment! Phew… Had to reset my PS preference too for it to appear after the update. Kinda annoying but well… you win some, loose some. Clearly worth it in this case:)

I found “Very compressed” worked in certain situations. Not everybody uses regular photos. Some people have comic books or other artwork that can lose a lot of data but end up looking better. In fact, even within comic books I found some settings worked better. That includes manually denoising. I fixed up one comic book and had to choose different settings for different pages.

1 Like

After all these adventures with Microsoft and Topaz updates, today I was forced to reinstall Windows 10 in the mode of saving installed applications. Before the reinstallation I had version 20H2, now I have version 21H2. Can you tell me which Topaz applications you had to reinstall so that I know what problems I may encounter in the new version of Windows?

Sharpen was broken.

The others worked.

21H2 was the best version I have used so far.

21H1 was the worst.

I totally agree with you about 21H1.
Thank you very much for clarifying.

To whomever is tracking this,
I just recently purchased gigapixel v5.7.2 and initially it worked both as a stand alone, and as a plugin. The plugin quit working so I tried v5.7.3, because the change log stated that it fixed the plugin version not launching. Well, v5.7.3’s photoshop plugin doesn’t work either, and gives the same error message.

“Could not complete the Topaz Gigapixel AI command because of a program error.”