Gigapixel v5.7.3

Batch processing images is completely broken, it uses the wrong models randomly

No problem. :slight_smile:

When Gigapixel will correct upscaling eyes ? and very low res photos ?

All photo:

Eyes:

Eyes:

I’m new to this world, and and got the Gigapixel a month ago. So far I dig, but it would be a good necessity to get the Denoise and Sharpen to combine all together to enhance pictures? My goal is to AI pictures like the Remini app. The goal everyone has, which is to 4k the heck out of pictures.

1 Like

Hi Alexander,

I just downloaded the Full Win (10) 5.7.2 installer (not online installer) to my PC from the Topaz Labs “Downloads” page & installed it (over my previous version of GAI vs uninstalling the previous version).

When I launched the standalone version it now says it’s vers. 5.7.1 Not 5.7.2 (which is why I ran the update, to get the latest version).

Is the wrong full Win installer posted on the Topaz Downloads page?

Also, I find that in Comparison View the upper left quadrant is Not holding whatever mode/model I’ve set there. I typically I like to place Standard up there to start. The program just keeps populating that quadrant with a duplicate of one of my other comparison quadrants - for some reason it likes to use either Low Res or Lines (duplicating what I already have for those models in the other Comparison View boxes/quadrants). It has been doing that for the last 2-3 versions…

Later - I just discovered that this GAI is causing even more bad issues. I cropped the original dng image using GAI’s crop tool before 4x upscaling it w/in GAI 5.7.1 (which was supposed to be rel. 5.7.2 according to the Topaz Downloads page numbering). My upscaled bird pic ended up around 73xx px on the longest edge once upscaled using the Very Compressed model. The preview I saw in the GAI UI showed the entire area I wanted included in my upscale. I saved that result out as a .tiff file with the idea of continuing some processing on it in Ps 2021. I opened the image in Ps and more than 1/2 of the image (that I saw in my GAI preview) was truncated out and had chopped off the birds as well as completely desaturating the color in the image. Here is a snip of what I saw in Ps. It’s unacceptable as a usable upscale…

I just installed 5.7.2 and it displays 5.7.2 very well when I launch the software. And it still works fine for me

Hi Harald. I’m glad it worked for you. I tried it a few times on my Win 10 PC … used different browsers (Chrome & Edge), tried both the full & online installers and (in that process) uninstalled then reinstalled & restarted the PC. In all instances what got installed was 5.7.1 (as my snips show). I was updating from 5.7.0. I usually have no issues with installs. Only other time I did, Topaz hadn’t updated the installer on the Downloads page. Perhaps a developer has another means to link me to the right installer - I’ve contacted Spt… Thx.

I used the link at the top of this page and I have v5.7.2

1 Like

Thx Paul! I will try that vs the Downloads pg when I get home later today. :crossed_fingers:

Yeah maybe when I saw it in download the problem was maybe already solved. Try anyway with Revo uninstaller to erase all traces of the software and try again to install it

1 Like

I will look into that! Thx. I find all kinds of traces of various old Topaz products/betas (long ago uninstalled using the Uninstall Program on my Win 10) when searching for other stuff. The product you mention may be the extra “vacuum power” I need to suck up that old, unneeded detritus…

That link worked, Paul. Now I have GAI 5.7.2 (definitely different than the 5.7.1 the main Topaz “Downloads” page was producing. Thx!

And, to add to the excitement (my thresholds have been lowered during the pandemic…), I used your tip of tapping the “Home” key to quickly get up to the top to find the link and the “End” key to get back down here to rpt back. :+1:t2:

1 Like

I also noticed that the colour is wrong if you upscale a webp image to jpeg. I’m guessing some sort of colour space conversion bug as upscaling to tiff 16bit works fine.

I tried cropping within GAI 5.7.2 (Win PC) again today & had the same experience as with 5.7.1 yesterday, the area that showed in the preview post crop did not end up in the saved out (to .tiff) file. The content was severely truncated and lost in the save process. This happened in a beta quite a few generations ago but seems to have recurred…

Also, colors in my saved out .tiff files do not match the original images (I’ve tried jpg & dng as source images using standalone GAI). And, the .tiff files that were saved from GAI standalone could not be opened and worked on in Ps. It didn’t recognize them as legit, openable files. (I tried using both Adobe RGB and sRGB separately to see if it was a colorspace conversion issue and found it had no impact - the output file colors were the same wrong colors in both tests).

I have just downloaded v5.7.2 to my older MacBook Pro running OS Monterey and it crashes almost immediately both when sending a file from PR 2022 and as a standalone. This could be due to the fact that this system has just 8MB RAM (still waiting on the repair of my newer MacBook!).
I have reported this to Support but wondering which version to roll back to. Any thoughts anyone?

I have been using Revo Uninstaller for a long time. I have never been disappointed.

Then in the “Windows 10 manager” software (not free but you can use it for free during 30 days) in the “utility” section and then on the “registry tool”, you type the name Gigapixel and launch the search. Once the search is done, delete the rest of the registry with the name of the software. it will create a default backup of this deletion just in case. You can define its location
https://i.postimg.cc/mgfQ9M30/image.png

1 Like

So for the fact that you actually only see pixels, it’s pretty good.

Of course it is not a model that exchanges the original pixels for those of another image, but uses what is available.


If your Photoshop is 22.5.2 or later, this means that TIFF files produced by GAI do not have all necessary attributes of legit TIFF files. Check this thread:


As for the colors, there were threads related to awkward color management of Windows 11. But seems these problems were limited to the first release of Win 11. Can your issues be related to that?

1 Like

Hi. I’m still on Ps 2021 (22.4.2) & haven’t updated to Ps 2022 yet (due to many bug postings I’ve seen in Adobe forums & past history…I typically wait a month-ish).

I see that Jeff Tranberry of Adobe posted this (& more…at the link you mentioned) to alert developers to:

Jeffrey Tranberry

Adobe EmployeeNov 22, 2021

If you’re still having trouble with TIFFs created/saved by software that’s still being developed, please share the following information with them: Photoshop’s TIFF parser had a buffer overrun security vulnerability in its synthesized calculation of the Image File Directory entry RowsPerStrip (278). The fix for that was to reject TIFF files that did not provide the required RowsPerStrip (278) entry. Under the rationale that this IFD entry is required, as per the TIFF specification

Ditto re: OS. I’m still using Win 10 Pro (64 bit).

Thx for the tips how to use it. Good to know. I have been finding ‘body parts’ of misc & sundry uninstalled Topaz products & old betas. So it’s good to know I can go down the line searching by products generally vs specifically using release #.