Gigapixel v5.0.1

Download: Windows, Mac
Released July 1, 2020.

Major features

  • Three interactive tutorials have been added: “Basic Resizing”, “Additional Controls”, and “Previewing Options”. They can be found in the right panel when no images are open
  • External Editor support has been added on Windows. For photo editing applications that allow you to open images with external programs, Gigapixel will process it, save the original image, then quit

Improvements

  • Dramatic speed improvement when opening up a large number of files at one time
  • Update Preview button no longer scrolls in the right panel
  • “Account” toolbar option has been changed to “Community”, with an added option to go to the forums

Fixes

  • Save button no longer needs to be clicked twice if the preview processing has been cancelled. Previously, it would either not do anything or say “Stopping…” and had to be clicked again to begin processing
  • Zoom level text field now allows for the “%” sign when changing the zoom level
  • Files not actively being previewed obey the 32,000 x 32,000 pixel limit again
  • Gigapixel AI process now ends cleanly on Windows. Previously, portions of the program would stick around if the preview was updating when the application was closed down

Known Issues

  • When zooming out with the scroll wheel or zoom slider, the Navigator outline sometimes does not match up with the section of the image being previewed. Clicking inside of the Navigator panel or on the preview will reset it
  • Resolution metadata does not correctly get saved out with certain images
  • Switching between scaling types (inches, centimeters, px / in, px / cm, etc) sometimes doesn’t calculate the correctly size
  • Gigapixel will hang on save when launched as an external editor on Mac. It will need to be opened as a standalone application in order for it to function correctly

If you have any issues using this version such as crashes, hangs, metadata issues or other errors, you can submit your logs and test images here . The images used when an error occurs are always helpful for us when pinning down what the issue is.

3 Likes

Crashes sometimes when I try to process an image (x6, cpu mode, openvino on)

2700x & 2070 Super

I don’t see any way to get this into Affinity Photo. There is no PS_plugins_X64 file folder in the Gigapixel AI 5.0.1 update.

Crashes in CPU mode while Mann-Made settings is on - cannot update preview or save picture (AMD 3950X), regardless of OpenVINO settings. This bug was also in 5.0.0 version.

Hi John,

If you go to File -> Preferences, do you have “Use maximum quality AI models” turned on? If not, can you turn it on and try it again?

I am using “Use maximum quality AI models” . Funny thing that in 5.0.1 it seams to crash only in 2.0x magnification - 4.0x and 6.0x work OK. Also after using “Use recommended setting” option to use OpenVINO is grayed out …

It looks like Affinity Photo needs a PS plugin in order for it interact with external editors. Gigapixel doesn’t have a PS plugin at this time (it should by the end of the month).

I’ve updated the changelog to better reflect this - sorry for the confusion! It’s basically a fix centered around processing then quitting when Gigapixel is opened with a list of filenames passed in, if that makes sense (programs like Lightroom open Gigapixel in this way).

Hope that makes sense,
Taylor

2 Likes

The option “OpenVINO” seams to be back after successful run of “Use recommended setting” - maybe one time issue.

This release is not working and does the complete opposite to what it claims.
With V5.00 I could call Gigapixel from Lightroom as a secondary external editor and it worked fine. It called it, opened my file and processed it. I then closed Gigapixel and went back into LR and synchronised my folder to include the file in my library - it worked.
Now it corrupts my file! Basically it calls as before but when I click Save in Gigapixel, it takes no notice of my preferences for file naming (I think it is trying to update without a file name change) - I get no pre-screen to confirm what my file settings are when clicking save, which happened previously. It processes, but doesn’t save a file or at least corrupts the original making it unreadable. Fortunately LR creates a tmp file so I have a version of the original. On top of that, it remains in memory, holding that file open … all the things you claim this version ‘corrected’ even though there was no problem for me beforehand.
So as I say, this release does the complete opposite of what it is supposed to do!!!
How do I revert back to V5.00 ?
I’m using Windows 10 and LR CC.

3 Likes

My computer specs.
Windows 10 Pro 64-bit Version 1903
Alienware Aurora R8 9th Gen Intel® Core™ i9 9900K (8-Core/16-Thread, 16MB Cache, Overclocked up to 4.7GHz on all cores)
NVIDIA® GeForce RTX™ 2080 Ti GDDR6 (Over Clock Ready)
Installed Memory (RAM) 32GB Dual Channel HyperX™ DDR4 XMP at 3200MHz
850W EPA Bronze PSU Liquid Cooled Chassis
Photoshop CC Version 21.1.0 release
Internet provider Century Link fiber optic Gigabit

Testing for Gigapixel AI 5.0.1b

The first time I downloaded it took 1 min 40 sec. It paused for 20 seconds before resuming. The second time I downloaded it took 1 min 20 sec. To install took 40 seconds but after I hit the finished button, it refused to open. I was looking at a blank window and at the top text that read Topaz Gigapixel AI (not Responding). After waiting 4 minutes I closed the window. I then typed the whole name Topaz Gigapixel AI 5.0.1 into my search box, clicked the icon, and it booted up just fine, and worked properly from then on.
Fixes:

  1. If by “Save” you mean “Save As” because I don’t see a “save’ button, then it works properly with one click.
  2. Percent sign is indeed allowed when changing zoom level
  3. To process and save a 6776 x 6008 pixel image scaled up to 6x, 36091 x 32000 took 5 min 24 sec before it showed finished 100%. However, it took a total of 9 min and 4 sec before it showed up as an image I could open on my hard drive. I don’t know if that verifies the fix shown as number 3 or not.
  4. Verified, on the images I tested, Gigapixel does now end cleanly on Windows.

You can add three images to the software all at the same time, and then be able to add any number of additional images later if you add those additional images all at the same time. However, if you start out with a total of four images, you will be unable to add any more until you remove at least one.

Now, if you have three images in the software and add any number of additional ones, you will not be allowed to add any more until you reduce the number in the software to three or less.

OK, Yeah, I realize it’s not that terribly important, but don’t you find it rather amusing? Maybe it’s just me.

Update: I retested the software this morning with the second download I did yesterday and the software is working normally. I can add or remove as many as I want.

I did two downloads as I mentioned above, and I’m quite sure I did the tests from the first one that had a long pause in the middle before resuming. It also didn’t open the program correctly and instead showed a blank window. The tests this morning were from the second download which downloaded quickly and opened perfectly. Just a glitch I guess.

1 Like

Terry you must be using the Gigglepixel version.

2 Likes

Very good Artisan-West, I must have clicked the wrong link, but — glad I did.

Hey Terry,

Thanks for the in-depth testing! It’s much appreciated.

Do you mind uploading this image here? I’d like to take a look at this further.

This topic is for public release 5.0.1. 5.0.1.b would be the last beta release.

I can no longer do that - the 32000 limit is now correctly applied no matter which way I try to exceed it. Previously there were a few ways to get round it.

I don’t find that - I can start with as many/few as I like and then subsequently add as many/few more as often as I like.

Integration in Lightroom Classic did not work :frowning: complete
It seems all ok, Edit in Gigapixel, make adjustment and just save the the TIF file. But Gigapixel didn’t save a correct TIF file and there is only a 1 KByte TIF file in the folder.
image
With Lightroom Export as JPG it work.
Will try to examine if the color space is the problem. JPG only can sRGB and normally I use proPhoto for TIF. Currently I cant check because:

  1. After several Export calls, Gigapixel refuse to start, so the MAC Problem is also on PC, or worser.
    Currently Gigapixel also refuse to start as stand alone :frowning:

PS: Found the running task in task manager and retested TIF with sRGB, but I still doesn’t work.
PPS: Tried export with 8 Bit/pixel and now the saved file is ok, but it is the unscaled one :face_with_symbols_over_mouth: so no upscaling just converting.
image

Hi, seems to be an issue with LR … EXIF doesn’t seem to be updated and the written size was just 8 Bytes.

EXIF entries for the original 3264 x 4896 upsized x 2:

image

And then the actual 8 byte data file:

image

1 Like

Hi, Capture one … this is the process panel:

Result on return to Capture One:

Again 8 bytes, invalid file:

image

1 Like

Hi Paul, It feels a little like the twilight zone. I did further tests this morning, and I am now also getting the same results as you are. Yesterday I did have two different downloads and It is possible that the one I used for the first testing which did take a long time to download and install, and didn’t work perfectly. I did cancel one of the two downloads and perhaps the one I’m useing now which downloaded perfectly, and quickly, is somehow different.

Anyway, as you say, it is working perfectly.

Hey, I really love the new AI model improvements. They do much much better with things like lips and eyes and nostrils, giving more natural contours. FANTASTIC upgrade (5.x)!

Dramatic speed improvement when opening up a large number of files at one time

Wow that’s great! Dumping in 1000 images and batch processing overnight will not be a sluggish UI pain anymore! (Edit: Yeah I can confirm, the UI is super fast now when loading big folders!)

I have a question about the JPG quality fix. Now, quality 8, 9, 10 are all different, so that’s great. But Quality 8 generated a ~600kb image (blurry hair and similar fine detail blurring when zoomed in), 9 generated a 1.69mb image whose high-zoomed noise/hair strands were barely sharper (due to JPG compression), and 10 generated a 1.70mb image which was super sharp.

It just means that now, quality 10 is the only acceptable one. I expected quality 9 to be between 8 and 10, but it ended up with almost the same quality as 8 but almost the full filesize of quality 10.

Can you confirm that the slider now properly tells the JPEG compression library to use quality 80, 90 and 100?

Could a more intelligent (better coded, better spatial understanding, compression quality etc) JPEG library be used instead? I assume that JPEG libraries are like h264 encoders, with some compressors being really dumb and producing bad files and other compressors being great and producing high quality files.

Perhaps a “JPEG Quality 95” setting is needed? In most other programs where I save JPEGs it’s a 0-100 quality slider and 95 is usually the sweetspot which saves a little bit of filesize while looking pretty much as good as 100.

Noticed two things with the 5.0.1 windows installer:

  • No longer code signed. Windows SmartScreen warns about installing the application, with “Publisher: Unknown publisher”.
  • A different installer framework seems to be used. Can’t open the .exe in 7zip anymore. I used to do that and click “Test Files” to verify that the exe is properly downloaded without errors.