Gigapixel v5.0.0

Download: Windows, Mac
Released June 24, 2020.

Major features

  • New previewing mode: Single Image View
  • New zoom features: zoom to fit, a zoom slider, text field input, and scroll wheel to zoom
  • Updated AI models
  • “Image Type” selection on the right panel: choose between two different AI models, one for natural images (portraits, nature) and man-made images (cityscapes, typography)


  • Preview panning responsiveness has been drastically improved
  • Images that have not been successfully loaded or could cause a crash when processing now pop up a warning that gives more in-depth information for better troubleshooting. Unsupported images include images in the CMYK color space and images with more than four channels (alpha masking channels that have been turned off in Photoshop, for example)
  • New auto-updater: new version installer will now download from within the application
  • Updated back-end CPU processing library
  • Added ability to right-click to select preset zoom amounts
  • Able to now pan on both the original image and the preview image
  • Preview window has been made bigger


  • Certain images should no longer successfully process then fail to save out the image - this was due to corrupted image metadata that was silently failing when exporting the image. Default metadata will now be used.
  • Preview should no longer double process (spinner reaches 100%, then starts over) in most situations. If it does occur please post here with steps on how to replicate.

Known Issues

  • If preview has been cancelled, clicking the Save button will be unresponsive the first time. Clicking it again will successfully start processing
  • Gigapixel will not shut down cleanly sometimes on Windows machines. If Gigapixel fails to open after shutting it down, go into Task Manager and end the process.
  • When zooming out with the scroll wheel or zoom slider, the Navigator outline sometimes does not match up with the section of the image being previewed. Clicking inside of the Navigator panel or on the preview will reset it.
  • Resolution metadata does not correctly get saved out with certain images.
  • Images with corrupted ICC Profile information will crash the software. This can be fixed and verified by opening the image in Photoshop and if a pop up shows that states it can’t read the ICC Profile information, let it auto-convert and save the image back out.

If you have any issues using this version such as crashes, hangs, metadata issues or other errors, you can submit your logs and test images here. The images used when an error occurs are always helpful for us when pinning down what the issue is.


Excellent. Looking forward to test this. AI new models intrigues me the most.

Hi, It seems that there may be issues with metadata as I created a 4x from a A7M3 RAW:

Saved as TIF no compression became 2.14GB (Note: 4GB is the limit for TIF so shouldn’t be an issue) and that the 24 bit crop of the sensor is also being included.

Got the following messages:


But it can be opened in CS6 if you ignore the message and press Continue. But it seems that noise, both luma and chroma, are not good in the RAW conversion before resize.

Although the image is ISO1250 normal conversion at 100% is like this, and following errors in the EXIF:


Creating from a TIF generated by a RAW converter gives a better result but the same errors as the result from the upsize where AP cannot open and PS reports a EXIF error so still an issue with the EXIF data:


So you can compare the Metadata here is the input (from the TIF generated by Imaging Edge) and the output from GigaPixel … there are many differences between the EXIF input and Output such as the Input showing a shutter count of 169 and the EXIF from GigaPixel 16218078 …

A7S00175.txt (11.3 KB) A7S00175-GP5-scale-4_00xexTIF.txt (12.5 KB)

Uploaded my log from the iMac with the Intel Iris card… :wink:

Tested GP 5 on a 2008 MacBook Pro with 4GB RAM and small SSD drive. Worked fine :wink:

Works fine under macOS Big Sur Dev beta on MacBook Air as well.

Got a small bug here, try to upsizing 6 times a picture which is 5472x3648 pixel , result picture would be greater than 32000, the result TIF file was corrupted after 3:40 min work :frowning:
There was no warning or something. The program do it’s job as usual but the TIF file generated was corrupted as expected. (TIF can’t be used for more than 32000 pixel)
The 6x upscaling was left over from previous picture. If I press the 6x button myself the result file would be 32000 width and should work.
It seems the 32000 pixel check is forgotten if a new picture is load.


Awesome results on this test photo.

Look at the Navigation window to see how far away the opera house is, yet it is definitely recognizable in the upsized version.


Why do I keep getting this annoying glitch? This software is so unpredictable! I either get a miracle with incredible results, mostly in the preview or it resorts to some annoying water pastel or horrible artifacts image. I didn’t manage to record the best result but this first image is kind of decent and the 2nd one is absolutely awful. I never get any results with original images and always have to shrink them down.

I am on windows 10 with an rtx 2070 with the lastest studio driver update. Doesn’t make a difference with cpu either just shows it rendering well in preview but then output turns to rubbish.

not a bad result
this pattern happens too often

1 Like

Each time you update you must run the calibration again, to do that open the preferences and click on Use Recommended Settings and the next time you update the preview it will re-calibrate your settings. Use that to process images along with selecting to use the Maximum quality AI models.


I also find that you need good quality input images to upsize, if there are too many artifacts they will also carry over into the output image. In the last image you uploaded (this pattern happens too often) i would select Auto Detect Settings and then set Remove Blur to 0 as the input image looks like a scan.

If that turns out OK you may want to try Sharpen AI to remove part of the softness which is not a blur.

1 Like

That’s a well known issue. Topaz explained it is like this because the AI has been trained with small images up to 500 * 500 pixels.

Each time you update you must run the calibration again…

What does “calibration” mean exactly? I always understood the “Use Recommended Settings” button to do nothing more than choose the preferred acceleration mode based on speed. It always chooses GPU mode for me, despite CPU mode (no GPU and no OpenVINO) delivering the best results.

Why do we need to run this after every update and what changes internally when the GPU/OpenVINO settings stay the same anyway?

For my understanding it is similar to the manual for your coffee machine where it says: “please be sure you plugged in the power cord.” Of course you did. It’s not the first time you used a coffee machine. But that’s the regular tip you get from a manual when you are looking for help because something is not working as expected…

“Preview should no longer double process (spinner reaches 100%, then starts over) in most situations.”

Not true in my case. Every time I make a change after the preview spinner starts, it still continues to 100%, then starts again from 0 and counts up to 100 for the change I had made.

Also, right after saving an image, the preview resets and the spinner counts up from zero to 100%. Saved image file does not show up until preview reaches 100% again.


instead of scaling (2x, 4x) why not also make Megapixels selectable.

Thats what we photographers more Familiar with.

I did notice with 5.0.0 that 2x is already 71 Megapixels with my 18 Megapixel Camera.

I didn’t use Gigapixel that often in the past because i didn’t liked it that much, thats why i came up with this idea now.

1 Like

I also like that idea of ability show how many Megapixels is original and ability to enter number in the scale also in Megapixels. For us photographer that would be really useful. Great idea.

I seem to be having 2 issues. First, I cannot get the Photoshop plugin to show on under Mac OS Catalina and the latest June Photoshop update. In addition, the program randomly doesn’t present the save dialog box. When not presenting the box, it seems to process a file and then crash.

No issues so far.

I tried some previously enlarged images with the new AI models, and got identical results at the identical speeds.

Additionally, I tried the Natural versus Man-Made image types, and the results were identical to each other. It didn’t matter if these were landscapes with trees and rocks, or graphic images of aircraft textures with geometrics lines and shapes. The results were pixel, to pixel the same either way.

I would have thought the different AI image types would have produced some differences. Perhaps it was because my preferences weren’t set to use the max quality model? (I find the enlargements look sharper set this way than when using the max quality AI model, and it’s 1/3 faster) Does the image type selection only matter with the Max Quality models?

There is no Photoshop plugin.

For this you will need to raise a support request at the main website.

Since ever I have this visual glitches with GPU mode on the natural (classic) mode. But with the new man made mode I don’t have this glitches. Please, fix that. With CPU mode I don’t have glitches, but is 10x slower. I have a 2070 super, but with my old 1070 I also had this glitches.

1 Like