Gigapixel v4.9.4.1

Download: Windows, Mac
Released June 11, 2020.

Improvements

  • Added the ability to switch between Pixels Per Inch and Pixels Per Centimeter separately from resizing by inches / centimeters

Fixes

  • Controls no longer change when opening or selecting another image
  • Controls no longer reset to the default (by 2x scale) when closing an image, then opening another
  • Reworked how the unit conversions are done, which means that the scaling options should stay the same when switching between units
  • Fixed a rounding issue when doing unit conversions
  • Adobe RGB color profile now gets written out to metadata correctly

Known Issues

  • When resizing down past 0.5, some images won’t show properly in the preview window - image will be clipped and pannable when it should show the entire image

Hotfixes

  • v4.9.4.1: Fix preview scaling issue occurring on some machines
3 Likes

Hi Taylor, @taylor.bishop

Seems to be some issues with calibration and processing. I have attached a screenshot of the settings used and the processing times reported for the 2 that ended sucessfully.

After switching from GPU to OpenVINO I get this crash … (don’t worry about the Debug option as I have Visual Studio on the PC so this will appear) …

Note I can reproduce it every time using the following steps:

  1. Open GigaPixel
  2. Load Image
  3. Select Use Recommended Settings from Preferences
  4. Update Preview, calibration selects both
  5. Save using Both
    a. Save does nothing
    b. Save again, processing says 5:52 mins … wrong by about 5 minutes
  6. Switch to GPU only, press Save takes 1:07 mins
  7. Switch to OpenVINO only press save and have the crash

Reported event:

Faulting application name: Topaz Gigapixel AI.exe, version: 0.0.0.0, time stamp: 0x5ee29722
Faulting module name: openvinoinfer.dll, version: 0.0.0.0, time stamp: 0x5ee29645
Exception code: 0xc0000005
Fault offset: 0x0000000000bb8eb9
Faulting process id: 0x2954
Faulting application start time: 0x01d640583ce06a7f
Faulting application path: D:\Program Files\Topaz Labs LLC\Topaz Gigapixel AI\Topaz Gigapixel AI.exe
Faulting module path: D:\Program Files\Topaz Labs LLC\Topaz Gigapixel AI\openvinoinfer.dll

My Environment:

Application & Version: Topaz Gigapixel AI Version 4.9.4.0
Operating System: Windows 10 (10.0)
Graphics Hardware: GeForce GTX 1050/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 446.14
CPU RAM: 16269 MB
Video RAM: 4096 MB
Preview Limit: 6353 Pixels

Have also attached to log file, just take off the .txt extension and open the ZIP.

GigaPixel 4.9.4 DM 200612 Logs.zip.txt (39.0 KB)

No issues with calibration here. My standard test image produced the exact same image enlargement at the same speed as the last several major revisions.

Something that occurred to me was that since each new version produces a pixel-for-pixel identical enlargement, the underlying process must be completely deterministic. (Same image, same parameters, will always produce the same result) No great revelation, just something I wasn’t consciously aware of before.

For me the preview not working good, just only once if i loaded the image. If i change the scale, at the preview do nothing. Manually update preview the same. Other changes are working just the scale preview not.

Same here.
The preview image doesn’t show at correct scale.
Changing size or scale, the preview image still remain the same.

I believe I am experiencing a bug with 4.9.4.0 (though I think it was present in 4.9.3.*, too) where the image in the preview pane looks gorgeous and the image in the saved file is genuinely awful.
Preview at 200%:


Saved file at 200%:

I’m quite shocked that the output file isn’t what I was shown. I hate to think I’ll have to go back through all my resized files looking for other similar issues!

1 Like

sean.bat
Yes. same to me. Preview looks more better than the final.

And some png file crash the gigapixel. Need to convert it to jpg.

I agree, the preview scaling is not working as it used to. It is now independent from the chosen enlargement size, and only changes what’s displayed as you select different preview magnifications.

That raises the question of what the preview now represents? 100% preview looks different than the original, so it’s not just a matter of 200% representing 2x and 400% showing 4x.

As for the output result quality, the 6x barrier is still there. 6.01x produces a very blurry result compared to 6x. Enlarging a previous enlargement to get the original beyond 6x still works.

p.s. The preview function is not working reliably or predictably! It’s behavior changed after saving a file. It changes back after closing and reopening the program. So far the logic it’s trying to follow escapes me.

I also checked the default look of the 400% preview against output files saved at three different magnifications (2x, 4x, and 6x) and its pixel resolution is somewhere between 4x and 6x, but it has less detail and clarity. This changes after you’ve saved a file appear to be closer to what you just saved, but it is still has less detail and clarity.

Just downloaded the latest update (v4.9.4.0) on iMac running OS Mojave. Same issue with the preview - changing the scale and updating the preview picture does nothing - the original scaled picture is maintained in the preview. This does change if the zoom is altered. Have not tried saving images with the different scales yet.

@taylor.bishop 4.9.4.0 broken for me.
No updates of preview if I change scaling, height or width. The preview stays on 2x Scaling until I press save.
The file is saved in the selected scaling, but preview stays on 2x.

Update: Get several crashes on Update, Save etc. So I decide to rollback :frowning:

Those artifact shown in the output file seem to be caused by GPU.
Disable GPU and use CPU or OpenVino should fix the problem.

1 Like

Ever since I rolled back to version 4.4.6, I’ve had zero problems. Posting this as a public service announcement. :smile:

3 Likes

I try to replicate the problems everyone is talking about and use the version 4.9.4.0 normally. So far no problems on my end. Not sure if it could be driver related but I started using Studio Ready Drivers from nVidia and lot of my problems system wide got resolved.

Application & Version: Topaz Gigapixel AI Version 4.9.4

Operating System: Windows 10 (10.0)

Graphics Hardware: GeForce GTX 1060 6GB/PCIe/SSE2

OpenGL Driver: 3.3.0 NVIDIA 442.92

CPU RAM: 16266 MB

Video RAM: 6144 MB

Preview Limit: 6842 Pixels

" Ever since I rolled back to version 4.4.6, I’ve had zero problems." Very true @johnnystar!

Preview now fixed in the 4.9.4.1
Any information frome the other bug why the final image worse than the preview?

I can’t replicate the problems either (am now on 4.9.4.1 so the scaling display is fixed). I’m also using the Studio driver. Other specs:

Application & Version: Topaz Gigapixel AI Version 4.9.4.1

Operating System: Windows 10 (10.0)

Graphics Hardware: GeForce GTX 1060 6GB/PCIe/SSE2

OpenGL Driver: 3.3.0 NVIDIA 442.92

CPU RAM: 32701 MB

Video RAM: 6144 MB

Preview Limit: 7825 Pixels

1 Like

We seem to have very similar specs. Kudos. :slight_smile:

1 Like

I appreciate that the hotfix was a minimal download to update. I can confirm that everything is back to normal again.

1 Like

Hi dency,

In your case has this been a problem for you in past versions or is it this version specifically?

Could you confirm that the output is worse than the preview in a photo editing program like Photoshop? Are you noticing in the output the grid-like issues as well or just a general fuzziness? The Windows Image Viewer and Windows Photos apps do some weird things to images, as it applies a proprietary anti-aliasing effect on top of the image.

Problems continue. Upscale with Upres with PPI of 360 only works with PNG output. Tiff file with same file/settings etc…, reverts to 300ppi with appropriate dimensions. Result are the same for other PPI’s.

Using same settings attempting any other output format crashes Giga.

Once Giga crashes it continues to crash when processing the file no mater what output I select.

I have copies of the System crash report (both after initial crash and crash on Giga next use), Main tzlog and QML_tzlog logs if they would be of use to you.