Gigapixel, Denoise (and more?) crashes video card when using the RX580 for processing

Hi folks…

I have the latest versions of the Topaz products and the most recent graphics driver for my RX580 4GB.

In the past couple years (with both the current and previous versions of the graphics driver) I had no problems and the RX580 worked well. But after updating the various Topaz products over the past few months, one by one they started crashing the graphics driver/card (where all screens (3) go blank and I have to reboot the computer to recover).

So far DeNoise, Sharpen, and Gigapixel exhibit this behavior.

It happens when I am adjusting settings and previewing, as well as while processing the photo(s). Happens every time.

My only solution is to tell the Topaz product to use the CPU.

Any idea what’s going on?

Thanks…

1 Like

I have the same issue with a AMD RX580. Both Sharpen and Gigapixel keep crashing

1 Like

Topaz got back to me via email. I tried a couple images, and the problem seems fixed, at least with Sharpen Ai - I didn’t have a chance to try Gigapixel - I will when I get a chance:


Thanks for reaching out and my sincere apologies for the long-overdue response. We experienced some staffing shortages due to covid-related illnesses, but should be back to our normal response times (less than 8 business hours) shortly.

For Sharpen AI, I’d ask you to do the following:

  1. Un-install
  • Navigate to the Windows Add/Remove Programs page (or search for it using the Search bar) > Search for Topaz Sharpen AI and click ‘‘Uninstall’’
  • Go to C:\Program Files\Topaz Labs LLC and delete Sharpen AI folder if there is one
  • Go to C:\ProgramData\Topaz Labs LLC and delete Sharpen AI folder if there is one.
  1. Open program RegEdit from your Start menu explorer and delete the registry entries of Topaz Sharpen AI, if there are still any, in:
    Computer\HKEY_CURRENT_USER\Software\Topaz Labs LLC\Topaz Sharpen AI
    Computer\HKEY_LOCAL_MACHINE\Software\Topaz Labs LLC\Topaz Sharpen AI

  2. Re-install with V4.0.2

  • Download the software from: Topaz Labs Download Page.
  • Reboot your computer. Install the program without any other applications running
  • Open the program as a standalone first to make sure it’s working for you

As for the issue with the 3 apps when running them on your AMD GPU, I want to rule out if this is a mechanical issue; i.e. a power supply issue. AMD GPUs sometimes cause some machines to crash with high GPU-resource intensive programs if the GPU is being somewhere at the peak and the power supply can’t handle all the usage. Can I please ask you to try turning the power limit usage of your AMD GPU and see if that makes a difference? You can do that in the AMD settings. For your reference, here’s: How to Tune GPU Performance Using Radeon Wattman Share this page. You can check the '‘Power Limit’’.

Please let me know if that makes a difference. Thank you, William.

Thanks for that, but did not help me. I have created a new help request

Same problem here. I’ve to reinstall the drivers gor my AMD RX 580

Same here with a AMD RX 480. GPU crashes, Topaz suggesting it is power related to the PSU, reading the number of issues here with a Gigapixel and Sharpen AI, I am very doubtful of the Topaz’s explanation

Bump - any solution here yet? The same thing is happening with the new/upcoming Photo AI.

I’m having a similar issue with my RX 580 and Gigapixel AI. It doesn’t happen every time, but on occasion the program will disable my graphics card entirely so I get a black screen. Generally I’ll then need to do a cold reboot to recover. However, this last time it happened after reboot my windows system couldn’t identify my graphics driver at all. I needed to completely reinstall the Radeon drivers to recover. Any idea why this happens?

In the solution they said to undervolt it I think?, as someone who has done this often on games it works really well and can be easily done in the AMD software settings. I will try this when I get a chance as its hard to know what to undervolt it to. Additionally on windows GPU drivers I have two RX480’s in my machine, both GPU’s show on default windows 10 drivers, but once I install official AMD drivers only the main one shows? I have messaged them for support, I will wait back and hear what they say, they will probably say similar but then I can’t remember if I told them about the one card only showing issue… but yeah using CPU works fine for me for now. Is there even an advantage over using such a now old GPU over CPU? I am using a Ryzen 7 CPU.

Well - I tried every kind of undervolt I can think of in AMD Adrenaline.- including using the “Power Tuning” limit (PERFORMANCE TAB - TUNING - choose MANUAL TUNING - then POWER TUNING), adjusting it from negative 50% to positive 50%. No luck.

Yeah, I have been emailing Topaz support, honestly I would just take it as they don’t support this GPU. Just use CPU instead, it works the same just longer I think.

Yep works the “same”, but WAY longer (even for higher-end CPU’s).

I guess I’m going to scrounge around for an Nvidia GPU - my son was telling me they have far fewer bugs vs AMD - that said, this Topaz bug feels like A TOPAZ BUG, as my card NEVER crashes, even during “stress testing”, with any other software.

BTW, I’m getting the same crashing behavior with Video Enhance Ai. What a mess.