Gigapixel AI v4.8.2

Download: Windows, Mac
Released May 7, 2020.

Major features

  • Drag and drop works again with folders, and now recursively adds images from subdirectories, up to 10 subdirectories deep.


  • Escape key now behaves more appropriately and won’t close the application. It will now close open dialogs and cancel processing.
  • Comma separator now works for decimals when specifying a custom scale, regardless of locale.


  • Preview pane no longer pops up when dragging in an unsupported file
  • Removed blank menu item under Account on Windows

Known Issues

  • Application sometimes crashes after closing images and adding new ones when Face Refinement is turned on.



  • Fixed issue that forced filetypes to have a lowercase extension.

I just updated to V4.8.1 and it does not open my jpeg/jpg files. Please help.


What happens when you try to open them?

It won’t open jpg or png files from my iphone. Gives a file format not supported popup. Opens other jpeg files.

Dear Taylor

It just says not supported and pop a list of support files - which jpeg is (of course) supported. I roll back to v4.7 version.

Windows 10.

Thanks for getting back to me. Can you give me an example filename you tried it with? EG picture.jpeg

I would term this as "Application always crashes after closing images and adding new ones when Face Refinement is turned on.

Dear Taylor

My screen shot of the file (jpg) just seems to send over post as it says “pic can’t send over post”. I tried updating, restarting etc. and gave up. Back to v4.7.1 where all seems to work well with my pic files.

I wait for next update or till u advice me what to do. Thanks.

He asked for the file name, not the file itself. I assume he’s trying to determine if there is a naming problem.

I want to be able to completely turn off Supress Noise and Remove Blur like the older versions. How come I can’t set them to zero anymore? They cause bad color shifting on some low quality jpeg images, which didn’t happen with them turned off in previous versions.


jpeg & jpg are fine on windows @taylor.bishop … but seems to be an issue with previews from Samsung Motion Panorama JPGs

PC Details:

Application & Version: Topaz Gigapixel AI Version 4.8.1

Operating System: Windows 10 (10.0)
Graphics Hardware: GeForce GTX 1050/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 445.87
CPU RAM: 16269 MB
Video RAM: 4096 MB
Preview Limit: 5199 Pixels

Save after Calibration gives this crash error:

Faulting application name: Topaz Gigapixel AI.exe, version:, time stamp: 0x5eb43eb3
Faulting module name: impbase.dll, version:, time stamp: 0x5eb43dbd
Exception code: 0xc0000005
Fault offset: 0x0000000001bbd5d8
Faulting process id: 0x2de4
Faulting application start time: 0x01d624dc3b18e30e
Faulting application path: D:\Program Files\Topaz Labs LLC\Topaz Gigapixel AI\Topaz Gigapixel AI.exe
Faulting module path: D:\Program Files\Topaz Labs LLC\Topaz Gigapixel AI\impbase.dll

Calibration selects OpenVINO as the optimal processing method but the processing time for a .jpeg image 2400x1600 2x is as follows:

  • 3:27 mins OpenVINO, and
  • 1:16 mins GPU/Medium

Summary: Processing using OpenVINO takes nearly 3 times longer than GPU processing and, this is the only app (I think) that gets the calibration wrong in a big way. For example, Sharpen AI selects OpenVINO but processing the same image using OpenVINO is 12 seconds & 11 seconds for GPU. Then DeNoise AI selects OpenVINO also, takes 9 secs to process with OpenVINO and 10 secs for the GPU.

Processing/Save details:


Just tested the file name issue. The files load properly with lower case file name extensions. Apple apparently uses upper case extensions by default. Renaming the extensions to lower case allowed them to load.

Yes you are correct, on windows you get a message that it is an unsupported file type if there is a upper case extension … which, in the case of RAW images they are always upper-case so they wont open.


@taylor.bishop this looks like it is a problem, but it is an issue on windows also.

Currently pushing out a hotfix for this. Thanks for the response!

1 Like

Should be fixed now. Sorry for the frustration!

Do you mind PM’ing me your system specs? We’re currently investigating this and the issue seems to happen more frequently on certain machines.

Thanks for the detailed report Don! Will definitely start looking into this.

Custom scale (above 6x) still much worse than 6x. Is like 2x with conventional upscaling.

Edit: 4.8.2 released 2 hours ago and no changelog or mention in this forum…

Maybe half of unsigned (or full signed) 16-bit integer max value (32767, including 0, or 32768, starting from 1) is the max for “civilian” GPUs? Cause they mentioned something about 32k pixel count limit in one of the later changelogs. Otherwise Topaz would have to switch to single or double precision calculations, which would, on vast majority of GPUs, cripple the performance significantly? And that’s why, among other things, one can’t go with more than 6x magnification?
It’s just a speculation though. Cause when I select 7.3 magnification for example, I still get pretty nice JPEG artifacts cleanup. Which brings the question - maybe a little option for just that - cleaning up JPEG artifacts? Gigapixel EXCELS in that field. :slight_smile:

Example in CPU mode:

Example in GPU (GTX 1080) mode:

I let myself use info1845’s example image from Video Enhance AI’s section for that.

1 Like

What is the issue Paul?