Gigapixel AI for Video, not utilizing GPU

Hello,

For some reason my Gigapixel for Video trial software is not utilizing my GPU (Nvidia Geforce GTX 1060, 6GB). I have tried using the commands -gpu 0, -nvidia 0, etc. but to no avail. When I look at the task manager, CPU utilization is 80%+ and GPU utilization is 1% or 0%. When I use nvidia-smi command I see a similar result, 0%. The process videosrcmd.exe does not even show up as a process in the list of GPU processes. It takes about 4 seconds to process each frame of 640x480 SD video, which is another indicator to me that it is only utilizing the CPU.

Can anybody help with this? Any suggestions?

Thanks

If you have dual GPUs on your system this is a system setting either through NVIDIA control panel or via Graphics Settings if you are using windows 10.

If you only have a single GPU you need to press Reset in the advanced settings and GigaPixel will select the optimal processing on your system, GPU or GPU.

Thanks for the reply. There are no settings in the Gigapixel AI for Video, though. I think that’s in the Gigapixel AI (for images). Do these programs affect each other? Would the settings in Gigapixel AI affect the operation of the Gigapixel AI for Video software?

Sorry I was talking about GigaPixel AI, the GigaPixel AI for Video runs in the cloud and does not and will not access local resources on your PC.

Thanks for the reply, AiDon. I am actually referring to the Desktop Windows Beta software, available here: https://videoai.topazlabs.com/beta . This is installed on my PC and uses my PC’s resources. The guide states that it is run with command prompt and the command can explicitly select the GPU to be used. However, it does not use my computer’s GPU. It only uses my CPU. Can you help to troubleshoot this?

I believe that it will automatically switch based on the optimal processing, either GPU or CPU …

Should you wish someone to help just raise a support request at the main website but, bear in mind, it may have been deprecated because of the online version being available. Note also i haven’t seen any activity on the beta standalone since April 2019.

I think the best place to get an answer will be the Facebook page for it - I haven’t seen any activity relating to it in these forums, but the FB page is very active.

Any fix for this? I’m having the same problem.

1 Like

I am having the same problem as well, with the Video Enhance AI free trial. I am using a V100 GPU. The GPU appears in nvidia-smi, and it is selected in the drop-down menu under process. However, when I press go, it goes slowly, does not start a process on the GPU (seen via nvidia-semi), and says VRAM usage is 0/0 GB. Any idea what could be causing this?

The same problem happend on my laptop as well. My GPU is GTX860m and when I use “videosrcmd.exe “PATH” -s 2 -ad 0 -m 1 -gpu 0” to run the program , the utilization of CPU was almost 100% . At the same time, the GPU’s utilization was always 0% whether from task manger or nvidia-msi. And I have already set the “videosrcmd.exe” to “High-performance NVIDIA processor” mode in Nvidia Control Panel, but obviously it’s in vain.

I hope the developers can fix this problem soon or tell us why it does not work as we expected.

Thanks a lot

Unless things have changed recently, VEAI only supports the 10xx series and higher.

I almost gave up on VEAI as everything was processing on the CPU. My GPU (GTX 1070) wasn’t even showing up as an option. That is, until I updated the Nvidia Game Ready driver to latest. Works fine after I did that. Went from over one minute per frame to around 8 seconds per frame on FHD to UHD conversion.

1 Like

I think I fixed the issue by switching from Nvidia game driver to studio driver. Also, using the latest driver helps.

I think I fixed the issue by switching from Nvidia game driver to studio driver.