Gigapixel 7 Installed but not opening

There are some potential conflicts with this installation if you have previous versions installed. These were unavoidable due to the nature of the update.

Below you will find the steps to resolve this issue, however, it would be very helpful for our team if you could share your logs prior to performing the resolution steps.

You can gather the logs by following these

steps and uploading the logs to this DropBox

Submit File to Dropbox

  1. Delete the Topaz Gigapixel AI folder from the default installation path - *C:\Program Files\Topaz Labs LLC\Topaz Gigapixel AI*

Delete Registry Entries using the steps below:

  1. Open program RegEdit from your Start menu explorer and delete the registry entries of Gigapixel.HKEY_LOCAL_MACHINE\Software\Topaz Labs LLC\Topaz Gigapixel AI
  2. After you have done this, try opening Gigapixel 7 again.
  3. If that does not work, please reboot your machine and download a fresh installer for Gigapixel AI v7 from our Topaz Labs Download Page.

I had to uninstall 7.0.0, possibly because it did not appear to uninstall v 6…3.3. So after wasting a lot of time, as well as updating my nVidia Studio driver (so unclear whether it was a driver problem) I could not get the new version to run at all.

Never had this type of update problem (or if I did it was very, very rare). Now the program starts up, but at this time I no longer have time to actually run anything, so it will have to wait until tomorrow

Added some days later:

As others have experienced, the v 7.0.0 installed but refused to run. The v 6.3.3 uninstall was not in the menu contrary to expectations. When I found the uninstall file in the Gigapixel folder, and ran it, it failed to do anything. Therefore I used Revo Uninstaller, and I was asked if I wanted to keep the models folder (which I did). Once uninstall finished I installed v 7 again, and this time it started up.
The next day I was able to test it and it works fine.

If this version was properly BETA tested, this problem would have been noticed and fixed. Topaz update pricing has gotten much higher (no more $99 update for all the Ai programs (not including Video Ai) so it is especially disappointing to see such a clear failure in catching a huger error of this type with the public release of v 7.0.0

2 Likes

I just installed the update, but it won’t run on my Windows 11 PC. I’m having the same issue.

3 Likes

v6.3.3 worked fine for me but I had problems when I installed 7.0.0. Neither version would launch. Multiple tries, multiple uninstall/reinstalls/reboots etc. Finally got 7.0.0 to launch and I can’t say what I did different to make it work.

1 Like

I also could not install version 7.0 as it could not find the uninstalled file for 6.33. I went to the site and downloaded the install file, which happened to be an MSI version of the install program. I ran the MSI file, and when it asked me whether I wanted to continue or not (as it could not uninstall version 6.33 )I said “yes “and the install continued properly. Everything works now as it should.

Sometimes I ran into install issues back with Windows 7 and running an MSI version of the install program file seem to always work.

1 Like

I likewise installed v7.0.0, replacing v6.3.3 on a Windows 10 PC. It appears to have installed, but it will not launch. I have uninstalled and re-installed multiple times, making sure to wipe any trace of past versions from my PC including in the PC registry. My PC’s hardware meets the stated requirements, and I have the latest NVIDIA Drivers for my GeForce GTX960. I was running v6.3.3 just fine a week ago. I’m out of ideas and hoping this group has fresh ones.

2 Likes

I had exactly the same experience. Prior updates worked perfectly, but not this one.

1 Like

The v 6.3.3 uninstall was not in the menu, but I did find the file when I searched the appropriate folder, however running that file did not uninstall anything.

on Windows 10. installed 7.0 from inside the app version 6.1.0. it said it installed without a problem but now GP won’t start.

I’m still struggling with 7.0. Despite uninstalls and reinstalls and reboots, it still won’t launch. I am trying one last time and then I am deleting, asking for a refund of the upgrade price, and hoping I can reinstall 6.3.

Failed … so back to 6.3

Version 6.3.3 has been working fine. I too never got 7.0.0 to start even with new drivers and all. Uninstalled it and got the file called the 6.3.3 version from the Topaz site. Installed it and find that it installs 6.3.2 with no way to upgrade to 6.3.3. This is the first time I’ve had this sort of problem and have been a user of GP from the start. Not happy. Would appreciate some response from Topaz that addresses what appears to be a very common problem. TIA.

This is a known conflict for Gigapixel v7. We’ve found that following the steps below has solved this.

  1. Delete the Topaz Gigapixel AI folder from the default installation path - C:\Program Files\Topaz Labs LLC\Topaz Gigapixel AI
    Note: If you didn’t install Gigapixel AI in the default installation location, it will not be in the path above.

  2. Open the app Registry Editor on your machine and delete the Topaz Gigapixel AI folder from the registry below.

  • HKEY_LOCAL_MACHINE\Software\Topaz Labs LLC\Topaz Gigapixel AI
  1. Download a fresh installer for Gigapixel AI v7 from our Topaz Labs Download Page.

We do appreciate everyones patience as we roll out version 7.

Here is my commons sense suggestion:

For every upgrade from this time on, offer the option of keeping the current version (before an update) and install the update in an alternate folder. That way, people would not be without a working version.

Yes, I am aware of no longer having the same standard exact folder location. However, this used to be one with many Topaz programs, including VideoAi. To this day I still have a much older version of VideoAi, because until the very latest version, the prior upgrade had messed up the user interface so badly, I could barely contain my frustration with using it. Finally, the bracket, method was put back and now I find things usable once more.

This is constant problem with Topaz interfaces. Tested interface sections are suddenly taken out to be replaced by ones that are frustrating and unproven. There is no sufficient carry over from one, long term tested an well liked user interface to another. Case in point is PhotoAi, which has done away with batch processing which had been an important component of all the Topaz Ai programs. So things go backwards, and features that almost everyone uses, are just eliminated, which means years of beta testing done the drain, and user frustration.

The only reason I can possibly think of is that this is done to stretch out the length of time before vital, proven, features are put back in, hence increasing the likely hood of customers needing to keep upgrading annually in order to get back functionality that they badly miss. While I can understand this motivation, it is very bad for the company’s good reputation.

I really like Topaz, they have not only been technically super smart, but have treated customers very well. If you have followed them for the last 5 years you know they have done this perhaps too generously, and had to therefore at some point, reduce the generosity somewhat, in order to be profitable.

I’m still an enthusiastic customer, and I provide feedback, in order to improve the product interfaces for everyone, and to make Topaz superior to the competition. I want Topaz to be very profitable by simply being better than anyone else, because the products are easy to learn and easy to use, in addition to producing superior results.

Thanks for listening !

5 Likes

What exactly “is a known conflict for Gigapixel v7?”

It is a truly botched installation/rollout if you expect everyone who installed 7.0.0 to delete the Topaz Gigapixel AI folder and edit the registry. Is everyone who installs 7.0.0 affected?

Windows 10 shows both 6.1.0 and 7.0.0 installed. Why are you not recommending that I uninstall both via Windows uninstall, and then “Download a fresh installer for Gigapixel AI v7 from our Topaz Labs Download Page?”

1 Like

Gigapixel 7.0 installation is a total disaster !!!. Is Topaz Labs going Microsoft way and having the paying users debug their P.O.S software ???
Urgently Topaz Labs needs to release a clean installation of Gigapixel 7.0 for Windows 10 and extend of the license for which we paid and cannot use !!!

No not everyone and not many, just some of those who didn’t have v6.3.3 installed or kept multiple versions installed.

1 Like

Hi AiDon.

Thanks but I would appreciate an official reply from justin.topazlabs that answers all of my questions since I replied to his post.

I did not have multiple installations. I had only had 6.1.0 installed. I followed GP’s prompts to install the update from within 6.1.0. This has to be the standard installation scenario for all previous GP users.

3 Likes