Gigapixel 7.1.0 - 7.1.1


We’re excite to announce the release of Gigapixel 7.1.0 which contains some incredible updates for the application.

This release marks an important milestone for Gigapixel:

  • New Recovery diffusion-based upscaling model (Beta) for recovering images under 1MP by intelligently simulating new details. You will need 8GB+ of VRAM for this model.

  • New Text & Shapes model for images with hard edges, curves, shapes, and text in many languages

  • New Low Resolution v2 model (Beta) which excels at low resolution upscales across the board

  • Model Comparison View has been added to help you quickly compare models and find the best pick for your upscale. This view mode will continue to be supported in future updates.

  • New standardized Topaz UI framework, with updated colors and icons across all Topaz Labs app for a unified, streamlined look.

Please check out the detailed breakdown of new features in this Gigapixel progress post. That post also contains some tips, examples, and more information about future changes in Gigapixel which. Many more exciting things to come.

You can use the in-app updater to install the new version of Gigapixel. Optionally you could also download the installers directly from this thread. They should automatically uninstall previous versions of Gigapixel for you before installing the updated version.

Released April 12th, 2024
Mac: Download
Windows: Download

Change log:

  • Fixed visual issue where toggles would look on when they were off
  • Fixed wrong link being used for help article
  • Fixed uncommon permissions issue on Mac
  • Fixed being able to pull up file list while in comparison view
  • Fixed recovery warning always saying “small”
  • Fixed comparison view incorrectly keeping auto model flag enabled
  • Fixed various button hover states, spacing, and icon sizes
  • Fixed auto settings not re-applying when switching between models

Known issues:

  • Saving from Photoshop Automate plugin may incorrectly save PPI information

Released April 10th, 2024
Mac: Download
Windows: Download

Here’s a breakdown of what’s new in Gigapixel:

  • New “Recovery” Model (Beta): Recovery is a diffusion-based generative AI upscaling model, which produces different results than our other upscaling models. While this model is slower than the other upscaling models, the model performs very well when upscaling low-quality source images, for example images with low resolution or significant blur.

    The model also seems to perform well on faces, buildings/structures and other objects. The detail slider allows you to control the level of detail in the image after the initial render in post-processing. We have found that detail settings in the 50-75 range work well for most scenarios.

    The Recovery model also allows you to preview sections of an image by rendering small tiles before running a larger recovery, as some of those renders can be lengthy. You can also still render the entire image directly from the export panel if you desire. Note that the recovery preview will be a different generated image than the final result, so it will not blend. However, it should be quite representative of the quality of the final output.

    Please Note: We have plans to release significantly more performant and smaller versions over time – but you will need a powerful graphics card for this version of the model. We recommend upscaling images under 1000px by 1000px depending on the size of your graphics card. This model currently requires 8GB+ of VRAM. Renders with the Recovery model may take several minutes even on relatively small images at the moment.

    For Mac users: Recovery mode currently only works for Mac OS version 13 or higher

  • New Low Resolution v2 Model (Beta): The Low Resolution AI upscaling model has been upgraded into the 2nd generation family of models, performing well out of the box for both low resolution and high compression images. You will still have access to the Gen1 model as well, using the drop-down menu on the top right of the model selection panel

  • New “Text & Shapes” Model: We have added a new AI-upscaling model that enables more distinct patterns and shapes during upscaling with man-made objects or defined shapes such as cars or buildings, and even written text and fonts.

  • Comparison View: The beloved comparison view makes its return debut with its notable four quad design. We’ve cleaned up how the interface is used, showing exactly which image you’re working on. You can also now configure default settings for which AI models are used in the view and remember those settings for future use. We will continue to improve and support this view over time, and we have some more exciting updates in store for this one.

  • Crop Rotation: We have extended the Crop tool within Gigapixel, adding new capabilities into your workflow. Images can now be rotated to create perfect vertical or horizontal lines.

  • Face Selection: In previous versions of Gigapixel, face recovery sometimes recognizes faces incorrectly. We have now added Face Selection, which will allow you to see the number of faces detected and manually choose which faces should be recovered.

  • UI Changes: New colors and icons across all Topaz Labs apps for a unified, streamlined look. Photo AI, Gigapixel, and Video AI are all receiving a UI refresh to make them feel more cohesive, as many of our users own multiple different Topaz Labs applications.

Please also be prepared for a large download given the set of new models.


Dakota Wixom
Product Manager, Topaz Labs

Change log:

  • Refreshed UI
  • Added comparison view
  • Improved crop and added ability to rotate
  • Added face selection
  • Added Text and Shapes model
  • Added Low Resolution v2 model
  • Added Recovery model (diffusion-based)
  • Added camera profiles for Panasonic DC-G9M2 and Sony ILCE-6700

Thanks Dakota! I completely missed the beta, I was busy watching the previous release thread… I did not see an email.

Anyway, successful update in place from 7.0.5, M2 Mac Mini, Ventura.

First issue:

Where is the photo I just opened? It’s listed at the bottom. Can’t get it showing:

Tried a completely different random image, same issue:

Quit and relaunched, all good!

Before I started testing this caught my attention.

Please fix this extremely confusing bug with the privacy settings:

Default state:


Turn it off (and press save):


Go back to the setting:


Says it’s disabled, then why is the slider back ON again?

I would expect the screen to look like the second picture I posted where it says it’s off and slider is also OFF!

The current design is saying disabled…but ON!




Yeah and I can’t toggle it to off if I don’t click on Reset do default settings first for some reason

A problem that was added in the previous version of Photo AI was introduced here :confused :confused:


That’s a 300x300 image here.

Where is the 100%? Just when I was commenting about how Gigapixel was my go-to tool now, it got one of the problems of previous Photo AI, and made it unusable for me.

I don’t understand! - I don’t get it

80% of my work with Gigapixel AI is with images that are 640px by 640px or less, at 1x.
And for regular images, I very often only use 1x too.

I’m really disappointed. I mean, introducing a cool feature like Recovery or Text & Shape :

New “Recovery” Model (Beta): Recovery is a diffusion-based generative AI upscaling model, which produces different results than our other upscaling models. While this model is slower than the other upscaling models, the model performs very well when upscaling low-quality source images , for example images with low resolution or significant blur.

Used on a very low res image, and we can’t get a preview at 100%.

It took too long for Topaz to fix the zoom problem on Photo AI, and now it’s introduced again here, in the program I use daily.

We can’t even work full screen with the program because it will stretch the image so much. I’m on a 4k monitor, so I would have to have an image with a minimum width (of 3840px to have a correct preview for the 1x upscale.

The new model is very good, but we can’t even judge the results because of the zoom and jagged edges

I really hope this is going to be fixed before the 2 weeks mark for the next version.


Disappointing. Really disappointing. You still haven’t corrected the problem :rage:.
This has been going on since version 7.0.4. I systematically report the problem is still not corrected.
As a reminder, I have a 9th generation Intel I9 9900K. And I have built-in AVX and AVX2 instruction
So please correct that. I don’t know what language I should say it in :rofl:

1 Like

There are old Bugs back again:

DPI is incorrect

The Photoshop Plugin sometimes don’t bring back the processed Image to Photoshop!

1 Like

the dpi stored in the meta data will only be correct if your printing software will print the image according to the meta data. attached to the image it is just like a wish for christmas: “please print my image at the desired resolution”. but every year again, not all wishes become true. especially if the next application that opens the image might not care about the wishes you stored within the image. :frowning:

1 Like

Low res V2 is weird too.
It looks more fake than low res v1.

On top of that, for some images, it adds noise and weird color

And below that’s low res V1

Here the original


Low Res v2 - It adds weird shapes in the images.
This one is not that crazy in comparison of other personal image I tested with.
And it destroys all the details. Look at the floor.

And here the low res v1 - There is no comparison. The floor, or the tree outside in comparison of the V2.

The original

High fidelity vs V2 vs V1

High fidelity

low res v2

low res v1

The low res v1 keeps the general shapes way better than V2

And here the original


No it’s a Bug:

Original > 300dpi
GigaPixel Result > 1dpi

mh yes. don’t worry too much about it. you can easy calculate and verify if the image has the correct pixels size to be printed at the desired dpi resolution via my batch file:

dpi to (262 Bytes)


1 Like

Installation was flawless.

Windows 11 Home 64-bit (10.0, Build 22631) (22621.ni_release.220506-1250)
AMD Ryzen 7 5700G with Radeon Graphics (16 CPUs), ~3.8GHz
32768MB RAM
AMD Radeon RX 6600 XT
AMD Radeon Graphics Processor
Display Memory: 16543 MB
Driver File Version: 31.00.14052.7003 (English)

Ran a 600 X 516 image in recovery that took 5m 24s, the GPU had 100% utilization with the temp of the GPU reaching 71°C/170°F.

Other models ran well without maxing out resources and moderate GPU temp increases.


The ‘quick save’ button which is present in Photo AI would be nice to have in Gigapixel 7.1.0, too.

When using a custom aspect ratio in crop, changing the width moves both borders simultaneously. Same thing when cropping the height. Because the desired part of the image is usually not exactly in the middle, this behaviour makes it necessary to drag the cropped area to a correct position. After that it may be necessary to redifine the crop, and move the crop again. It would be better if every border of the crop area could be moved independently.


v7.05 has not been finished, At least three issues exist。7.1 has already arrived!
After testing the new models,I went back to v7.0.5 + v6.1
low v2 ,is not a good model,Recover Model likes Remove Tool in Photo AI ,too too slow,it is not useable for me. and other issues mentioned above .

Please contact support. This may be due to something like an antivirus deleting the file we use to check for AVX instructions and if we can’t check it defaults to not supported.

1 Like

Thanks for reporting this, we’ll likely be hotfixing this today. The text should be the actual state of the setting, but there is a visual bug where re-opening the panel does not show the correct state in the toggle.

It’s already fixed on our end, so we’re planning on adding a couple more fixes and then release a 7.1.1. Sorry about the bug.


Thank you. I contacted support earlier today. They helped me out by giving me the workaround of doing it on the command line. It’s pretty drastic but it worked. Now we’ll see with the next updates if I still have to do it from the command line or not. Because I must admit it’s a bit annoying to do it like that.

Such is life when you sail the high seas!

Yeah, I can confirm that v2 is very much needed. I tested it on an image made by AI and it looked very plastic. Much too smooth.
The skin details didn’t look at all natural compared to v1

1 Like

:joy: RIP. Indeed

1 Like