Gigapixel 7.0.5


This week’s patch fixes several issues, mostly involving file list selection. Further, some fixes were made to the export pop-up, including the addition of an alert upon export completion.

As a note, all pre-7.0.0 versions of Gigapixel will upgrade through 7.0.0. This means if you’re on 6.3.3, the in-app upgrade flow will take you to 7.0.0, and then you can see 7.0.5 from that version. You may optionally also download the installers directly from this thread. They should automatically uninstall Gigapixel 6 for you before installing the updated version.

Released March 27th, 2024
Mac: Download
Windows: Download

Change log:

  • Added an alert for export completion
  • Added error status for export failure due to missing output folder
  • Disabled some shortcuts while exporting images
  • Fixed current image closing instead of desired image when using right click menu on Mac
  • Fixed wrong file name being displayed on close image prompt
  • Fixed Ctrl+Click sometimes selecting multiple images in open file list
  • Fixed current image being set incorrectly upon closing previous current image
  • Fixed invert file selection not working
  • Fixed auto settings not being highlighted

v. 7.0.5


Upgraded and tested a couple of images, all went as designed without any errors.

Microsoft Windows 11 Home
Version: 10.0.22631 Build 22631
Processor: AMD Ryzen 7 5700G with Radeon Graphics, 3800 Mhz, 8 Core(s), 16 Logical Processor(s)
Physical Memory (RAM): 32.0 GB

Installed from the above link not from within the app. All seems to be working well.
Mac mini M1 16GB Sonoma 14.4.1

Hey, we think this was a caching issue. Can you try again?

No problem installing with the In-App Update here. (Win 11)

Win 11 Pro desktop PC. AMD RX6800 XT processor, Intel i9 12th gen. 64-bit. 64GB RAM. TB of memory. Ps processing prefs set to best, most efficient scratch disk and optimal recommended processing usage level.

GAI Rel. 7.0.5 installed in the usual fashion from the Win installer above with no issues.

I was able to launch, process, upscale test .jpg with no issues using the Standalone vers. I did not save b/c that’s not my usual workflow.

Also, able to launch, process, upscale same test low res .jpg using Ps 2024 File > Automate vers. Processed result saved back to Ps layer okay.

1- I still experience a lag of 25-30 secs. when I call GAI from my Ps layer. Nothing happens, no indicator that GAI is being called. It’s just ‘dead air’ until it kicks in. I wish it was a faster response time.

2- I still must actively click the “x” in the message box that’s generated by GAI after I click “Save to Ps” in order to get my image to scale & show the GAI-processed content. I wish this would just happen automatically like it used to with prior Topaz products w/out requiring my (or, any user’s) intervention.

Re-downloaded the file from the link above and tried re-installing, with the same result. Before it gets to to the fail point. Windows (10 Pro) initially balks at running the file at all, saying it is from an unknown publisher.

Overriding the error message (“Run anyway”), the installer then fails with the corrupt cab message. I can try it a third time, but the definition of insanity… :slight_smile:

Update: And on the third download, it worked, and the publisher is recognized as Topaz Labs. Maybe there’s something to insanity after all… Thanks for your help, Adam!

For users that have both 6.3.3 and 7.x.x, how would you rate the upscale image quality of one vs. the other?


For what type of image are you asking (Raw, jpg, tif, low res, photo, illustration, etc.)?

1 Like

It works, there have been no errors yet.
(MacOS Sonoma 14.4.1)

1 Like

The only difference is that 7.x.x has the newer Standard V2 and High Fidelity V2 models that produce slightly different results. The other six models are essentially the same.


I hope that the installation problem caused by the bug with the CPU AVX is corrected in this version. Because I don’t see this correction anywhere in the changelog.
For info, I had this problem when trying to install version 7.0.4
Knowing that my CPU is
I’ll test this new version and make my next comment. Positive if it works or negative if it’s still not fixed.

Well, you haven’t corrected the problem. That’s really annoying :neutral_face: :slightly_frowning_face:.
I do have a 9th-generation Intel i9. Don’t you support it anymore? I’m stuck on version 7.0.3. I can’t get the new features added since 7.0.4. I don’t know what you’ve done, but remedy that.

And I’m sure it’ll be exactly the same for the next Photo AI update, due for release in the near future. Since this problem is present on Gigapixel 7.04 Photo AI 2.4.1 and now Gigapixel 7.0.5. So I can expect the same thing on Photo AI 2.4.2, since it shares the same CPU compatibility source code. it bores me.

If you have a solution, I’d love to hear from you.

I am looking for a comparison in general, with any type of image you have seen a difference or improvement. In my case, version 6.3.3 no longer works for some reason, so I can’t test it myself.


The Photoshop Bug is back:
If the maximum Upscaling Factor is exceeded, then it goes back to Photoshop only with bicubic Interpolation (no AI Enhancement!) :thinking:
It must be rendered instead with the maximum Possible factor!

I’ll have to try it later for you. I only have one PC which means I’d have to uninstall 7.0.5, reinstall the older rel. to test with it then uninstall it and reinstall 7.0.5 to test same image. And, I’m in the middle of prepping a Ps tutorial for my YT channel.

If someone else has multiple computers and can try it more easily, that would be great. B/c it would rep a lot of gyrations and time for me, are you just curious or would it impact you making a purchase decision? If just nice to know for you vs buy/don’t buy, I might leave to someone else to “play”… :slight_smile:

Oh, don’t go to too much trouble, I’ll survive. :blush:

1 Like