Gigapixel 7.0.3


This week we have another patch for Gigapixel. This one includes a host of optimizations which should help larger batch workflows. We are also still in the process of optimizing other areas of the codebase so look forward to that in some of our upcoming releases.

As a note, all pre-7.0.0 versions of Gigapixel will upgrade through 7.0.0. This means if you’re on 6.3.3, the in-app upgrade flow will take you to 7.0.0, and then you can see 7.0.3 from that version. You may optionally also download the installers directly from this thread. They should automatically uninstall Gigapixel 6 for you before installing the updated version.

Released February 28th, 2024
Mac: Download
Windows: Download

Change log:

  • Optimized image loading and control editing flows
    • Should drastically speed up time and memory usage when loading images
    • Personal benchmark loading 20,000 images:
      • 7.0.2 - 38 minutes + crash, ~140GB memory usage
      • 7.0.3 - 10 seconds, 1.2GB after engine runs
  • Optimized memory allocations when compressing images
    • This can lead to drastically less CPU usage after processing
    • Personal benchmark compressing 11648x8736 image:
      • 7.0.2 - 25 seconds
      • 7.0.3 - ~500 milliseconds
  • Fixed save options not changing when using compression and quality sliders
  • Fixed zoom in hotkey working in crop mode
  • Fixed typing current slider value not working
  • Fixed fit zoom not working at specific resolutions + display scales

Installing through the application was seamless and my test images processed quickly and look good.

I will give it a pressure test when I have more time.


Before and after the update Gigapixel has bogged down to a crawl. It worked fine until a few days ago. It also changes the hues quite often.Very frustrating to have an efficient workflow.Ready to ditch it.

What part is slow? Maybe you can check your AI processor preferences. If it’s running on CPU it will be much slower. Change it to your most powerful device. If that’s not it, contact support and they can help.

I want you to bring this format back.


What’s the difference between Gigapixel and PhotoAI Upscale?

All versions of gigapixel doesn’t work with gpu titan black (select it in preferences do not give results). Drivers is updated(nvidia studio drivers not compatible with this card).

I use both and the short answer is : No, if you own Photo AI, you will have little to no value buying GigaPixel AI. they use the same AIs for Upscaling.

the Longer Answer is:
GigaPixel AI predominantly focused on Upscaling.
Photo AI in addition to its upscaling capabilities (same quality / results as GigaPixel on upscaling) also has other picture treatments you can run on your existing pictures, like denoising and sharpening and Object removal AI (remove an object from your photo).

Additional features Photo AI provides that GigaPixel lacks.


If your main job is to Upscale, then GigaPixel is the best cost effective tool for you (assuming you are not owning any Topaz Tool at the moment). If you looking for existing photo treatment in addition to upscaling capabilities, then Photo AI might be beneficial for you.
In your case since you already own Photo AI, I would not spend the extra money on a tool that you would hardly benefit from.

The only advantage I see that Giga Pixel AI has over Photo AI is, Upscaling large number of photos (Batch process). it has an easier UI for this type of task, than Photo AI.
I also noticed on my machine that Giga Pixel processes the pictures (Upscale) much faster then Photo AI. but I got an older computer (GTX 1080 Ti with an Older Ivy Bridge-E 4930k CPU), so this might not be a problem or any difference on newer machines.


looking forward trying it out

Gigapixel plugin still don’t work with XnView. And still I can not open GP from XnView, because GP “thinking” that is open as plugin and I don’t see option to save upscaling image.

There’s a thread on the suggestion page where you can add your vote to the request to bring it back: Add back the 4 image 'Comparison View' to Gigapixel AI 7


Hi there. Since this last update the zoom function doesn’t work correctly for me at all. Namely:

  • When opening image it automaticcaly opent to fit the screen, what is undesirable. I want to see the images at a size of 100%, but he programm fits any image to the screen zie. That is counterproductive in any way!

  • The keyboard shortcuts to select the zoom doesn’t work at all!

Please fix that, thanks!

Kind Regards

1 Like

Gigapixel does not have an XnView plugin available

Gigapixel have Adobe plugin. XnView is compatibly with Adobe plugins, of course if only plugin is written OK. Plugins Denoise, Sharpnes, TPAI works OK with XnView. GP not. The conclusions seem obvious.

Denoise, Sharpen and Photo AI use our PS filter plugins which Gigapixel does not have.
Gigapixel is not a filter in Photoshop because of the upscaling models so it’s accessed through a different plugin (Ps > File > Automate)

So just to clarify - I have best part of a year left of GPAI updates, is it likely I’ll get a multi-model view of how the assorted models work, like 6.x had, or did that get deleted for some reason along the way. Still using v6 in the meantime… alas…
(BTW did v7 get done for some particular customer and wasn’t really intended as a v6 upgrade? Denoise Ai and Sharpen Ai are EOL so why isn’t GPAI either dead or getting usefully updated?)

I tried version 7.0.3, strangely it doesn’t detect the compression required in the JPEG format, I set it to 85% the first photo remains heavy as requested the second and the others in the lineup become double or triple the weight, around 20 Mb per 8K photo. Every time I save a photo I have to move the compression slider and I can only save one photo at a time with that value, every time I load a photo I have to move it if I don’t do it the photos are of considerable weight. I tried uninstalling and reinstalling the program, but nothing, same problem.

I’m constantly experiencing crashes with this (and prev versions). Same thing with Photo AI. Nothing special, just trying a simple 2x or 4x upscale. Sometimes it works without issue, but changing something simple as what model it should do, or between 2x or 4x sometimes causes immediate crash. Is there a log or something I can send you?

On the Mac at least you can go under Help to see the log files.

Screenshot 2024-03-08 at 9.18.16 AM

Screenshot 2024-03-08 at 9.18.04 AM