Gigapixel 7.0.0

Hello!

I’m excited to announce the new major update for Gigapixel! This update features a massive amount of changes under the hood, including an updated AI engine which should be faster and compatible with newer GPUs compared to 6.3.3, a UI refresh across the entire app, and updates to the Standard and High Fidelity models.

For Standard and High Fidelity v2 are have changed the following:

  • For Standard we’ve improved the deblur consistency (blurry patch issue)
  • For High Fidelity we’ve improved the grain preserving consistency for low denoise/remove jpeg sliders
    • For use cases requiring keeping original noise/grain, select this model and tune down the two sliders.
  • For High Fidelity we’ve fixed the tile blending artifacts
  • For both models we’ve fixed the tile artifacts on Apple Silicon Mac’s Neural Engine
    • In Photo we have an option to turn off Neural Engine but it will slow down processing
  • For quality in general, the models should be more generative

Another big change on the UI involves how images are selected and how controls are shown for those selected images. You can now use shortcuts like Ctrl/Cmd + A to select all and Ctrl/Cmd + Shift + A to deselect all images in the file list. When multiple images are selected, the controls in the right panel will now show a mixed state if the values between the images differ. For instance, if you select 2 images where one has a slider value of 50 and the other has a slider value of 75, the slider will show a blank box and a new “mixed state” slider design to indicate that the current selections have different values. You can then move the slider to apply a new identical value to both of the selected images if you want.

Important notes:

  • All preferences will be reset when updating to this version! Make sure to re-check your preferences (and check out the new ones too).
  • It is expected that you will need to re-authenticate with the updated version on first launch.
  • On first run models that were updated will re-download automatically. On subsequent runs if we detect invalid models it should auto re-download them.
  • Mac: The new minimum OS version is 11.0 (Big Sur). Due to the way the old in-app updater works, you may be offered an update while not on Big Sur. Unfortunately we cannot fix this case automatically, but users who need to re-install 6.3.3 can find the installers in this thread.

There really are too many changes to get into the weeds with, so instead of an exhaustive change log I’ve pulled out a few points.

Major changes:

  • Updated AI engine which should allow better compatibility and faster processing
  • Added Standard and High Fidelity v2 models
    • These models will eventually replace v1 models in time. If you have quality issues, please let us know.
  • Refreshed the UI with new design and controls
  • Updated preferences with new options
    • Note: This will fully reset your preferences

Notable additions:

  • Added panning and pinch to zoom gestures in preview
  • Added updated RAW preview handling (should be closer to Photo AI)
  • Added ability to capture before/after in split and side by side views
  • Added ability to move the file list up and down via dragging
    • Note: There is a known issue where removing/adding images causes it to snap back to the default position
  • Changed logic for selections
  • Changed controls to show mixed states if multiple images with different values are selected

v7.0.0
Released January 17th, 2024
Mac: Download
Windows: Download

17 Likes

Anyone using the in-app updater remember that you cannot exit GigaPixel as that will stop the download, once the installer is downloaded the installer will close GigaPixel.

The wrong model is chosen where a low resolution and a very compressed image is loaded. This should choose Very Compressed instead chooses Low Resolution:

How do you install this program?

Both installers (the full installer above, and the in-app installer) fail because they cannot uninstall “Gigapixel AI 6.1.0.” I’m not running 6.1.0, I’m running 6.3.3 and there is no uninstall file. There’s a shortcut, but no uninstall.exe file; I’ve never messed with any of files in the program directory, so it was probably never there.

Without an uninstall file, Windows (10) won’t uninstall it either. Tried reinstalling 6.3.3 to see if that might restore the missing file. Nope, the program reinstalls normally, but there’s still no uninstall file.

So, the bottom line is that there’s no way to install 7.0 until the old version is uninstalled, and there’s no way to uninstall the old version. After waiting one week short of a year for an update, it’s quite frustrating.

2 Likes

can’t you uninstall using the Windows control panel ?

No, without an uninstall file available, Gigapixel isn’t even listed among the Control Panel’s programs.

1 Like

Downloaded but won’t install. Get the following error dialogs.

  1. Request to uninstall 6.3.3

uninstall 6.3.3

  1. Failure to find the uninstall program – I can’t find it either

can't find uninstall

  1. Statement that the uninstall won’t start.

failed to start

So I can’t install 7 until I can uninstall 6.3.3 which I can’t do since the uninstall file didn’t get installed. I tried reloading 6.3.3 over itself in hopes of getting the uninstall.exe file installed but that doesn’t. I need to get the uninstaller loaded. Any and all help greatly appreciated.

dave

3 Likes

With the automatic upgrade proccess the updated program didnt run at all.
Had to dowload the installation file manually, remove the updated installed program and re-install.
Messy.

Now:
The crop selector feels weird, it feels like a chore. The previous one was much more user-friendly.
And, where to disable the preview?

I’m having a slight difficulty… I’ve deleted GigAI from my Mac…and tried reinstalling it several times now…and it’s not installing the Plug-in Extra plugin… It fact, I don’t see where it’s installing the plugin file on my system. Any insight where I should look?

Same on my box. Not listed in the programs section of control panel.

1 Like

I haven’t had an issue on Win 11 but I don’t keep multiple copies installed …

You can try downloading a utility like Revo Uninstaller and use that to clean up the uninstalls.

Don, Does that mean you uninstalled 6.3.3 b4 installing 7? Vs. trying to overwrite the prior version with 7? (I used to always uninstall b4 installing new vers. and folks convinced me that wasn’t necessary, so I stopped doing that).

BTW, like others, I don’t have a GAI 6.3.3 listed in my control panel Programs List. Only a 6.3.2. Yet my app says I’m running 6.3.3. I think we need some direction from Topaz devs re: how to find and clear out 6.3.3 on all machines (mine is Win 11 Pro).

I only install with the installers on the prod rel forums, not in app.

it’s slower than the previous version, how could I fix it?

Try uninstalling v6.3.3 this way:

  • Delete the old gigapixel install folder. Usually C:\Program Files\Topaz Labs LLC\Topaz Gigapixel AI\ but could be different. The v7 installer will tell you where where it is if you’re having this issue.
  • Delete the HKEY_LOCAL_MACHINE\Software\Topaz Labs LLC\Topaz Gigapixel AI folder from the registry
4 Likes

See if you can uninstall v6.3.3 by deleting v6.3.3 folder first.

Usually C:\Program Files\Topaz Labs LLC\Topaz Gigapixel AI\ but could be different.

The v7 installer will tell you where where it is if you’re having this issue.

Then delete the HKEY_LOCAL_MACHINE\Software\Topaz Labs LLC\Topaz Gigapixel AI folder from the registry

2 Likes

Ditto. I see GAI 6.3.2 in my list. But what’s running on my Win 11 Pro is GAI 6.3.3

That worked… thank you!

1 Like

No I used the in-app install option, usually the issues where the uninstall exe is missing are caused by multiple installs.

1 Like

Wohoo!! Amazing! I’ve been checking for an update on every app launch recently. Thanks guys! Much appreciated.

3 Likes

Can someone who managed to install V7 shed some light on if the issue with face recovery not working on many NVidia graphics cards such as my 3080 TI has been fixed? It has been persistent for ages and though I addressed it multiple times I was not even considered worth a reply.