Extreme DeNoise Model Creates Boxes

[PhotoAI 3.0.1 and previous verions]:
When processing photos with very heavy noise and artifacts using the extreme denoise model selection, dark squares appear throughout the image. Im assuming the extreme denoise model uses a localized area technique where the algorithm looks at the general noise amount and applies denoise according to each specific local area. But for some reason, when using very heavy, noise-saturated images, these local areas physically show up and appear as boxes, even on the final output on the image:
Preview of original:

Download original full-res file here. Will be deleted soon. (Google Drive)


To reproduce, simply load an image with heavy noise, preferably with a dark background environment. If Auto-Apply hasn’t already done so, select the Extreme profile for Denoise. Keep in mind this cant be replicated with any image. I only notice it with certain ones, like my example I provided. No other Denoise profile causes this issue, only Extreme.

These artifacts usually occur due to overprocessing. Could you try using either the Denoise feature or the Sharpen feature in order to see if this artefact is still present in your edits?

I have removed Sharpen, as it isn’t the primary enhancement needed.
With Extreme Denoise model, even at the minimal slider amount, the boxes still appear:

Now, I would jump lower to the Strong Denoise model, but major artifacts appear around the moon and clouds, even at the strongest slider amount:

Introducing some Minor Deblur does help control the artifacts, but many are still present, and the clouds just look terrible, like they were oil painted:

Granted, this maybe a rare instance where overprocessing is needed, but unlike the Strong model, the Extreme model is the only one able to handle the splotchy-ness of the sky that’s present in the strong model, and make the clouds appear much more natural. The obvious downside? those boxes appear.

Could you try adjusting the Selection option in the Denoise feature and adjust the masking option to help with this?

It may be the case that you should set your Auto selection to None and work with the brushin order to receive the most optimal output.