Export does not remove _temp files on completion

V’s 3.3.10 and 3.4.0. When an Export (I’ve done Dione and Dione X2 only at this point) completes successfully, VEAI does not delete its _temp files. So you end up with TWO copies of everything: the final output, and a _temp copy of it. All Exports completed successfully (i.e. without an error message).

Nor are the _temp files deleted when you select Close all inputs in VEAI.

Nor are they deleted when you quit VEAI.

Just two short experiments left 4.5Gb of rubbish _temp files on my (expensive) NVMe source drive. This could get out of hand very quickly, and other than going to the folder where the Export lives, you wouldn’t know.


Confirmed. Also closing a video in the application does not free the file so I can still not delete it before the application is quit!

1 Like

@neil.francis-2548 Can you both post logs?

Here are my latest log files:
logsForSupport.tar.gz (1.7 MB)

1 Like

Thank you!

1 Like

The same on MacOS

Using latest Topaz VideoAI. Working on large file. Each time, VideoAI produces two files: one is the one I want; the other has the same name but “temp” in the filename. If I try to move that temp file to the trash or if I try to right-click on it, my desktop freezes.

Definitely not disks (using NVMEs with lots of space). You’re probably right about the Visualizer/Preview. It had this problem with a previous release of Topaz VideoAI. One strange thing I noticed is that when unselecting the “Include Live Preview for Exports” and restarting the program, that is selected again. Clicking “Save” doesn’t seem to stick.

Are the temp files lingering after the input file has been released or when the app is closed? If so, can you please share your logs and a screen recording?

Oftentimes it is easiest to share a screen recording for issues like this to quickly show me exactly what is happening. I use Loom for screen recordings since this is a free and easy to use app.

To gather logs, please select Help > Logging > Get Logs for Support and attach the zip file to your reply.

The temp files were lingering after the input file had been released and the app closed. This, however, is no longer the case after having deselected the “Include Live Preview for Exports.”

1 Like

Thanks for following up with me.

We do not expect to hold on to this temporary file after the export is done. We should be deleting it, and even if we do not, you should be able to manually delete it. Since you were unable to do so, this is abnormal and I would be curious if you could share a reproduction video?

If you don’t have Live Preview on, then the file isn’t created.

What happens with the temp file is strange. First, it is slightly larger (bytes) than the actual file that was generated. Second, if I right-click on the temp file, I get a revolving circle on the desktop (since that is where the temp file was located), and I cannot access any other files there. Third, if I just try to drag it to the trash can, it stays where it is–nothing happens. In the second and third cases, the situation remains that way for a very long time (better part of an hour); then, a Properties dialog box might appear (in the second case) or it disappears and the trash can indicates it has a file (third case). Right-clicking on the trash can and selecting Empty Recycling Bin initially causes nothing to happen, but after a long while (again, better part of an hour) a dialog box appears asking if I want to delete whatever is in there. Clicking yes then immediately deletes the temp file.

VERY ODD! Can you go ahead and share a screen recording and your logs from tvai?

Here (Mac studio M2 ultra, MacOS 14.0 Beta) the temp files are not deleted automatically as well - but I can do that without further problems manually.

Well, I don’t have that anymore. I recycled the program and the machine after that a couple of times. Then, I turned off the preview, and I haven’t had that problem anymore.

Of course you don’t have the problem if you disabled the preview - without preview there’s no double files created in the first place…

1 Like

drathjens, the freezing behavior you describe could be a wobble in your operating system that becomes evident via this VEAI bug. You can check this by creating an Export with Preview, which creates a _temp file. Then, QUIT VEAI altogether and THEN try to delete the _temp file. It should delete just fine. If not, try rebooting and THEN delete (reboot necessarily releases all file handles).

If this is the case, and your system locks up only when you HAVEN’T quit VEAI, then that is a wobbly OS symptom from trying to delete a file that has a (VEAI) lock on it. Proper OS behavior is to actually report that there’s a lock (e.g. “file is in use”), so you can’t delete the file.

this issue is not only realted to temp files. any file that was opened in video a. i. no matter if it has been closed in video a. i. the meantime can still not be deleted because it is marked as “still in use” by video a. i.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.