Error when attempting to export video

When I try to export a video, and after the model has downloaded, I get an error message, saying to upload the log here.

This only started happening when I installed the NVIDIA GeForce RTX 3060 graphics card, and has worked fine prior.

Log: (10.9 KB)
System profile: DxDiag.txt (99.2 KB)


When switching graphics cards it’s sometimes necessary to complete a full reinstall of the app so that the correct AI models are redownloaded:

How to Clear Your Topaz Labs Registry Entries (Windows)

I’ve uninstalled, cleared registry entries, then installed again.

Now when attempting an export, I get this error message:

  • Error message from AI engine: download failed.
  • Error message from AI engine: model failed. (10.2 KB)

Hi there, you do not have enough VRAM going into processing. Please free up VRAM and try again.

The AI engine error has been fixed, but the prior error has returned.

VRAM usage doesn’t seem to be full. The card has 12GB of VRAM. (10.2 KB)

Yes, your GPU has ~12GB total, however, if you are using other apps that use VRAM, you will be opening Topaz Video AI with less than the full amount of VRAM available. Each task you perform in TVAI will use more VRAM.

VRAM: 11.8447 GB Used VRAM: 0 GB Free VRAM: 5.67236 GB

I would try a clean install at this point;

  1. Uninstall Topaz Video AI

  2. Delete the AppData > Roaming Folders for Topaz Video AI
    As a note, this folder will be hidden. To view this file, select View > Show Hidden, and here is the path;
    C:\Users<username>\AppData\Roaming\ Topaz Labs LLC\ Topaz Video AI

  3. Delete Registry Entries using the steps below:
    Open program RegEdit from your Start menu explorer and delete the registry entries of Topaz Video AI

I. Computer\HKEY_CURRENT_USER\Software\Topaz Labs LLC\ Topaz Video AI

  1. Reboot Computer
  2. Reinstall

If you are still running into this error message, please reply back :slight_smile:

I’ve uninstalled Topaz Video AI, which seems to have already deleted the registry folder for it, because I didn’t see it in regedit.

I’ve deleted the folder from “Roaming” as well.

I’ve rebooted and reinstalled, but the error persists. (12.9 KB)

Can you please try a clean driver install and then choose All Gpus in Topaz Video AI?

I’ve done a clean driver install, but I don’t see an option for “All GPUs”. Should it be under “AI Processor”?
All it shows are “Auto”, “CPU”, and “NVIDIA GeForce RTX 3060”.

Also, the error still occurs.
I’ve also noticed that if I set the AI processor to CPU, as well as changing the encoder to a non-NVIDIA one, then no error occurs.
Having the CPU be used as the AI processor and/or encoder is not what I’m looking for though, as it’s slower.

EDIT: Updating Topaz Video AI from 3.2.8 to v3.2.9, and the driver from 535.98 to 536.09 has not fixed the error either. (44.3 KB)

Yes, this option should be found under AI Processor.

I am having out lead developer take a second look at the updated logs to see if there are any other steps to take. We may need to schedule a screen share to see what is going on here.

Can you make sure that NO other apps are running when you open Topaz Video AI?

Yes, I’ve made sure no other apps and possibly conflicting processes are running when I opened Topaz Video AI.

Additionally, outside of Topaz Video AI, I’ve tried NVIDIA’s Super Resolution using a video player compatible with it, and would only show a black screen when in use (with sometimes a freeze frame shown with quality 4, and a bit more with quality 1).
This has led me to believe the error in Topaz Video AI is because of an issue with the graphics card or driver, and not with the application itself.

Thank you for following up with me! It is not often that our team is stumped, something does seem to be amiss with the driver. When the app is being opened, over half of your VRAM is already being used and since you have confirmed that no other apps are open, I would contact Nvidia.

I’ve let NVIDIA know about the issue. Will report back here if there’s any fixes.

1 Like

After talking with NVIDIA support, they have suggested to try old versions of the graphics driver.
I’ve done so, and the old drivers did not fix the issue.

I’ve also been told this:

I request you to also contact Topaz Support and check if there any bugs for the issue’s you are experiencing, Topaz Video AI may have occasional bugs or glitches that can interfere with CUDA/TensorRT operations.

You can contact Topaz Ai support here:

Check with them and do let us know with the update.

Did you try the Studio driver v528.49, try that and see if it helps. My 3060 with the latest driver had issues with a couple of apps not just Topaz so I had to downgrade.

I have now tried studio driver v528.49, and has made no difference.
I have also updated to v3.3.0, which has made no difference either. (9.3 KB)

Thanks for taking so many steps in order to resolve this. I am sharing your latest update with our team and will get back to you asap

1 Like

What email do you own Topaz Video AI under? I am not able to find a purchase for this license under your forum email.

I do not have it purchased, as I’m using the free demo feature, which adds a watermark to the video.

1 Like