Error message unable to save changes for "Edit in Topaz Photo AI" when using MacBook photos

Error message unable to save changes for “Edit in Topaz Photo AI” when using MacBook photos

Steps to reproduce issue:

  1. click edit in Photos
  2. click …
  3. select edit in topaz photo ai
  4. edit image
  5. save to apple photos
    error message appears

Topaz Photo AI [v1.x.x] on [Windows/Mac]

This error is common - I think it’s due to the orientation of the image.

Landscape works, Portrait not.
So as a workaround you could first rotate the image then edit it in TPAI and only after saving the changes reverse the rotation.

@jo.vo is correct. We are working on a fix for this issue soon.

You can make any edit to the image or rotate the image in Apple Photos and it will save properly.

1 Like

I’m so so glad to see this being worked on, it’s by far my biggest frustration with Photo AI.

It should be solved by now.
Here this works in the latest version.

Could you try updating to the latest version and let me know if it’s working or not? We hadn’t changed anything but I heard a few reports of this getting fixed.

I’ve been using 2.0.4 and having the issue.

Thanks for letting me know, I’ll update my team.

That’s strange. Also that Topaz devs apparently did nothing and still the problem vanished here🤔

I had photos where I could get this failed to save message in 100% of the time that then suddenly did work.

Now, after your answer I tested again and: the problem is back. Most Portrait oriented photos can’t be saved in Apple Photos after editing in Topaz. Landscapes do work.

Oh, and I found outthat low res photos seem to always work, regardless of their orientation.

But why could I edit some photos in high resolution and portrait mode for a while and now not anymore? Really confusing :face_with_diagonal_mouth:

New interesting finding (which explains why it seemed to work temporarily):
If I edit any higher resolution image that is made in portrait orientation (mostly iPhone 11 and iPhone 14 photos) saving back to Apple Photos will always fail.

Landscape photos and low-res photos (e.g. 1600x1200) will always work.

BUT (and this is the new finding): if I crop the exact same image (that refused to work before) in Apple Photos before editing with Topaz it’ll correctly save back in Apple Photos - even if I only crop a bit. Maybe there is a resolution limit in image height up to which it works (width can’t be the issue, because landscape always works)?

Maybe this can help the devs in understanding and solving the issue @Lingyu

Here is a screen recording showing this (first failing to save back and then working after the image is cropped):
Bug_SavingBackToApplePhotos.mp4.zip (5.3 MB)

@Lingyu
After further testing it’s also NOT due to a maximum size as the exact same pattern can be seen with photos from my Sony alpha which are at 4000x6000 resolution and even a little cropping by few pixels is sufficient for the save back process to work.

I now found out that not only cropping, but any edit in Apple Photos before you select the Edit in TPAI option is enough and then you can successfully save the edits in TPAI back in Apple photos.
It’s really strange that this only happens with portrait oriented images, though.

Maybe this can help to isolate and solve the problem.

Any news about this issue?

I’m having the same issue. Can confirm it is happening on any portrait photo I have shot with my iPhone 14. Landscape photos are fine. Can confirm any small edit (crop or other adjustment) made in Photos before launching to Photo AI will allow it to save ok.

Hope this can be resolved soon as I have many photos that don’t require any editing in Apple Photos before going to Photo AI.

Just tried with latest version (2.1.4) and the issue still exists

Yes. But as it seems no one really cares anymore :roll_eyes:

Just bought and downloaded Photo AI. Using it with 14.2.1 as an Apple Photos plug in and the issue is still there.

This is still a problem. If i do a minor edit and press DONE and then EDIT and go to Topaz then the save to photos works without the error coming up.

I’ve just purchased Photos AI 2.3.1 and its disappointing that the bug has not been fixed - I found the solution in an earlier chat for v1 (namely the bug is only triggered when using a portrait photo, landscape is fine).

Can anyone from Topaz confirm it’s on the To Do list?

Many thanks

1 Like

Last update from Topaz was in Sep that they were working on a fix soon. But here we are 6 months later and still no fix even in the 2.4 major release. @Lingyu Any update on this?

1 Like