Downsizing stopped working in PhotoAI 1.3.3

Topaz PhotoAI 1.3.3 on Windows 11

Reducing photo size no longer works. The “reduced” image is the same size as the original.

Steps to reproduce issue:

  1. Open an image.
  2. In the output scale size, enter 0.5.
  3. Notice the indicated output size is 0.5 times the original size.
  4. Save the image.
  5. By examining the new image properties or by opening the new image in a viewer, notice the actual size is the same as the original image.

Additional, possibly relate problem: As before try to reduce the size of image to 0.25 by entering the new size in the size field (the scale field won’t allow two digits after the decimal point).
Notice that you can’t save the this smaller size.

Both of these features worked in v1.3.2.

Screen shot of PhotoAI with sample image attached.

upscaling with custom factor (e.g. 1.6) does not work for me. Fixed factors, width and height work fine.
Steps to reproduce issue:

  1. choose enhance resolution - standard
  2. field s input: factor 1.6 press return
  3. New image size will be calculated, but resolution remains in original state
  4. Preview doesn´t change either
  5. Hit save button will start the process, but only file size gets bigger and no upscaling happens

Topaz Photo AI [v1.3.3] on [Windows]

I could not reproduce the upscaling problem with a factor of 1.6, and Topaz support said they could not duplicate it either. Could you provide more information, like a screen shot showing all the PhotoAI settings?

Topaz support says the downscaling problem is fixed in a release scheduled to be out this week.

Hello and thanks for reporting this. The downscaling issue will be fixed in the v1.3.4 update releasing tomorrow.

I also could not reproduce the upscaling issue. Are you using it in stand alone or as a plugin?

V1.3.4 partially fixed the downscaling issue. I can get a scale factor of 0.5 or larger, but not smaller.

If I enter a scale factor less than 0.5, the value is rejected.
If I enter any pixel size that is at least half the original size, I get that size. Anything less than half the original size, the value is rejected.

I hope this limitation is a bug and not a feature. I don’t want to downscale twice to get 1/4 size, or 3 times to get 1/8 size.

Downscaling is currently limited to 0.5 at the lowest. Any lower than that and the quality will be poor.

What use case do you have for downscaling lower than 0.5? If there is a workflow we are preventing I’m curious to know so we can decide how to improve Topaz Photo AI. More detail is helpful for making that decision.

I have large-format images, like 10000x7500 pixels, that I would like to reduce to a more reasonable size for sharing and viewing. Half size is still quite large.

I’ve been having a separate conversation with Tim He. Here is what I sent him:

Right now, to get a reduction to 0.25 I have to scale by half, then scale that result by half. I ran some tests. Some images looked good after two reductions. In others, small artifacts introduced in reducing by half were amplified when reduced again. I would expect that a single pass reducing to 0.25 would look better than two successive reductions.


Test photo 1 included tile roofs. PhotoAI reduction to 0.5 added some small artifacts in the roofs. The second reduction made those artifacts much larger. I tried different enhancement parameters, but none yielded acceptable results.

Test photo 2 was the example I submitted earlier, two older women in a garden. It looked good reduced to 0.5, and still looked good reduced again.

My favorite image viewer is IrfanView. I used it to reduce both photos directly to 0.25. Photo 1 (with tile roofs) looked much better using IrfanView. But Photo 2 looked better with PhotoAI even with two-stage reduction. It should be better still with a single reduction to 0.25.

So here is my request for enhancement of PhotoAI:

Don’t enforce a limit on the amount of reduction. Include a warning that large reductions might produce poor results, and let the user decide whether the result is acceptable.

I added a task to our product backlog so we can discuss this change. The Enhance Resolution models were trained for upscaling, not downscaling, so we are not as confident about the downscaling results.

I will speak to my team and see if there are other reasons for this decision.

Gigapixel AI currently has a maximum downscaling of 0.2. Could you try using that and let me know if the downscaling results are acceptable? If it is, we can look into removing the cap for Topaz Photo AI as well.

We are enabled up to 0.2x downscaling in Topaz Photo AI in v1.3.5 and onwards. Please update to that version to downscale your images further when we release it on Thursday.

I tried my two sample test cases plus another one with GigapixelAI v6.3.3, reducing to 0.5 and 0.25. Test case 3 featured a car parked under some trees.
All 3 looked good reduced to 0.5. With PhotoAI, the tile roofs and the car had artifacts – jagged edges on the car, wobbly lines on the tile roofs.
Reduced to 0.25, all 3 looked OK but not great with Gipixel. Not exactly artifacts, but a little fuzzy. With PhotoAI, the 0.25 reductions were unacceptable, very wobbly lines on the roofs and on the edges of the car (outside edges, windows, etc).

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.