Denoise leaves huge artefacts behind in dusk sky. Lightroom Denoise works perfectly on the same image

I used Denoise to reduce the noise on a dusk image shot at ISO 6400. Denoise chose to use “strong” and a strength of 33. However parts of the sky had massive artefacts left behind and the image was completely unusable. Even with a strength of 100, artefacts were still left behind.

Lightroom’s Denoise however, does a perfect job on the very same image with no artefacts left behind at all. See attachments.

This is the image at strength 33

… and at strength 100

… and this is the same image that was processed with Lightroom’s Denoise at strength 80, which is the only usable image of the three.

Topaz Photo AI [v3.0.0] on [Windows]

I can see artefacts in the right hand side of the sky in your DNAI image.
Please upload your original raw file, so others can take a look at it and advise.

Thanks for the reply, here’s the raw image …

_DSC5497.dng (55.8 MB)

Please send me your system profile information so I can check if your computer hardware is up to date.

You can securely submit your files(s) to my Dropbox using the link below.

Please be sure to send me a note here to let me know you sent something.


Yes it must be machine specific. I ran your image and there were no artefacts. However, I am not sure why there is a colour cast on the preview (even on the popup save dialogue). When saved the colours are correct.

Is that Whitstable?

Thanks! Hmmmm very strange! I wonder why? I take it that you are using 3.0.0 ?

Yes, Whitstable at dusk :slight_smile:

Yes v3 on a Mac mini M1.
Oysters yay!

1 Like

Oysters indeed!

What Denoise AI model did you use? The autopilot suggested Strong for me and I got the artefacts whatever value I used for strength.

I just played around with the image a bit more and things were better with the Extreme AI model and I wondered if that’s what you used, or did you get these results with Strong?

I merely ran autopilot and RAW Denoise selected Normal with the settings as shown below.
(The colour cast puzzles me, as I have not seen it on images of mine!)

If you are on a Windows machine is your GPU driver up to date?

Here’s an image of mine taken in Whitstable. Again, there are no artefacts: this is an ARW raw file from a Sony camera. Test it yourself if you like.

Whitstable 19.ARW (24.2 MB)

In your first image, it does show its a tiff file you did edit, maybe thats the cause.

Very nice image!

I updated the AMD graphics driver 2 days ago, but with limited success. The previous one was only three months old anyway. However, the latest driver was crashing Lightroom whenever it needed to perform any GPU acceleration, so I uninstalled it and went back to the previous version. I have the artefact issue with both the old and the new driver.

I just tried out your Whitstable image in Topaz 3.0 and there are no issues. I actually had several other images from my own Whitstable shoot too that were taken at sunset where the sky had a yellow hue. Those images were fine. I only had the artefact issue with two images that had lower exposure and the sky was dark blue in colour. I also set the AI processor to CPU, so it didn’t use the graphics card at all and I still had the same problem.

Only two days ago, I ran a bunch of daytime images through Topaz, again with no issues. I’m just having this problem with those two low-light images from Whitstable.

Having said that, I think i’ve managed to work out why I have this problem and you don’t. You are opening the raw image directly from Topaz. I am processing the image from Lightroom. If I open my raw file directly from Topaz I don’t have any artefacts either.

These are the copy file options I use when calling Topaz from Lightroom. Calling Topaz from Lightroom is clearly giving different results than it does when Topaz opens the image itself as a raw file.


When I saw it was a TIF, I suspected a LR issue! I don’t use LR and there was no problem sending it form On1 PR, or using the standalone.
Hopefully the devs will use your original image when sorting out the manifold problems sending stuff from LR!

When i do denoising with any software i do use a folder as a cache, i do erase the dngs created afterwards, bc they are just to large and the tech ist fast evolving, so fast after a year you will denoise some images again.

I tried sRGB as the colour space against Lightroom’s recommendation and that was better, but not perfect even at 100% strength. There were still artefacts.

The issue therefore appears to be with Topaz processing a TIF file, which becomes very clear with darker, high ISO images.

I’ll wait to see what the Devs say.

Thanks for your help and keep eating the oysters :slight_smile:

Would you mind sending in some more information to get a better understanding of the problem you are having with this particular type of image? Please send the following information:

  1. The original image file.
  2. The processed image.
  3. A screenshot or description of the settings panel so I can see what adjustments were turned on.

You can securely submit your image(s) to my Dropbox link from the above comment and I hope you enjoy those oysters in the meantime :slight_smile:

Please be sure to send me a note to let me know you sent something.

Sorry for the delayed reply. The original image is in this thread, however, I will send the original and updated images to your Dropbox account. A screenshot of the settings panel is already in the first post of this thread.

I have just installed 3.01 and I can confirm that it does NOT fix the problem. Once again, here’s a screenshot of the preview before and after with the Denoise settings.

If I put the strength up to 100, it will get rid of most of the artefacts in the sky, however, it has a serious negative effect on the rest of the image.

I think I have to go back to an earlier version as 3.0.0 and 3.0.1 are absolutely not working for me right now.

Thanks for sending in that information. I have made a task for the team in order to investigate this further. I will be sure to reach back out to you once we have more information regarding this issue.

1 Like

Seems like its the Lightroom tiff problem.

Wenn denoising a tiff, its much more complicated for TPAI than denoising a raw.